Sign-in / Sign-up
Your question

IDE hard disk not getting detected in bios

Tags:
  • Hard Drives
  • SATA
  • BIOS
  • Storage
Last response: in Storage
January 13, 2011 7:37:13 AM

Hi Guys


Earlier i was using My 250gb Sata with my IDE 80gb without any problems but now My IDE hard disk is not getting detected after adding my new second Sata 500gb hard disk.

Any solutions ?

Thanks

More about : ide hard disk detected bios

a c 119 G Storage
January 13, 2011 1:45:58 PM

Verify that your IDE and power cables are firmly attached to the HDD and mobo (IDE). It is possible that something got jostled out of place when you installed the new HDD.
m
0
l
January 14, 2011 2:45:11 AM

Yes i have checked that cables are firmly attached, i also tried different jumper settings. Using the same cable my dvd writer is getting detected only the hard disk is not getting detected.

Thanks
m
0
l
Related resources
a c 463 G Storage
January 14, 2011 3:05:04 AM

Check that your jumper settings are correct. I assume you have both the 80 GB old HDD and your optical drive sharing one ribbon cable and IDE port on the mobo. You will need to check each of those device's case labels to be sure of setting the jumpers correctly - what works on one may not be the same on another. You MUST ensure that one of them is a Master, and the other is a Slave. Ideally the HDD should be Master, and the optical unit the Slave, but that is not always necessary.

Having set the jumpers on each device, you should plug the END (Black) connector of the ribbon cable into the Master device. The MIDDLE (Grey) connector should go to the Slave.

The possible exception to this is that you can set BOTH devices to the "CS" (Cable Select) option. Then the one on the END of the cable WILL be the Master, so try to make it the HDD.

If all that still does not solve the problem, check in your BIOS Setup screens and / or your mobo manual. Is there any indication that the BIOS has some overlap of ports, and you need to connect the second SATA drive to a specific port to avoid conflict with IDE devices? This is NOT common, but a few early BIOS's had odd restrictions.
m
0
l
January 16, 2011 5:01:00 AM

Thanks Paperdoc i tried what you said but it didn't work.

Anything else i can try ?


thanks
m
0
l
a c 463 G Storage
January 16, 2011 1:25:53 PM

Time to start a systematic search. First step might be to try to return to the last configuration that worked. I'm NOT talking about those prompts during start-up about restoring.... I mean, disconnect the new SATA HDD, both signal and power cords - you indicate that was the ONLY change made. See if it will start that way. If it does, you have to start looking for some odd conflict between the two drives.

I expect that may NOT solve the problem, and you'll be looking for other things. Next, try this (on the basis that the optical unit is working OK). Disconnect the optical drive, both power and ribbon cable. IF it was the Slave unit on the cable, no further change for now. But IF it was the Master, you will have to set the old 80GB unit to be Master, since it's the only device on the cable and port. Does that work? If not, try switching cables around so that the 80 GB HDD is fed power by the connector that used to go to the optical drive. ALSO move the middle connector of the IDE ribbon cable (used to go to optical drive) to the HDD, even though that is not the ideal way to connect a Master unit. What we're looking for here is a poor cable or connector.

You also could try to "fix" a possible dirty connection. At the end of the IDE ribbon cable that plugs into the mobo port, disconnect it and then re-connect it two or three times carefully. If there are any dirty pins making poor contact in there, this will scrub them clean.

Once you've tried these things, reorganize the cables and jumpers, if necessary, back to where they were. Any solution so far? A similar kind of test might be to disconnect the 80 GB HDD and use its end connector from the ribbon cable to connect to the optical unit, just to verify that the optical drive works that way. (You'd have to set the optical drive's jumpers temporarily to Master for this.) That would show the cable is OK.

If none of this solves the problem, the results may indicate that the 80 GB HDD itself has developed a fault. Can you remove it from your system and try to connect it in another machine to test whether it works there?

Let us know what you find.
m
0
l
March 5, 2011 4:12:09 PM

Hi there!,

I appreciate your way of explaining the stuff! hope you would've experienced such a disaster before ;) 
I'm also experiencing the similar problem with my SATA 250GB HDD, 80GB IDE HDD and the dvd writer after I upgraded my memory to 2GB from 1GB! I've tried all combinations suggested and one technical guy can imagine of!, but alas, nothing worked. it detects the SATA, detects the IDE primary, but never it detects the slave dvd writer. Both IDE 80GB and optical drive are connected using a single IDE Cable, coz, my MOBO has one one IDE port to connect :(  Now, if u make IDE80GB as primary it will detect that, and if it is optical drive, it detects that! I tried changing even the IDE cable itself. the surprising thing is that, it was working all these years until I touched it for RAM upgrade. I don't remember what combination it was working till then. Since I'm a technical support guy, you can think of all ways I would've tried of :) 
Any help / suggestion appreciated!
m
0
l
a c 463 G Storage
March 7, 2011 2:55:50 AM

Let me make sure I got this all correctly.

You have a mobo with one IDE port and are using one data cable to connect both an 80 GB IDE HDD and an optical drive to that port. You say that it all worked just fine before. However, since you installed extra RAM, the system behaves differently. Now it can detect the 80 GB HDD if its jumpers are set to Master, but it cannot detect the optical drive unit. If you disconnect the HDD and set the optical unit's jumpers to Master, it detects that unit OK.

Check these items.
1. Do you have good power connections (4-pin Molex connectors from the PSU) to BOTH IDE devices? If you swap them, does the system change its behavior?
2. Check the count of wires in the ribbon cable - should be 80. Just count across from one edge. When you get to 20, are you ¼ of the way across, or half way? (The only cable types are 80 or (old) 40 wires).
3. Is the ribbon cable installed correctly? It has three 40-pin connectors on it. The BLUE one must go to the mobo port. The BLACK one on the END must go to the Master device, and that should be the 80 GB HDD. The GREY one in the middle goes to the Slave device.
4. Re-check your jumper settings on each IDE device. For this, use the diagram on each of the devices - do not use the diagram on the HDD to set jumpers on the optical drive. Ensure the HDD is set to Master; check if your has different settings for Master alone and Master with Slave Present (some do, some don't). Ensure the optical unit is set to Slave.
5. How do you now the optical drive is not being detected? Are you basing that on screen messages as the POST proceeds, or are you looking into the BIOS Setup screens for the IDE devices? What are the messages?
m
0
l
June 12, 2016 12:51:52 AM

i have o problem like yours to i have 1tb hdd on sata and on ide i tryed 4 diferent optical devices and 10 diferent data cables and noneworked it wont detect cd/dvd rom neither in bios and device manager have all drivers downloaded and up to date what can i do my remaining solution is to try a sata opdtival device . if you have any solution please help . motherboard asus p5kc
m
0
l
a c 463 G Storage
June 12, 2016 10:11:29 AM

The mobo manual says it should detect any IDE devices automatically. Check these items:
1. The IDE device (optical drive) must have both power and data cables attached. Power is via a 4-pin Molex female (with 4 holes) connector from the PSU plugged into the male socket (with pins) on the back of the drive unit.
2. The ribbon data cable should have 80 wires in it, even though the connectors only have 40 holes in them. It has three connectors on it, normally - Blue on one end (MUST go to the mobo IDE port at the bottom edge), Black on the other end (MUST go to the Master device on this cable), and Grey in the middle (MUST go the Slave device IF you have one, or to nothing).
3. If the optical drive is the only item attached to the IDE ribbon cable, then it MUST be the Master device on that port. Set its jumpers according to the diagram on the optical unit itself so that it is a Master with no Slave. (Your post indicates that you do NOT have a second IDE device on this cable - correct?) Then the BLACK connector on the END of the IDE ribbon cable must plug into the optical drive. The Grey middle connector is not used. (Some IDE ribbon cables simply do not have the grey middle connector.)
4. IDE ribbon cable connectors each have one hole blocked off so that they only plug into the ports one way.

If everything is set this way, the mobo should detect the optical unit in BIOS - see manual Section 4.3.4 on p. 4-13. In the lower section of the screen where you can configure some things, set the TYPE to CDROM, the LBA Mode to Auto, Block Transfer to Auto, PIO Mode, DMA Mode and SMART Monitoring to Auto, and 32-bit Data Transfer to Enabled. Remember after changing any setting that you must SAVE and EXIT to make your setting permanent. See manual Section 4.8 on p. 4-37.

If the BIOS Setup screen cannot detect your IDE unit, you MIGHT try moving your SATA HDD to another SATA port just in case it is interfering with detecting the IDE device. IF you do that, you will need to adjust the Boot Device Priority - see manual Section 4.6.1 on p. 4-30. To do this will take two steps.:
(a) Disconnect the SATA drive's (smaller) data cable and reboot the machine into BIOS Setup and verify that no SATA device is detected. Go to the BIOS Boot Menu and set the boot device to the floppy drive or the IDE optical drive, and NO option to boot from a SATA drive. This will force the BIOS to forget any SATA records it had.
(b) Shut down and re-connect your SATA unit to the different port. Close up and boot into BIOS Setup. Verify that the SATA drive is detected now. Go to the BIOS Boot Menu and make sure you set the boot device to your SATA drive. Personally, I have my system set to use three possible units for booting, in this sequence:
Floppy drive (yes, I have one)
Optical drive
SATA HDD
That way IF I place a bootable disk in the floppy drive it will boot from that. IF I do not, but I do place a bootable CD in the optical drive, it will skip the floppy unit and boot from the optical drive. IF I place NO bootable disks in the first two units, the machine will check each in turn, find no disk, and skip on until it gets to the HDD and boot from there. The last option is the normal way. I only put a bootable disk (floppy or optical) in its drive when I am doing special things like using diagnostic utilities to fix a problem.
m
0
l