GA-EP45-UD3L Mobo, Dominator RAM & QX6850 cannot run DDR2-1066

I have a Gigabyte GA-EP45-UD3L P45 Socket 775 ATX Motherboard with a QX6850 - originally I had 2x 1gb Crucial pc2-8500 - wanted to upgrade so I went with 2x 2gb Dominator TWIN2X4096-8500C5DF

As soon as I got home and installed them, got random blue screens, boot loops - ran memtest found no errors - ran pc check and found that I would get random chaotic/microtopology errors depending on what sticks I had in what bank - I changed them to back to pc2-6400, ran test's no errors what so ever in 2 passes - I was hoping to utilize the full 1066mhz - I can't seem to get the overclock quite right keep getting BSOD's - although what is the most interesting is that the crucial memory required no BIO's adjustments but automatically runs at pc2-6400 - when I looked up dominator memory it is in fact on the approved memory list for my motherboard and the only 2gb stick really listed

Is there specific voltage adjustments I need to make to have the ram speed run on auto - I have already tried both 2.1v and 2.2v with no luck. :(

Being on the noob side, and please someone correct me, because my chip has a FSB of 1333 - I can only get the 800mhz memory speed using stock cpu speed?

This has been an absolute nightmare, your help is much appreciated!
4 answers Last reply
More about ep45 ud3l mobo dominator qx6850 ddr2 1066
  1. You may need to bump your memory controller voltage 1-3 steps above stock. Try fully clearing your BIOS and reset all your settings manually.
  2. Do a "Load Optimized Defaults" from the BIOS; it should pick up the advanced parameter set stored on the RAM itself, and set up the memory correctly; save, exit, reboot, and re-enter the BIOS; go to the "MB Intelligent Tweaker(M.I.T.)" page, cursor down to the ******** Mother Board Voltage Control ******** section, verify that "DRAM Voltage" is set to "2.100V"; and, at the same time, you might 'bump up' the "MCH Core" to "1.200V" - won't hurt anything, MCHs (northbridges) are designed to 'run hot' - and often contributes to stability with recalcitrant memory... Save, exit, reboot, and see whatcha get!
  3. I tried doing all of above, I appreciated the tips but I am still getting BSOD's - the most interesting thing about it - is after I updated to the latest bios - set optimized defaults - and it ran stable for a lot longer than any other config I had going - ran a stress test for 20+ mins and it was just fine, then while playing a game, bam another blue screen, repeated this process just to be sure it wasn't the game itself - I just don't get why this doesn't work right out of the box as is, it's listed as approved memory on Gigabyte's Website, exact model # and everything - I have found no FAQ's on it at all about setup. This is frustrating. Should I be looking to get another motherboard - I am still within return policy - the real solution I am aiming for is to find some memory that just works out of the box. I have a set of 4x 1gb pc-8500 Crucial Ballistix 2.0v - which works but I have read some bad reviews on their failure rates.

    Any further advice would be much appreciated!

    Getting things like this:

    Problem signature:
    Problem Event Name: BlueScreen
    OS Version: 6.0.6002.2.2.0.768.3
    Locale ID: 1033

    BCCode: a
    BCP1: 00AB40D4
    BCP2: 00000002
    BCP3: 00000000
    BCP4: 81E454E7
    OS Version: 6_0_6002
    Service Pack: 2_0
    Product: 768_1
  4. Hi, well I have got the same mother board and also a similar problem with the exception of the memmory, mine was a Corsair. At the end I replaced everything but the memory so, after taking a look at many forums and finding very few info, I got to the point of simply testing my computer running with only 1 memory. I think one of the modules was damaged even if the mem test was alrigth. Maybe soemthing is wrong with the Dual Channel technology.

    Anyway, I removed the defective mem moduloe. And I'm going to run some other tests and check the DC just to be sure..

    Hope this helps
Ask a new question

Read More

Gigabyte Motherboards