Sign in with
Sign up | Sign in
Your question

Hard drive not reading full partition

Last response: in Components
Share
August 22, 2009 1:10:18 AM

So, I have a PC that crashed - bad motherboard. Got a new one with processor and memory - all good.

I installed it and booted, hoping Windows XP would figure it out. No such luck - BSOD. I tried all day to fix it and decided to reformat it. This PC is for my dad, BTW.

So, he tells me that at some point he might like to go to Windows Vista. So, I figured that when I was reformatting it - I would do it with 2 partitions instead of 1 so he can add Vista later if so inclined (from my 70-620 they say that will work).

I boot from CD, delete my one partition of 250 GBs hoping to see 250 GB of unpartitioned space. Instead I see

Unknown Disk

(there is no disk in the drive)
Unknown Disk

(there is no disk in the drive)
131070 MB Disk 0 at Id 0 on bus 0 on atapi [MBR]
Unpartitioned space 131069 MB


Obviously, not what I was expecting. I tried making partitions, deleting them, nothing seems to get me back my 120GB I lost. I made a partition and installed Windows hoping to see the free space in the Disk utility in computer management - nothing. I can't understand where my 120 GB went.

I had an old 98 boot disk and so I booted from it and FDISKed it. Nothing. It has the same issue.

I unplugged the drive and plugged it into my mac and ran disk utility on it. I formatted it with MBR and made 2 paritions like I want and the mac sees the full size. I have 2 FAT volumes of 100 GB and 130 GB partitioned with MBR on my mac. I plug it into my windows machine and boot from CD expecting to see the same - and it still shows that 131070 MB partition. I tried formatting it with apples partition map and I still have the same problem.

I did get it to see the whole drive once - in my mac I made it MBR with 1 partition of free space. The windows installer read that, but as soon as I put a partition on it - it went back to 131070.

I'm sure I'm missing something easy here. Any ideas?

Thanks in advance!!!!!
August 22, 2009 1:23:06 AM

Sorry for the double post - but I might have done something good. so on the mac, I parition the drive with MBR and split it 50 / 50. I make both partitions FAT and drop a file in each one, just to make sure all is well.

I still got that 131070 thing, but under it is 2 partitions type FAT of equal size. I'm installing now, hopefully that did it.

Whats the deal here though. What did I do wrong?
m
0
l
!