Sign in with
Sign up | Sign in
Your question
Closed

Micro SD card wont format

Last response: in Storage
Share
January 14, 2011 4:28:04 PM

Hey guys,
So I have an 8gb SanDisk micro SD card I use in my Motorola Backlfip phone, yesterday when I was using the phone, taking pictures and stuff suddenly the phone went into infinite reboot, then once i removed the card the phone could be recovered. Then I connected the card to the computer to back up the files and format. But none of the files I made, i.e.the pictures that day were there. All the other files are there. But I can't format it on windows.I even tried using the official sd card software from the website. Neither worked, with the second claiming the disk was in write-protection mode,but none of the standard changing of preferences or flipping the switch on the adapter worked.
The files on the drive can't be deleted either. On ubuntu, I deleted all the files and formatted the drive, thinking i was successful i remounted, only to find that it was just as it was before.So what'sup, is the drive frozen in some state? Can this be fixed, it's very new, about 5 months old.

I've tried the card through multiple adapters and by putting it into the phone and connecting it to a computer. The problem persists, I tried to format through a few different phones and cameras with no luck...

More about : micro card wont format

a b G Storage
January 16, 2011 11:28:15 PM

To change the write-protection mode, right-click on it> properties> advanced>security> change the Write Permission to Allow.
If still no luck... the card might be fried for some reason, it's controller went bad; I would get another one, copy the files that I need from the old one, and take it from there.
Score
0
January 17, 2011 8:22:42 AM

Thanks I guess the card is dead, bummer though.
Score
0
Related resources
January 27, 2012 4:04:15 PM

shaunpattrik is completely right... thanks so much for the advice that was driving me crazy... for anyone that cant format with cmd prompt there are videos on youtube.... it is super easy THANKS AGAIN!!!
Score
0
January 28, 2012 10:23:35 AM

This topic has been closed by Mousemonkey
Score
0
!