Sign in with
Sign up | Sign in
Your question

Something's underclocking my CPU

Last response: in Overclocking
Share
March 27, 2011 2:17:34 AM

Can someone please help me out here, I'm at my wits end! Noticed something weird about my NP5135 with i7 640m today and it's bugging the crap out of me.

The multiplier stays at x14 ~ 1.9ghz max when it should be x21 ~ 2.8ghz. I think it is software related but I have no idea what is actually causing the problem.

I have not done any over/under clocking on this laptop.

The reason I think it's software related is that the multiplier correctly goes up to x21 ~ 2.8ghz as soon as I enter desktop on boot up, but quickly gets limited to x14 ~1.9ghz when windows finishes loading everything. I have tried to terminate processes one by one while running prime95 to see which one is limiting it but had no success.

Here's some screenshots of processes running. If more info is needed please give me a shout.

Specs:

i7 640m
4gig Ram
Windows 7 Home SP1
Geforce GT 425m

More about : underclocking cpu

March 27, 2011 3:57:30 AM

Don't the mobile chip's clock frequencies change on demand? and I think you can switch off that feature in the BIOS? (I could be completely wrong here)
m
0
l
March 27, 2011 3:59:47 AM

yea there's speedstepping but i'm talking about under full load so it should be going up to a potential maximum of ~3.4 ghz (2.8ghz + Turbo)
m
0
l
Related resources
March 27, 2011 8:44:10 AM

dont know much about core i7/i5s, I read somewhere turbo disables cores to get higher clocks, i cant confirm tho
m
0
l
a c 138 à CPUs
a c 241 K Overclocking
March 27, 2011 8:57:19 AM

Go bios and Disabled intel eist
m
0
l
a c 309 à CPUs
a c 121 K Overclocking
March 27, 2011 7:08:12 PM

That is normal operation. The cpu is being downclocked when there is nothing to do to conserve energy, a feature that is particularly useful on a laptop.
m
0
l
March 27, 2011 7:10:55 PM

The speed is limited under FULL LOAD RUNNING PRIME95, not due to speed stepping when idle.
m
0
l
a c 309 à CPUs
a c 121 K Overclocking
March 27, 2011 7:21:03 PM

mizteck said:
The speed is limited under FULL LOAD RUNNING PRIME95, not due to speed stepping when idle.


Oh...
In control panel/power options/change plan settings/change advanced power settings/processor power management/maximum processor state

check to see that you have 100%
m
0
l
March 27, 2011 7:26:51 PM

yea i'm already on a max (100%) CPU power profile, plugged in as well.
m
0
l
a c 309 à CPUs
a c 121 K Overclocking
March 27, 2011 7:38:15 PM

Do you possibly have a cpu cooling problem? A cpu will downclock to protect itself from heat.

I suggest you contact the laptop vendor and see if there might be a bios or other fix for your problem.
m
0
l
March 27, 2011 7:43:56 PM

not a cooling problem, the CPU maxes out at 60C and the fan doesn't even need to kick it up to max speed because the max speed is only 1.9ghz right now

Not a hardware or BIOS issue either because I can see for a brief stretch of time when I first enter desktop from boot that the CPU is indeed working properly at ~2.8ghz. So it's something that windows loads subsequently that causes this limit.
m
0
l
a c 309 à CPUs
a c 121 K Overclocking
March 27, 2011 7:48:12 PM

Can you try cancelling some of the tasks running, one by one, to see if you can find the culprit?
m
0
l
March 27, 2011 7:55:50 PM

yea I mentioned in the first post that I tried eliminating each task while running Prime95 to see if the speed goes up, but didn't work.
m
0
l
a c 309 à CPUs
a c 121 K Overclocking
March 27, 2011 10:42:56 PM

There should still be a bios issue, open an incident with the laptop vendor.
m
0
l
a c 125 à CPUs
a b K Overclocking
March 28, 2011 3:40:09 AM

Did SAGER by some chance have there own custom power settings on the system.

If you set max performance, its no different?

For the hell of it, run prime on a single thread and see if you get full speed plus turbo on one core.
m
0
l
March 28, 2011 12:56:53 PM

nah sager didn't have custom power settings. The issue is def not caused by power settings because it's already on max performance, with 100% power to CPU under advanced settings.
m
0
l
March 28, 2011 1:02:53 PM

Also, how do I set Prime95 to test one core only?
m
0
l
a c 125 à CPUs
a b K Overclocking
March 28, 2011 4:01:46 PM

when you run it, under torture test, there is a space where it says number of threads. setting that to 1 will make it run on a single core. I am just curious if there is something causing the down clock under full load or always

You have 2 cores and 4(2 per core) threads to deal with.

You can then use the task manager to assign the program to run on one core only under the affinity menu
m
0
l
March 28, 2011 4:27:16 PM

yea didn't change anything, still max out at 1.9ghz ~ x14
m
0
l
a c 125 à CPUs
a b K Overclocking
March 28, 2011 4:39:58 PM

ok, yeah, something is wrong. i core prime should get you all the way to max turbo.

are you running cpuz to check right, maybe see if tmonitor shows any different(i just shows all cores speeds, easy to read)

http://www.cpuid.com/softwares/tmonitor.html
m
0
l
March 28, 2011 5:38:03 PM

im using both coretemp and cpu-z, so I don't think it's a data reporting issue.
m
0
l
a c 309 à CPUs
a c 121 K Overclocking
March 28, 2011 6:00:45 PM

Have you updated all the drivers? Particularly the chipset and graphics drivers?
m
0
l
March 28, 2011 7:26:49 PM

they're as current as they can be from Sager, which doesn't say much because they're usually slow with updates. But it used to work fine @ 2.8ghz and 3.4 on turbo.

It still works for a brief moment upon entering desktop @ 2.8-3.4ghz
m
0
l
a c 309 à CPUs
a c 121 K Overclocking
March 28, 2011 8:06:42 PM

What changed between when it worked and now?

Can you do a system restore back to the time when it was working?
m
0
l
March 28, 2011 8:11:08 PM

that's the problem I can't be sure when it started screwing up.
m
0
l
!