Solved

External hard drive disconnects then reconnects periodically

I have a 1.4TB Seagate Free Agent external hard drive that will disconnect and then reconnect a few seconds later, and does this about every 20 or 30 minutes. Even when I'm not accessing the drive or using the computer it does this. I dual boot XP and Vista and it does this in both. My first thought was to try a different cable, but the problem persisted. However when I tried the drive with my laptop I had no problems whatsoever. Given the symptoms I'm gonna take a guess that it's a hardware problem, but more than that I have no idea.
7 answers Last reply Best Answer
More about external hard drive disconnects reconnects periodically
  1. PIZZA Man said:
    I have a 1.4TB Seagate Free Agent external hard drive that will disconnect and then reconnect a few seconds later, and does this about every 20 or 30 minutes. Even when I'm not accessing the drive or using the computer it does this. I dual boot XP and Vista and it does this in both. My first thought was to try a different cable, but the problem persisted. However when I tried the drive with my laptop I had no problems whatsoever. Given the symptoms I'm gonna take a guess that it's a hardware problem, but more than that I have no idea.


    Using Seatools or whatever software teh HD came with, check the sleep time.
  2. I have SeaTools, however i do not see sleep time. Could someone familiar with the software help?
  3. Can anyone help me or I am doomed to have the autoplay pop up every half hour?
  4. Does really nobody even have a guess? Do you think my USB ports are underpowered? How would I check to see if they were?
  5. Best answer
    PIZZA Man said:
    Does really nobody even have a guess? Do you think my USB ports are underpowered? How would I check to see if they were?


    PIZZA Man, I stumbled across your post looking for a similar answer (my external Seagate drive has been doing the same thing and driving me nuts). The previous poster's comment about sleep time got me thinking, so I went into Seagate Manager to play with the settings.

    Under "My Drives", "settings" button, I clicked on ""Adjust Power Settings"

    The options here appear to regulate the drive going into power saving mode. I can't confirm this is the root cause of the issue we are both experiencing, but it seems highly probable. I changed the power-saving mode frequency to "Never" and will keep an eye on it to see if it resolves the issue - you might want to try the same

    Hope this helps,
    James
  6. I'm not 100% certain, but I think that worked! It's been much longer than usual since it disconnects! When I was about to give up hope you came along and saved me. Thank you!
  7. Best answer selected by PIZZA Man.
Ask a new question

Read More

Hard Drives External Hard Drive Storage