Sign in with
Sign up | Sign in
Your question

Only one core working

Last response: in CPUs
Share
August 23, 2009 3:02:36 PM

I've been using an AMD Athlon X2 4000+ Dual core processor (2.1 GHz)
Recently, and I'm not sure when, one core stopped working.
CPUz only shows one core, so does Windows task manger.
I'm at my wits end, please help.

More about : core working

a b à CPUs
August 24, 2009 4:43:57 AM

go into msconfig and see if you can re enable it
August 24, 2009 5:04:25 AM

Go to System properties, in the advanced tab go to environment variables. Check the variable NUMBER_OF_PROCESSOR. If it is set to 1, edit it and set it to 2. Then restart the system.
Related resources
a b à CPUs
August 24, 2009 10:15:50 AM

did you upgrade from single core?
Anonymous
a b à CPUs
August 24, 2009 11:57:23 AM

I had a similar problem but it was with an Intel Core 2 Duo. It was a long time back now but the problem I recall was the fact that ACPI was not enabled in the BIOS. It all to do with the HAL (Hardware Abstraction Layer). If you are running Vista and you change the BIOS to enable ACPI and boot up you will then see miraculously both cores running. If you are running XP then it could be that you need to run some other software to fix the HAL or in the worst case re-instally XP after you set the BIOS to enable ACPI. Search on the internet for HAL if you want any more info as my experience was a long time back.

Good Luck.
August 31, 2009 12:43:25 AM

Quote:
I had a similar problem but it was with an Intel Core 2 Duo. It was a long time back now but the problem I recall was the fact that ACPI was not enabled in the BIOS. It all to do with the HAL (Hardware Abstraction Layer). If you are running Vista and you change the BIOS to enable ACPI and boot up you will then see miraculously both cores running. If you are running XP then it could be that you need to run some other software to fix the HAL or in the worst case re-instally XP after you set the BIOS to enable ACPI. Search on the internet for HAL if you want any more info as my experience was a long time back.

Good Luck.


I can't seem to find ACPI at all in my BIOS.

masterjaw said:
Go to System properties, in the advanced tab go to environment variables. Check the variable NUMBER_OF_PROCESSOR. If it is set to 1, edit it and set it to 2. Then restart the system.


I tried this, but once I restarted, it was set back to 1.
a b à CPUs
August 31, 2009 1:50:34 AM

go to processors on device manager and see if you get two processors
a b à CPUs
September 6, 2009 1:39:14 PM

Or try CPU-Z
February 16, 2010 12:15:45 PM

masterjaw said:
Go to System properties, in the advanced tab go to environment variables. Check the variable NUMBER_OF_PROCESSOR. If it is set to 1, edit it and set it to 2. Then restart the system.

!