Sign in with
Sign up | Sign in
Your question

Biostar ta790gx128m mother board

Tags:
  • Motherboards
  • Biostar
Last response: in Motherboards
Share
November 8, 2009 1:45:09 PM

I have a biostar ta790gx128m mother board I troubleshooted the on board leds the top one is lit the bottom one is out. The pc turns on and nothing els monitor will not power up stays at a blank screen. cannot get to bios at all I need some help trying to figgure out what is with this board. The leds report memory error I need some help on how to correct the issue.

More about : biostar ta790gx128m mother board

November 17, 2009 1:30:00 AM

How did you get it fixed after you swapped the mother board? I have read your previous threads at the end there is no replies how did you fix it.
m
0
l
Related resources
November 18, 2009 5:11:16 AM

This may be simple but can be easily overlooked.

- Are you sure you are reading the two LED lights correctly? For example, the top one lit and bottom one unlit indicates that the memory is off. But are you sure the top one is actually the top one? Or that it is memory that is the problem? IIRC, for Biostar, if one LED is not lit, it means (as you said, a memory error) but if the LED's are reversed (top unlit, bottom lit), it should be a VGA error, which would explain why your monitor is not booting up. And if it is a VGA error, is your video card plugged in correctly?

May sound simple, but it is a problem I had to resolve from a friend whose problem is identical to yours. Hope this helps, and if not, at least you eliminated one possibility!
m
0
l
November 18, 2009 1:18:20 PM

the top led is on and the bottom led in off which the manual states is a memory error I have done everything buy change the mother board itself .
m
0
l
November 19, 2009 12:02:20 AM

The motherboard was my main problem. My other problem was that the 1066 GSkill Ram i bought didnt work with my specific motherboard. With the new motherboard that wasnt faulty and the new RAM i bought from Best Buy it worked just fine.

That isnt to say that 1066 RAM doesnt work with the Biostar board. I found on some reviews from other people with same Motherboard, that the GSkill RAM i purchased didnt work with the board for some unexplained reason.

Have you tried any other RAM? It is possible your RAM is bad or not compatible.

Do you have a motherboard speaker? If so are you receiving a beep to indicate that it is Posting?
m
0
l
November 26, 2009 11:35:29 AM

I got everything fixed I changed the board and the ram. I went to crucial pc26400 ram and got a replacement board from biostar.
m
0
l
March 20, 2010 2:44:27 AM

The 1066 GSkill have 2.0 - 2.1 Volt
Biostar TA790GX128M default 1.8 Volt

- Reset bios (Clear CMOS)
- From Bios adjust manual used 1.9 - 2.0 Volt
m
0
l
!