Sign in with
Sign up | Sign in
Your question

BIOS not responding to DEL key on Logitech Illuminated Keyboard

Last response: in Systems
Share
May 20, 2009 11:28:33 PM

I have an Asus P6T Deluxe V2 motherboard, with a Logitech Illuminated USB keyboard.

The problem is, when the BIOS starts I press the DEL key to enter the BIOS but the BIOS doesn't respond, as if my keyboard hasn't been initialized. The keyboard works fine at any other time. I have the same problem with the F8 key at BIOS start, which I sometimes use to boot from my USB drive, pressing F8 fails to produce an action as well.

In Windows the keyboard works fine, it's just at BIOS start it fails. I tried a friend's cheap USB keyboard and his works fine, it's a Logitech 200 model. While I had it I updated my motherboard BIOS to version 0502 to see if there were any fixes for this type of problem, nothing, same problem exists.

Does anyone have any ideas? ...other than maintaining a cheap keyboard purely to boot my system from my USB drive or to enter the BIOS?

Thank you.
Anonymous
a b B Homebuilt system
March 24, 2010 11:09:23 PM

I had same problem try update ur BIOS. I have ASRock MB and there is new BIOS patch for Logitech Illuminated. Keyboard working in BIOS but still not with F8 key.
a b B Homebuilt system
March 25, 2010 12:11:43 AM

USB keyboards always pull this kind of stuff. PS/2 keyboards are needed for full control over preboot environments. I use that alot since I dual boot so if I end up with any worthless USB keyboards I just give them away.
Related resources
March 25, 2010 4:10:46 PM

Had this problem with my Logitech G15 so I just used an old PS/2 keyboard I had.
July 14, 2011 8:08:12 AM

Struggling with the same problem. Other than waiting for a proper BIOS update, I came up with a workaround which is to make your boot process fail due to supposed "fan problem". In my case, CPU fan is connected to secondary FAN socket, thus BIOS reports an error not seeing the fan in primary socket. This way, I get a chance to press F1 this time (which is working fine) to enter setup. Not too smooth solution, yet the only one I have so far - no PS/2 in ASUS P8Z68-V PRO.
July 27, 2011 8:40:24 AM

I was too quick in making an alarm. It appears waiting for newer BIOS is not needed. I took a chance and disabled false alarm notifications that were allowing me to enter BIOS via F1 key. And - surprisingly - did not loose a chance of entering BIOS at all :)  PC does accept my attempts to hit Delete key - it just has to be done at the very end of POST - right before OS load starts. Then, both - Delete and F8 keys (to choose boot device) work without a problem.
!