Sign in with
Sign up | Sign in
Your question
Solved

How do I change HDDs from IDe to ACHI without reinstalling Windows 7

Last response: in Motherboards
Share
November 12, 2009 5:21:23 PM

This is my fist build, and thankfully with the help of Tom's Hardware forums, it was successful. Everything worked fine except for the fact that I get this message every startup saying "SATA detected running in IDE do you want to change to ACHI?" I changed it and windows 7 didn't want to boot. I did a little research and then switched it back to IDE just to get the computer running again.

Is there any way of switching to ACHI without a fresh install of Windows 7?

FWIW I have a GIGABYTE GA-MA785GMT-UD2H AM3 AMD 785G HDMI Micro ATX AMD Motherboard.
November 12, 2009 5:24:10 PM

Also I downloaded the latest ACHI driver for the mobo via Gigabyte's website and it says that it needs to be installed pre-windows via F6.
m
0
l

Best solution

a b V Motherboard
November 12, 2009 5:26:43 PM

To resolve this issue, enable the AHCI driver in the registry before you change the SATA mode of the boot drive. To do this, follow these steps:

Exit all Windows-based programs.
Click Start, type regedit in the Start Search box, and then press ENTER.
If you receive the User Account Control dialog box, click Continue.
Locate and then click the following registry subkey:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Msahci
In the right pane, right-click Start in the Name column, and then click Modify.
In the Value data box, type 0, and then click OK.
On the File menu, click Exit to close Registry Editor.
Share
Related resources
November 12, 2009 5:51:35 PM

evongugg said:
To resolve this issue, enable the AHCI driver in the registry before you change the SATA mode of the boot drive. To do this, follow these steps:

Exit all Windows-based programs.
Click Start, type regedit in the Start Search box, and then press ENTER.
If you receive the User Account Control dialog box, click Continue.
Locate and then click the following registry subkey:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Msahci
In the right pane, right-click Start in the Name column, and then click Modify.
In the Value data box, type 0, and then click OK.
On the File menu, click Exit to close Registry Editor.


That was quick. Thanks evongugg, all my SATA components are now running in ACHI and Windows booted properly. Thanks again.
m
0
l
!