Sign in with
Sign up | Sign in
Your question
Solved

Razer Mamba - Lag issues

Last response: in Components
Share
August 27, 2009 11:07:53 PM

Hey Hey,

I finally caved in and splurged on a new mouse for myself and my partner. Just under $400 AUD later and I now have two Razer Mamba's. Excellent mouse, except for one glaring issue that I'm hoping someone can assist with:

OS - Windows 7 64bit (mine), Win XP 32bit (hers)
Latest drivers, etc.

With my pc, occasionally when I'm browsing the web or just looking through folders on the hard drive I experience what could only be explained as mouse lag. I have the polling rate at 1000, but occasionally the mouse cursor just lags out, affecting both the cursor movement and things like mouse wheel scrolling.
Being my first foray into wireless mice I'm not sure if I need to change some settings or whatnot.

The dock is about 10-20 cm away from the mouse, so distance isn't an issue.
Polling rate is 1000, sensitivity is at around 2100. The battery is fully charged and nothing different is running on my system when the lag occurs than what used to be running with my old wired mouse.
I've also tried disabling the Razer tray from starting then rebooting, thinking that it might be trying to send synapses info (onboard memory) to the PC at random intervals, but that hasn't helped at all.

More about : razer mamba lag issues

Anonymous
February 9, 2010 9:21:27 PM

I think i allso follow this, i got exactsame mouse, same OS ans same probs.. :-s
m
0
l
February 15, 2010 9:14:24 AM

If you both are experiencing the same problems with the same os(im assuming windows 7) then i would probably say its a driver issue.
m
0
l
Related resources
April 4, 2010 10:52:48 AM

Just wanted to update, still having the problems.

Updated firmware twice, upgraded/reinstalled PC drivers multiple times.
Both mice are doing it, hers was RMA'd a while back.
m
0
l
June 14, 2010 10:55:53 PM

it is youre mouse pad there is the prb
m
0
l
June 15, 2010 8:32:13 AM

evedk said:
it is youre mouse pad there is the prb

Ouch my brain.

And no, it's an issue with the mouse not the mouse pad.
m
0
l
June 15, 2010 9:39:47 AM

arael said:
Hey Hey,

I finally caved in and splurged on a new mouse for myself and my partner. Just under $400 AUD later and I now have two Razer Mamba's. Excellent mouse, except for one glaring issue that I'm hoping someone can assist with:

OS - Windows 7 64bit (mine), Win XP 32bit (hers)
Latest drivers, etc.

With my pc, occasionally when I'm browsing the web or just looking through folders on the hard drive I experience what could only be explained as mouse lag. I have the polling rate at 1000, but occasionally the mouse cursor just lags out, affecting both the cursor movement and things like mouse wheel scrolling.
Being my first foray into wireless mice I'm not sure if I need to change some settings or whatnot.

The dock is about 10-20 cm away from the mouse, so distance isn't an issue.
Polling rate is 1000, sensitivity is at around 2100. The battery is fully charged and nothing different is running on my system when the lag occurs than what used to be running with my old wired mouse.
I've also tried disabling the Razer tray from starting then rebooting, thinking that it might be trying to send synapses info (onboard memory) to the PC at random intervals, but that hasn't helped at all.


Omg, it seems as if these Razer products fail..
I just posted a forums about my Razer lycosa keyboard lagging terribly while typing, gaming, and everything.. Its your mouse and my keyboard.. ):
m
0
l

Best solution

April 3, 2011 3:23:48 AM

Yea I just got my mamba a few days ago and have the exact same problem with the same os. I've found the best way to fix it is just to use the mouse with the usb cable plugged straight into it. It seems to be a wireless problem. I've tried both at 500mhz and 1000mhz polling rates and the problem remains.
Share
May 11, 2011 5:52:13 AM

Best answer selected by arael.
m
0
l
!