Sign in with
Sign up | Sign in
Your question

Memtest86+ results (40 passes, only errors on 3 of them)

Last response: in Memory
Share
November 13, 2009 4:50:16 PM

Hello. I built a new computer about 2 weeks ago with

- Asus P5QC motherboard
- Intel Core 2 Quad Q9550
- 2x 2GB 1333 DDR3 (Kingston ValueRAM)
- Asus NVidia GeForce 9800GT 1GB (Asus modelname is EN9800GT 1G)
- 600W PSU
- 2x 200 GB old SATA drives on RAID0

Installed Windows 7 x64 Pro Retail. Everything works perfect, all RAM is detected, 3D acceleration works, etc... But suddenly the whole thing freezes. I'm fed up, I can't find what's wrong, so I ran memtest86+ for quite some time. Results are... well... weird.

I get errors only on 3 passes out of 40. Really, what I got was 1 error, actually 8 in a row, on 1st pass. I stopped the scan, set the memory limits to somewhere around that error (2600M to 2700M) and kept it running. It showed up another 2 "batches" of errors but on completely different locations (inside the 2600M-2700M range). Only the 1st byte out of the 4-byte piece is wrong (and totally random, as the error mask follows no pattern).

Can this be bad RAM or (as I suspect) a bad memory controller (and so, a bad NB)?

Now I've tried turning off memory remapping on BIOS, which leaves me with 3328 MB instead of the original 4096 MB. Hasn't hung yet, but it could happen any minute (my system seems to run for 7 hours straight without crashing and then crash 4 times in 3 hours).

If you need any more information I'll be glad to supply it.
a c 80 } Memory
a b Ĉ ASUS
November 14, 2009 11:57:33 AM

Have you tried running it with DDR2 memory? That motherboard might not be the most stable when using DDR3 memory.
November 14, 2009 1:42:10 PM

GhislainG said:
Have you tried running it with DDR2 memory? That motherboard might not be the most stable when using DDR3 memory.


What would that do? Proove the problem is either the motherboard or the DDR3 memory? I already know that. And no, I don't want to run it with DDR2 as I paid for a motherboard capable of running DDR3 memory...
a c 80 } Memory
a b Ĉ ASUS
November 14, 2009 3:43:24 PM

I get your point, but motherboards that only support DDR2 or DDR3 often are less picky with memory modules.

You could increase the north bridge and/or RAM voltage a bit or run the memory at 1066 MHz instead of 1333 MHz.
November 14, 2009 4:26:28 PM

Yeah... there are a lot of "possible fixes", the problem is that... well, I never know if it's fixed or not. So changing something and waiting to see if it happens again is unreliable and a pain in the ass.

For example, I thought it could be due to a bad PSU so I changed it. Everything went smooth for around 8 hours, and right when I thought it was fixed then bam, there it goes again.

Right now I'm running with only one of the DDR3 modules for almost a day and no crashes (haven't ran memtest86+ yet). Of course, this is only for the sake of testing and finding out if maybe it's my RAMs fault.
!