Sign in with
Sign up | Sign in
Your question

Ga-ma78g-ds3hp rev 2 running x4 on pci express slot on a 5850

Last response: in Motherboards
Share
November 14, 2009 3:31:02 AM



The card is in the proper slot for x16 but is running at x4 limiting performance.
a b V Motherboard
November 14, 2009 6:42:30 AM

Check power input to card, maybe a bad ground, if you have a second pic-e connector try it.
Also remove any other Pci-x devices if you have any until remedied.
You do have enough watts available on your power supply right?
Shouldn't be an issue but check bios to make sure Peg is selected for video and the IGP is disabled. It should disable automatically with the discrete card in but check.
m
0
l
a c 177 V Motherboard
November 14, 2009 4:14:42 PM

The relevant settings are on the "Advanced BIOS Features" page of your BIOS:

"Internal Graphics Mode" to "Disabled"
"UMA Frame Buffer Size" to "Auto"
"Surround View" to "Disabled"
"Onboard VGA output connect" ...doesn't matter...
"Init Display First" to "PEG"

and, while you're there...
"Away Mode" to "Disabled" - causes weird bug in win 7...
m
0
l
Related resources
November 14, 2009 8:01:19 PM

I just upgraded my power supply thinking that it was the problem. Still 4x however, although last night I kept getting lock ups where the mouse cursor first appears with the new psu it worked first time. I will go into the bios and double check all of those things, I know I tried the peg setting.
m
0
l
a b V Motherboard
November 15, 2009 1:50:04 PM

I can find no logic in what's happening since you seem to have good power. There are enough pci-express lanes to run a single discrete card at by x16. Again nothing hooked to seconday ports usb or pci right. As the next thing I would pull the video card and examine the slot with a magnifier for any debree left from manufacturing. Also exam the contacts on card for anything similar. After reinstalling use optimal defaults in bios reboot and follow billbat's description. Doesn't seem reasonable to be a driver issue as the by x16 should work with default windows drivers or Catalyst when your measuring with GPU-Z. Actually out of curiosity try running CPU-z as that also displays the link width just to see if it agrees with sister program.
m
0
l
November 17, 2009 2:56:19 AM

I swapped out the mobo and everything seems to be running nicely now.


A third (I have tried the 5850 a 4850 and a 4670) card in the gigabyte board says that it is running at 4x on the pci slot as well. I haven't heard from gigabyte as of yet. At least the 5850 is up and running well.
m
0
l
!