Sign in with
Sign up | Sign in
Your question

Games running Choppy

Tags:
  • Radeon
  • Graphics
Last response: in Graphics & Displays
Share
June 14, 2009 10:10:09 PM

Hello,

I recently purchased an upgrade for my outdated system that Tom's Hardware had an article on, the Gigabyte ATI Radeon HD 4650 1GB GDDR2. Please keep in mind that this is an AGP card.

First I will give you the stats:

MOBO: DFI 875P-T (Phoenix Award BIOS never updated since purchase) with an upgraded bios chip to support my processor
CPU: Pentium 4 3.2 GHz.
Memory: 2GB
HD: 320 Gb Seagate Baracuda 7200 RPM 3.0Gb/Sec xfer speed
GPU: Gigabyte ATI Radeon HD 4650 1GB GDDR2 (GV-R465D2-1GI)


I was running the Radeon x900 xt platinum edition previous to my upgrade. If you need me to fetch further specs, I can do so.

Anyhow I opened up my case, dusted it out (esp around the AGP slot), took out the x900xt, dusted again, and installed the 4650. I made sure the power cords where also plugged in. I updated to the most recent drivers (still the ones on the CD) and fired up the infamous WoW. I did not change my video settings from what they were with my last GPU. The game runs choppy as hell. GPU LAG EVERYWHERE!!! Given that this is an old system I am not sure if I needed to do anything beyond installing the card and updating the drivers. I am running all the ATI utilities as well. I havent tweaked anything.

Anyone have any idea what is going on? This card should leave my old card in the dust. Obviously it isn't going be able to play GWAR on max settings, but I just want to play WoW and Titan Quest on normal settings!!!


More about : games running choppy

June 15, 2009 12:51:18 AM

Try driver cleaner then reinstall drivers, if that doesn't work reinstall windows?
June 15, 2009 1:05:57 AM

daship said:
Dum ass


I have already reported this issue to the mods. Recently there have been several dual / triple / quad posts, usually dual posts followed by another set of dual posts with slightly different topics. It must be a website issue, as three or four posters could not all be this inconsiderate.
Related resources
June 15, 2009 1:06:52 AM

daship said:
Dum ass


I have already reported this issue to the mods. Recently there have been several dual / triple / quad posts, usually dual posts followed by another set of dual posts with slightly different topics. It must be a website issue, as three or four posters could not all be this inconsiderate.
June 15, 2009 1:07:11 AM

daship said:
Dum ass


I have already reported this issue to the mods. Recently there have been several dual / triple / quad posts, usually dual posts followed by another set of dual posts with slightly different topics. It must be a website issue, as three or four posters could not all be this inconsiderate.
June 15, 2009 1:22:10 AM

...And it's getting worse....
!