Sign in with
Sign up | Sign in
Your question
Solved

Core i7 Turbo "always on"

Last response: in CPUs
Share
August 30, 2009 3:31:29 PM

In my flaming blade GTI bios i have the option to turn Turbo mode Off/On/Always on. I believe "always on" means that all cores will be on x21?

With always on feature CPU-Z reports all cores on x21. The problem is it always on x21 and doesnt show any signs of EIST (speed step) working.

At the same time i use RealTemp it shows my multiplier fluctuating up and down showing EIST is working.

Which program is reporting the correct current cpu multiplier and clock speed?

More about : core turbo

a b à CPUs
August 30, 2009 3:37:32 PM

turbo is just the cpu overclocking itself when needed always on will allow it so the cpu will jus step up by itself , off is usually for overclocking if you cpu runs stable @eg 4ghz you dont want the stepup to work cuz it will crash when it turbo's
August 30, 2009 3:46:05 PM

what im saying is CPU-Z its currently showing me my cpu is running at x21 x133 @ 2807mhz constantly. (speed step not working)

Where as RealTemp is showing my the cpu us running at x16 to x21 x133 @ 2138mhz - 2807mhz. (speed step working)

which one is showing the correct info?
Related resources
a b à CPUs
August 30, 2009 11:25:36 PM

CPU-Z is almost definitely correct.
August 31, 2009 12:51:56 PM

If your running version 1.48 or newer, CPU-z is your best bet.
August 31, 2009 2:58:40 PM

i dont get it tho, im using cpu z 1.52.2 its currently showing me that im always on x21 multiplier on my 920 D0 @ 0% cpu load

Every other program is showing me im on x20 multiplier (even bios)

i still dont think cpu z is reporting correctly
a b à CPUs
August 31, 2009 4:51:28 PM

I think it is. If you have it set so that turbo is "always on", it should sit at 21x all the time. Try setting turbo to "on" instead, and I bet CPU-Z will show speedstep as working.
September 1, 2009 6:19:51 AM

Cpu-Z reports the following;

Turbo OFF : x20
Turbo On : x21
Turbo Always on : x21

Few weeks ago it used to report with Turbo on, x20 multiplier and when i load something it would boost up to x21 or x22. But now its constantly on x21 not moving at all.... gettting so frustrated :( 

Best solution

a b à CPUs
September 19, 2009 8:31:40 PM
Share

CPU-Z is not very accurate at reporting the multiplier, especially at idle.

i7 Turbo can accurately report the multiplier for each thread in real time using the method that Intel recommends in their November 2008 Turbo White Paper.

Here's the latest RealTemp beta download which includes the i7 Turbo program.

http://www.fileden.com/files/2008/3/3/1794507/RealTempB...

If you are using Vista or Windows 7, remember to go into the Control Panel -> Power Options and set your Minimum processor state appropriately since this also controls the multiplier you'll end up with at idle.

When all of your power features are not in agreement, you can end up at idle with a multiplier that cycles up and down continuously on a Core i7 920 between 12 and 21. i7 Turbo will report the average multiplier when this is happening.

If you enable C3/C6 and are not overclocking then the multiplier can cycle between 21 and 22 when running single threaded applications. CPU-Z won't show this correctly because it samples your multiplier once per second while the multiplier can be changing internally hundreds of times a second based on load. The less load you have, the more time your active core can use the 22X multiplier. Some single threaded apps can run 75% of the time with the 22X multiplier. i7 Turbo would report the multiplier for the core working the hardest as 21.750. The other 3 cores need to go to sleep in the C3/C6 sleep state for this to happen.

The Intel X58 board is one of the few that properly supports this feature even when overclocking the BCLK. Most don't.

Quote:
CPU-Z is almost definitely correct.


Too many people blindly believing stuff like that is the reason why this issue never gets fixed.
January 18, 2010 1:03:03 PM

unclewebb said:
...

If you are using Vista or Windows 7, remember to go into the Control Panel -> Power Options and set your Minimum processor state appropriately since this also controls the multiplier you'll end up with at idle....
Quote:
CPU-Z is almost definitely correct.


Too many people blindly believing stuff like that is the reason why this issue never gets fixed.


Hi,

If I understand correctly, on my Dell 15 (1557) with i7-820QM by doing this simple precedure ill be able to increase performance/make it run in turbo mode constantly?
!