Sign in with
Sign up | Sign in
Your question

GA 965P-DS3 rev 1.01

Last response: in Motherboards
Share
November 18, 2009 10:16:42 AM

Win7 Ultimate x64
GA P965-DS3 rev 1.01
Intel duo 2 core E6400 overclocked 2.8ghz
Zalmon 9500A HS
Corsair 4x1gb 800mhz
Sapphire ATI HD5770
Corsair 650w psu

Does anyone have this board and version. I'm looking to see if there are any update for the bios. My Memorex DVD rw 16x isn't working properly. It shows up and everything but it's not doing anything. I put in a disc and all it does is spin and then freezes up the screen until I eject the disc. So I'm hope'n to update the bios to see if it will work. Thanks

More about : 965p ds3 rev

a b V Motherboard
November 18, 2009 1:57:52 PM

Newest Bios is F14 dtd 09/06/25 for rev 1.0
http://www.gigabyte.com.tw/Support/Motherboard/BIOS_Mod...

Is this a new DVD-rw, or did it just recently quit working. If that is the case then I dought a BIOS up date will help.

Might try removing the driver and reboot. Also if this just started when Win 7 was install it is probably a driver issue. Verify Bios setting (DVD recognized during boot).
Also check web site (link above) for a 64 Bit driver update.
m
0
l
November 18, 2009 10:05:05 PM

It looks like I can't update my bios. The new bios is not excepting the new 64bit version or something.
I tried to remove the dvd-rw driver several times already and rebooted the computer and it did reinstall it at startup along with another cd drive that I don't have and that I seem to can't delete or uninstall because everytime I restart the computer, it shows up again. Both of my Memorex drives shows up in my bios as one master and one slave and it shows up in my computer. It has power to it and open and closes and spins the disc when I put it in but then that's all it's doing. I tried to update it in my devices but it says it can't find a newer update and memorex does not have anything on it. I'm pretty much stuck here. I think I should just buy a new one and see if it works.
m
0
l
!