Sign in with
Sign up | Sign in
Your question

4670 Artifacts on *Some* Games...

Last response: in Graphics & Displays
Share
June 16, 2009 1:18:37 PM

Hello, i am having artifacts on my Sapphire Radeon HD 4670 Ultimate.
i bought it on Ebuyer, and still have a years warranty.

Hey, im receiving strange artifacts, where the Textures ingame is 'Stretched' so much that i cannot see a thing.

I Have latest drivers, Catalyst 9.6
Windows Vista 64Bit Home Premium
2GB Ram
Sapphire HD 4670 Ultimate
AMD Athlon x2 4400+ @ 2.3GHz

i ONLY receive artifacts when playing Terminator Salvation and HAWX
(in DX9) and Dead Space.

To try to fix Terminator i have:
I have tried CCC Settings to optimize settings ingame to see if that was the issue, No Luck.
I have tried installing DirectX after install, from the 'Support' folder, No luck.
I have tried Changing resoloutions, No luck

I havent had this problem in all my other games, Crysis, Fallout 3, GTA IV, Burnout Paradise as they work Flawlessy with high FPS on maxed settings and Movies on it are also superb.

So.. Any fix to whats going on?.. My last option is to RMA it.



I really want to get those games working, paid alot for these games!

PS.
My 4670 is NOT overclocked and runs 50degrees max on full load when playing fallout3+GTA IV for a few hours (however it did once top to 80 when playing hawx after a mission)

Thank you.

More about : 4670 artifacts games

June 16, 2009 1:45:43 PM

Try turning Catalyst AI either off or to a lower setting for these games and check for patches or try running in DX10 mode.
June 16, 2009 1:48:08 PM

I will try turning off Catalyst and i have already applied patches. There is no option to run DX10 mode in Terminator and Deadspace from where i can see :( 

Will post back in a min.
June 16, 2009 1:51:08 PM

Nope, no effect when turning off Catalyst :/ ..
Anything else i can try?
!