Sign in with
Sign up | Sign in
Your question
Closed

Front audio panel problems

Last response: in Motherboards
Share
November 19, 2009 10:40:04 PM

Hello, I'm trying to set up my front panel audio connection with a Antec Sonata III case on a Gigabyte P55-UD3R motherboard. However, I'm not experienced in doing so and something seems to be wrong (as plugging in my headphones to either jack in front while audio is playing does nothing).

I do not understand how to use the Pin No./Definition tables given in both the Antec manual and my Gigabyte manual. I've located the pins on the motherboard and plug in the HDA cable (AC'97 does not yield any sound either, and I would rather HDA) so that all pins in the header are in. I looked through the BIOS and did not find anything notable pertaining to audio, other than Azalea codec options. I installed GIGABYTE's drivers and nothing.

I've tested the headphones in the rear port (where a box will pop up confirming I have plugged them in, as it should) and they work fine. However, in the front, nothing happens. In the "Realtek HD Audio Manager", no change seems to yield a function in the front panel.

Any help is much appreciate; I posted this in the PC Cases forum and someone advised me to post here (I guess it is appropriate as this would seem a GIGABYTE issue).
a c 156 V Motherboard
November 20, 2009 12:07:11 AM

Hi, theta. I guess my suggestions didn't work.

Calling bilbat.
Score
0
November 20, 2009 12:19:53 AM

Err, you mentioned cutting the connectors off or something and I am entirely unsure of what you mean by that. I did try everything else, though, thanks.
Score
0
Related resources
a c 177 V Motherboard
November 20, 2009 12:28:47 AM

Will be back in an hour or so - middle of re-pair (not repair, as in fix - had 'em set up as a 4 drive array, & it sucked the big wazoo!) RAIDs & reinstall OSs (& Office 2010 :ouch:  )
Score
0
a c 156 V Motherboard
November 20, 2009 8:53:22 PM

theta, if you do not know what you are doing or why you are doing it, do not cut off any connectors. :) 
Score
0
November 21, 2009 9:12:48 PM

Any suggestions? I'm guessing it is a driver issue but unfortunately I can't install XP without screwing up the MBR of Windows 7, so I can't really try it in there.
Score
0
a c 177 V Motherboard
November 22, 2009 1:27:21 PM

AcKKK! Sorry it took me so long to get back to you - reformatted RAIDs, reinstalled systems - lots of beta 2010 s'ware, so, of course, lots of really weird beta problems!

Your case has both kinds of connectors, but doesn't show the exact labeling - you are correct in assuming you need (or, actually - want) the HD, as it allows muting of speakers when headphones are plugged in. RealTek driver, rev 2.37 is here:
http://www.realtek.com.tw/DOWNLOADS/downloadsView.aspx?...

On the "Integrated Peripherals" page of the BIOS, "Azalia Codec" should be at 'auto' (manual only shows 'auto' & 'disabled' - if there's an 'enabled' set it to that!)

Can't plug the header in wrong - it's 'keyed' for proper insertion, so, though it's the same pin arrangement as a USB header, with differing 'blocked' pins, the plugs won't interchange...

Once the driver's in, check procedure 'C' on 110 of your manual, to be sure "front panel jack detection" is enabled...
Score
0
November 22, 2009 6:03:11 PM

I installed the latest drivers and made sure Azalia Codec is at auto. Procedure C seems to only be for AC'97 but I tried it anyways. None of this has worked.
Score
0
a c 177 V Motherboard
November 22, 2009 7:21:07 PM

How are you determining this? Are you sure the headphones/speakers you are plugging in work? At least try some different ones to confirm... This will sound supid, but I diddled around for, oh, ten minutes trying to get some gain on my headset mic, only to discover it had a mic switch (shipped in the 'off' position, of course, in keeping with Murphy's law...) hanging on the damned cord!
Quote:
...check procedure 'C' on 110 of your manual, to be sure "front panel jack detection" is enabled...

The listed procedure disables detection, for AC'97 set-ups...
Score
0
November 22, 2009 8:45:02 PM

Understandable, I've tested both jacks in front with both new headphones and old earbuds, both of which work when plugged into the rear audio ports.

Additionally I've tried both disabled front panel jack detection (which is obviously not what I want) and enabling it (unchecking the option).
Score
0
a c 177 V Motherboard
November 22, 2009 9:22:17 PM

Lemme fuss around a bit, and I'll try to come up with a procedure to test 'both ends' - I know a lot about it, as I started off by cutting away the extra connector from my last Cosmos, and found out (after much wailing and gnashing of teeth...) the 'detection' ground was made in roundabout fashion through the other connector - but it took some serious troubleshooting!
Score
0
November 27, 2009 10:21:49 PM

There was an update for the Realtek drivers that I downloaded from GIGABYTE's website (as opposed to Realtek's because of their outragously slow 10kb/s download speed and my assumption that both drivers are the same).

It concerns me that there is no box being brought up when anything is plugged in in the front... I wonder if something is causing this, but unfortunately I have no idea how to troubleshoot it. As far as I can tell the fault should be mine as I haven't encountered anyone else with this issue.

Any more help is appreciated.
Score
0
a c 156 V Motherboard
November 28, 2009 1:34:03 AM

bilbat said:
... the 'detection' ground was made in roundabout fashion through the other connector - but it took some serious troubleshooting!

What???
Score
0
a c 177 V Motherboard
November 28, 2009 12:58:21 PM

Here's what I mean:

My Cosmos came with both HD and '97 connectors (wiring in black...); I knew I'd never use the case with a board old enough to not support HD, so I wanted to get rid of the extra connector (so it wouldn't be 'dangling around' accidentally shorting something, so it wouldn't be 'dangling around' period, so I could be anal and obsessive... :pt1cable:  ); however, when I cut it off (at the red line...), it 'lost' the ground to the HD's pin 4 'detect' line (which is 'floated', and 'low true'), and my RealTek ALC889A codec could never 'see' that it was, indeed, an HD. After much cursing in German, muttering, and gnashing of teeth, I finally discovered that I needed to add the jumper (in green) to get the 'detect' to happen...
Score
0
November 28, 2009 3:13:31 PM

Okay... The connector comes with both AC'97 and HDA on the same cord, and I have the un-needed AC'97 zip-tied to some metal in the case, to keep it from touching my graphics card. I tried it both ways and nothing is recognized...

I don't think I would ever try to get rid of the connector though and I don't think that is really the problem. I do have a Creative Soundblaster card somewhere but I don't know if it has the pins for this connector... I'll check soon and if it does I can try using that to determine if it the motherboard (which does have a cold boot problem that I hope is unrelated to this). It'll just be a very arduous thing to do considering I'll have to disable and uninstall the drivers for the integrated audio, find a way to plug in the sound card with my oversized graphics card, and then install Creative's awful drivers.

I'm almost hoping I check the card to find no pins. :\
Score
0
February 26, 2010 7:01:40 PM

Here's what worked for me . . . On my Gigabyte MB, the front panel headphone/mic jacks wouldn't work until I went into the Realtek HD control panel and checked the box that says 'Disable front panel jack detection'. It's under the Audio I/O tab and you click on the wrench where it says Analog.

Hope this helps someone else in the future.
Score
0
a c 177 V Motherboard
February 26, 2010 7:12:24 PM

OK - who forgot to tell me that it's officially been designated "Dredge Up Old Threads" Day!?!? :heink: 
Score
0
July 23, 2010 11:27:35 AM

i do have the same problems with the front audio panel, but i just figured it out how to enable it, maybe this could help you out ,go to control panel > click realtek hd sound effect mananger . and then see the image below to adjust the settings

http://img696.imageshack.us/img696/1853/howtoe.png
Score
0
December 2, 2011 11:36:17 AM

gbizier said:
Here's what worked for me . . . On my Gigabyte MB, the front panel headphone/mic jacks wouldn't work until I went into the Realtek HD control panel and checked the box that says 'Disable front panel jack detection'. It's under the Audio I/O tab and you click on the wrench where it says Analog.

Hope this helps someone else in the future.




Thank you very much, is working for me too
Score
0
!