Sign in with
Sign up | Sign in
Your question
Closed

@ instead of " on Windows 7

Tags:
  • Configuration
  • Dell Studio Xps
  • Windows 7
  • Windows Vista
  • Keyboards
  • Windows XP
Last response: in Windows XP
Share
December 15, 2009 4:30:33 AM

I’ve recently upgraded from windows vista to Windows 7 on my Dell XPS Laptop. Now my keyboard outputs " whenever I press @ and visa versa. I’ve checked that my Region and Language settings is set to UK (As my @ sign is above numeric 2) but this doesn’t change a thing, Does anybody have a solution?

More about : windows

a b $ Windows 7
December 15, 2009 5:38:54 AM

Check your Device Manager. See if the Keyboard driver is properly set.
I think it should say Standard PS/2 Keyboard.
I have a Dell laptop and that is what mine says.

Score
0
a b $ Windows 7
December 15, 2009 6:17:23 AM

Have you actually checked the keyboard layout, as opposed to the general language settings? Control Panel/Region and Language/Keyboards and Languages/Change Keybords?

It may be that you have both US and UK keyboards installed. in which case delete the US one.
Score
0
Related resources
December 15, 2009 7:00:01 AM

Thanx guys. In the device manager, under keyboards, I seem to have two drivers, “HID keyboard device” and “Standard PS/2 Keyboard” considering what you said, I know PS/2 should be set as the device, but there seems to be no option in choosing between the two. Can it be that they are clashing?

The actual keyboard layout: @ is above numeric 2, like I said, and “ is next to enter. When I initially installed Windows 7, it gave me an option to choose languages and later on, keyboard layouts. From the get go I chose UK as a Language and UK layout for the Keyboard. Seems that no matter how I change it, it has no effect on the problem (I’ve even tried Arabic layout for fun, that didn’t do anything)

I’m really getting frustrated with this seemingly small problem…
Score
0
a b $ Windows 7
December 15, 2009 7:06:35 AM

Multiple input devices showing is quite common. I also get that.

Does the "Change Keyboards" dialog show the US keyboard layout installed, or just the UK one?
Score
0
December 15, 2009 7:24:59 AM

It only shows the UK one installed.
Score
0
a b $ Windows 7
December 15, 2009 7:31:13 AM

That is most odd. I have never heard of Windows behaving in this manner and will be intrigued to learn what the resolution is. One thought; it might be worth using Device Manager to remove all keyboard devices and let Windows install them anew when it reboots.
Score
0
a b $ Windows 7
December 15, 2009 7:38:14 AM

Since you upgraded from Vista, it is possible that Vista sees the keyboard as a Standard PS/2 Keyboard and Windows 7 sees it as a HID keyboard device.

In the Device Manager, you can click on a device you do not want, then press the Delete key. If, for some reason, Windows still sees the deleted device it will reinstall it.

If you delete the HID keyboard device and Win7 re-installs it, you might try deleting the Standard PS/2 Keyboard. My Dell laptop is still running Vista which might explain why mine only says Standard PS/2 Keyboard.

I would also suggest you check out ijack's suggestion. His point is also valid.

Hope this helps.

PS. I hope you don't get stuck with an Arabic layout. Unless of course you're really into Arabic. :) 
Score
0
a b $ Windows 7
December 15, 2009 7:40:28 AM

One further question. Do you see the Langauge Indicator (it should show as "EN") in the task bar? If so, click it and see what it says.
Score
0
December 15, 2009 8:04:35 AM

I'll try deleting the HID keybord in a moment... just busy installing something. I can't see the Language Indicator. Where can i activate it?
Score
0
a b $ Windows 7
December 15, 2009 8:31:36 AM

If you have more than one language installed, i.e. US and UK keyboard layouts, it should show by default. So it sounds like you don't have the US keyboard layout installed. In which case you have a very clever computer! How on earth does it know to put "@" above "2"? I'm baffled.

Edit: OK. here's something else that you could try.
Score
0
December 15, 2009 8:59:19 AM

Sorry, I just want to make double sure we're on the same page, as I find allot of problems sometimes remain unsolvable due to miscommunication. By physical layout of my keyboard, I mean that when you look at your keys, the @ key is on the same key as numeric 2, and the “ is next to the Enter, on the same key as ‘. Which one of the two (US / UK) has the physical layout defined with the @ as I just explained? I’m just worrying that I’m trying to solve the wrong problem here…
Score
0
a b $ Windows 7
December 15, 2009 9:00:38 AM

FYI - ijack's referenced link, under Edit, speaks of Windows XP.

ijack, I don't know if you checked or not, but I checked the Windows 7 Registry.
The indicated Registry location is also valid for Windows 7.


Score
0

Best solution

a b $ Windows 7
December 15, 2009 9:03:11 AM

Lizzard, I have the same key layout as you described and mine works as a US layout.
Share
a b $ Windows 7
December 15, 2009 9:06:53 AM

Gandalf said:
FYI - ijack's referenced link, under Edit, speaks of Windows XP.

ijack, I don't know if you checked or not, but I checked the Windows 7 Registry.
The indicated Registry location is also valid for Windows 7.

It is on mine. (Window 7 Home Premium 64-bit.) And it reads "809" as I have the UK keyboard layout.

A further thought - what about installing the US keyboard layout as well as the UK one and then seeing if the Language Indicator (which should automatically appear in the Task Bar) allows you to choose the UK one.
Score
0
December 15, 2009 9:49:47 AM

Haha! See that's why I ask. My apologies guys, what I was looking for was actually the US layout. Not UK, thanx for pointing out Gandalf, and for your help as well ijack!!
Score
0
December 15, 2009 9:50:54 AM

As for the other layouts doing nothing. Seems like a simple restart solves that problem. can't believe i didn't think about that.
Score
0
a b $ Windows 7
December 15, 2009 9:54:17 AM

Oops - I'm embarassed that I didn't realize you were describing a US keyboard! (Or possibly a Mac one.)
Score
0
December 7, 2011 10:32:54 AM

press "ctrl+shift" simultaniously. let go.
now try getting the @ again with "shift+2"
Score
0
a b $ Windows 7
December 7, 2011 10:46:23 AM

Best answer selected by nikorr.
Score
0
a b $ Windows 7
December 7, 2011 10:46:31 AM

This topic has been closed by Nikorr.
Score
0
!