Sign in with
Sign up | Sign in
Your question

Disabling Onboard Audio Also Disables Soundblaster Card

Last response: in Components
Share
September 5, 2009 7:34:42 PM

My current computer setup has two PCI sound cards (a Soundblaster and an M-Audio EMU). I use them both for audio recording. So far, i've had no problems having both of them enabled while the computer is running. Last night, i ran some latency testing and found that my onboard audio driver (portcls.sys) was causing considerable lag when i try to record. After a quick Google search, it seemed that i should have had my onboard audio turned off this entire time, as my Soundblaster is what is running to my speakers.

After going into BIOS and disabling onboard audio, i booted back into Windows. It played the default startup sound, and then, no sound at all. Items would "play" but no sound would come out from the speakers. I went into Device Manager and while the onboard audio device was not listed (which made sense), the Soundblaster and the EMU were both still listed. I tried going into the Sounds option in Control Panel, and while everything still showed that the Soundblaster was my primary audio device, no sound!

Any ideas? Everything points to onboard audio needing to be disabled in order for a PCI sound card to work, but it's completely opposite in my case. As soon as i disable it, all sound devices turn off and i get no sound.
September 9, 2009 6:20:53 PM

Make sure the volume sliders are turned up, and that you don't have anything muted. You should be able to do what you want, I have had 3 sound devices at once before, without issue.

Other than that, check all the settings one more time. Perhaps the program you are using to play back sounds for a test is hard set on a different audio device. Some apps let you choose which audio device to use, instead of the system default.
m
0
l
September 9, 2009 7:48:38 PM

Thanks, but i had tried that. Yesterday, i uninstalled all Creative drivers and software, took the cards out, disabled onboard audio, reinstalled the cards, drivers, etc. After all that, the same result: no sound will play unless onboard audio is enabled. Even if the system sees the Creative card and drivers, i can play audio or video but get no sound.
m
0
l
September 27, 2009 8:09:31 PM

First thing to do , go to your mothedrboard website and download latest bios and update the firmware.

Secondly download and install 'Guru3D - Driver Sweeper'.Then remove all sound drivers from your system using this tool. Then restart the system.

Thirdly download latest driver for your sound card from creative and install it.

.............................................................................................................

If problem didnt go away it could be that theres are conlicts between hardwares, try putting the sound card in another slot.
.............................................................................................................
Remember onboard sound must be Disabled


Guru3D - Driver Sweeper
http://downloads.guru3d.com/Guru3D---Driver-Sweeper-%28...
m
0
l
!