Sign in with
Sign up | Sign in
Your question
Solved

Ide/sata issue in bios

Last response: in Storage
Share
February 6, 2011 10:40:29 PM

hello everyone, i just want to start by saying thank you to everyone who posts here, i've been muddling my way through building and setting up a pc for the first time and got a lot of help from these pages.

i've finaly got my system up and running and aside from a pretty hot mobo temp (52 C) everything is in good working order. there is one small matter which has me really confused though...i set up xp on a sata hdd with raid disabled as initially was installing xp and didn't have the ability to pre-install the sata drivers. in this case the drive showed up in bios under third ide channel. my cd and dvd roms are under 2nd channel and now i've installed a ide hdd under the first channel and have it set as slave with jumper(don't think this matters when using sata and ide together but thought i'd set it to be sure). the issue is that when i set bios to recognize this ide hdd (i.e. to auto-detect) it shows up in bios and i set the hdd priority and boot priority to use the sata drive first with o/s on it and then it fails and gets stuck in a loop of booting but failing to load the o/s?

i then tried enabling raid just as a shot in the dark and that gets me as far as the "windows didn't start properly" screen but when i start windows normally it re boots? finally i disabled the auto detect for 1st ide channels so the ide hdd drive doesn't register in bios but low and behold the system starts and prompts me to update drivers for the new hardware at which point it located and installed sata raid drivers for xp. it boots and loads the os fine now and windows recognizes both hdd but i'm confused as to why the settings work in this way and i'm still not sure whether or not my sata HDD is working properly as a sata or still being used like ide? should i just be happy that all is working or am i sacrificing performance from my two hdd because i haven't configured bios properly? any and all help and suggestions will be greatly appreciated!

System Specs;

ASUS a8n32-sli deluxe mobo
AMI v.02.58 Bios 1303
WD500gb SATA HDD (Black Caviar)
WD200gb IDE HDD
nVIDIA SATA and SATA RAID Drivers are installed as well as up to date IDE controllers

thanks again,

ryan

More about : ide sata issue bios

a c 359 G Storage
February 8, 2011 1:01:26 AM

First step is to fix the jumper on your IDE HDD unit. Setting Master or Slave on an IDE device has nothing to do with what you boot from. Any IDE port MUST have a Master device on it to operate, and MAY have a second device on its port / cable that must then be the port's Slave. These settings pertain to that one IDE port, and not to the entire machine. So you probably properly have the optical units on the second IDE port set correctly - one jumpered as Master and on the END connector of the ribbon cable, the other as Slave on the MIDDLE connector. Set your IDE HDD on the first IDE port to Master and connect it to its cable's END connector.

The only other option for IDE jumpers is to set BOTH devices on one IDE port to "CS" (for Cable Select), and then the one on the END WILL be the port Master device.

That should solve your mobo's confusion over IDE devices. Now, you have one other source of confusion. Many mobos with both IDE and SATA ports (like yours) use a confusing label system. They call the IDE devices in the system the Master and Slave devices on the First and Second IDE Ports (or sometimes IDE0 and IDE1), then then they start calling the SATA devices as Masters on later IDE ports, even though they are on SATA ports! You will note that there are NO SLAVES on those later IDE ports after the first two. That's because there cannot be a Slave (second device) on any SATA port.

From your story it appears that you Enabled RAID on the SATA ports and later booted successfully. That forced Windows to think you need the RAID device drivers so it loaded them. This does NOT put your drives into any RAID array. You actually have to enter a RAID configuration utility and deliberately assign HDD units to a RAID array and then Create it if that's what you want. But until you do, by default all your drives are separate and NOT in a RAID system.

Since you had no way (or desire) to install special drivers as Win XP was being installed at the very beginning, you were right to set the SATA drives to IDE (or PATA) Emulation mode. In fact, at least for the one HDD you plan to leave as a boot drive that is NOT ever going to be in a RAID array, you could re-set it to that mode. That is, IF your BIOS allows mode setting individually for each SATA port. Some do not, so if you plan to use RAID for ANY SATA ports you have to set them ALL to RAID mode, and the RAID driver allows use of individual drives that you do not assign to a RAID array.

Once you get these adjustments made, go back into BIOS Setup and verify that all the drives are being detected properly and are Enabled. Then go to Boot Priority Sequence and set up what you want. For example, I suspect you want it to try one of your optical units as the first boot device, then one of your SATA drives as second choice, and NO other choice. When it's set your way, Save and Exit to boot.
m
0
l
February 8, 2011 2:32:37 AM

i had this same question posted in another forum which i now realise i shouldn't have but i wasn't sure which category to post it under

http://www.tomshardware.com/forum/forum2.php?config=tom...

and got some feedback there. i've been through the jumper issue and i think i've got the answer from jaquith

"Couple of things, first is Boot Priority in the BIOS; IDE needs to be first, second if the SATA HDD had an OS installed then that's where the problem is -- if the SATA & IDE drives were both connect in the PC when the OS was installed on the IDE then some OS files are located on the SATA HDD.

To correct the problem if what I said was true you'll need to: remove the SATA HDD from the MOBO {pull the SATA cord}, reformat the IDE, and reinstall the OS on the IDE.

To confirm this, remove {pull the SATA cord} SATA HDD and reboot. Failure confirms the problem."

i think i misled you earlier when i was taking about the "raid" setting. i thought i was using this as a way to enable AHCI as there was no other setting in BIOS (AMI v02.58 1303 on an ASUS A8N32-SLI Deluxe) that would allow me to adjust this setting. i just assumed that was the spot and i was trying to enable the sata to run using this controller after i had installed the SATA drivers. i now realise this might have been premature and i'm not sure where to enable AHCI?

i only have one SATA drive and one IDE. i do have the OS on the SATA and the IDE was not plugged in when I installed so i'm guessing it's the boot priority issue. i would prefer not have to re-install windows on the IDE as i already have loads of other software installed on the SATA so do you think it's alright to operate with the IDE set to "not installed" and windows picking it up or will this cause me grief in the future?

i am interested in getting the one SATA drive to run as such with AHCI enabled if it's not doing so already? how can i tell if it is and if it isn't how can i set that up?. do you think it will be possible with the current set up?

thanks so much for your input, you guys are really great to help all of us laymen figure it all out. as i said in that other thread, i'm really just doing this all to help out my dad and won't even get to use the computer when it's finished but after going through and figuring it all out, i'm excited about the prospect of upgrading my own computer or building a new one when i have the cash to do so!
m
0
l
Related resources
a c 359 G Storage
February 8, 2011 7:10:56 PM

For starters, what you want is quite all right - should be able to do that with no problem. That is, you want to continue to use your one SATA HDD as the boot device and still have the IDE HDD also installed and functioning normally as a drive that just is not used for booting.

First step, as I said, is to get the IDE device jumpers all set correctly. That means on EACH of your IDE ports you need to have ONE device jumpered to Master and on the END connector, and the other (if there is one) set to Slave and on the middle connector. With 2 IDE ports you can have 2 Masters in total (one each) and up to 2 Slaves, too. For example, I have a very similar mobo - an ASUS A8R32-MVP Deluxe, the one that supports ATI Crossfire graphics cards, not SLI. I have two 320 GB Seagate SATA II HDD's on SATA ports, and 2 DVD-RW dual layer optical drives (one with Lightscribe) each as Masters on two separate IDE ports. More recently I connected an older 120 GB IDE HDD as a Slave on one of those ports. There's also an external HDD connected via an eSATA controller and port on the mobo. I'm running XP SP2 for now, switching up to Win 7 soon. All those drives work just fine, and the boot sequence I have set is 3½" floppy first (yes, I have one), upper optical drive second, and SATA0 port unit last - no other choices.

Anyway, get the IDE devices set up first so there is no problem for the mobo to deal with them. You do NOT need to make an IDE device the boot device just because it is connected! You can continue to boot from your SATA drive and use it as C:.

However, you can NOT use it in AHCI mode without a LOT or work. Win XP in all its versions does not have drivers "built in" for AHCI devices (that's really the proper way to use SATA units), but it does have them for IDE devices. That can be a problem both when you install XP originally, and whenever you boot from a device. XP can't handle an AHCI device to read or write anything! (Well, unless you install the required drivers.) There are two ways to deal with this dilemma, and they start at the time you first install your OS.

The "complete and proper" way, I suppose, is you use a feature that many Windows releases have had. Early in the Install process there is an option to install device drivers that windows does not have, and make them a completely "internal" feature of this particular installation so the devices can always be used, even for booting. Originally this was implemented so people could set up SCSI or RAID devices as boot units, but it works perfectly well for AHCI devices, too. HOWEVER, the only way the Win XP Install routine can do this is to load them on request from a floppy drive that already has them on it, and a lot of machines did not have this device! So, how can one build and sell a machine that uses SATA HDD's that want to be treated as AHCI? Mobo makers provided two solutions. One was to be sure that builders knew exactly how to use the AHCI driver install process when installing XP, and they all cover it in their manuals. The other is MUCH easier, and both you and I did it this way. You go into the BIOS Setup screens and set the SATA Port Mode to IDE (or PATA) Emulation. When this is done, the BIOS intervenes and makes the actual SATA unit appear to the OS as a simpler older IDE device it already understands completely, and the Install and all subsequent operations just work perfectly! BUT that imposes two limits on you. One is that a few of the ACHI device advanced features are lost in this Emulation of a simpler technology. The other is that you cannot simply switch the SATA Port Mode to AHCI later. If Win XP does try to load itself from an IDE device and finds only an AHCI device it cannot use, it can't load anything! AFTER Win XP has loaded from an IDE device it can load AHCI drivers to allow it to use such a device as a data disk, but it cannot BOOT from such a device.

So, if you really wanted to change to AHCI use of your SATA HDD, you have two options. The straightforward way is to start from scratch - re-install Win XP and all your apps, etc., only this time you use that special feature to load the AHCI drivers from a floppy disk as you do the Install. Alternatively I have seen some complex detailed procedures that people have used to install the drivers on their HDD and then modify the Windows Registry and related files so they can be found and loaded at the very start before Windows itself loads. Unless you're skillful I suggest not doing that. Your best choice may well be to continue using the IDE Emulation mode and not worry about a few missing AHCI device features.

Once you have the IDE devices set up right and make sure your SATA HDD has its port mode still set on IDE (or PATA) Emulation, go to check the Boot Priority Sequence. I suspect you will want it to try one of your optical drives first, then your SATA drive second, and no other options in the list. Should not be any problem. If you have ANY confusion in setting up which HDD to put into the list (because it MAY call your SATA unit an IDE unit on Port 3 or something), just take careful note of the SIZE of the two HDD's and you can identify the 500 GB SATA unit that way.
m
0
l
February 8, 2011 8:34:18 PM

so far i've tried all the jumper settings listed on the top of the HDD. they are as follows, 1 and 2= Cable Select, 3 and 4= Slave, 5 and 6= Master with Slave, and finally no jumper= Master or Single. it does not say what positions 7/8 and 9/10 are used for so i'm going to try putting it at the end as you suggested and if that doesn't work i will try 7/8.

the current set up is:

CD ROM Secondary IDE Master, CD/DVD Secondary IDE Slave
EIDE Device (WD200GB) Primary IDE Master or Single (have had it on all specified settings as i mentioned before and each time so far it has prevented the OS from loading)
AHCI Device (WD500GB) Sata Port 1 with Satat Ports 1 and 2 enabled (they only enable together)

i have also tried switching the two around to have the optical drives on primary IDE and the HDD on secondary which made no difference. the only other thing i haven't tried is putting an optical on the same channel as the HDD which i might do tonight if the jumper settings still fail me. do you think this will work better? i noticed you said you had an optical as master and a HDD as slave on one channel. is this set up preferred?

THe boot sequence for me so far has not been an issue. i can easily see which HDD is which by the method you described. in this BIOS i have to select the order of Optical Drives and Hard Drives first in one screen and then whichever of the two i put first shows up in the BOOT priority selection screen. so i have the DVD ROM and the SATA HDD first in their categories so they show up. i have no floppy drive so i disabled that port and as a result i only ever get two choices out of three possible spaces in the boot priority which i assume is correct.

no matter what the jumper settings on the IDE drive it is always pre selected first in the HDD priority so i always have to change this to get the SATA to show up in the BOOT priority. that is why i supposed that other fellas answer was right because it seems as though the BIOS wants to load that IDE first everytime i re-install and when i switch the priority it doesn't work. of course if i left it it wouldn't work either as the OS is on the SATA!

ok, i'll try the settings that i haven't yet with the jumpers and maybe switch some drives around and if that doesn't work i'm going to leave it the way it is and just let it work without knowing why! it's going to my dad anyways and i'm sure he doesn't care how it's set up as long as it works.

i'm definitely going to leave the sata the way it is on IDE emulation mode. so if this dosen't work i'm just going to leave the IDE HDD as "not installed" in BIOS as it continues to register and work in windows and call it a day!

thanks so much for your help, really appreciate it.
m
0
l

Best solution

a c 359 G Storage
February 9, 2011 5:22:13 PM

From what you say about the IDE's label, the proper setting for its jumpers is NO jumper. That would make it a Master on its IDE channel with no Slave on that channel.

Having the two optical drives as Master and Slave on the Secondary IDE Channel is quite all right. That should work fine.

IF you decide to put an optical drive on the Primary IDE Channel along with the HDD, the ideal arrangement is for the HDD to be the Master (would require a jumper on pins 5&6 since it now has a Slave) and the optical unit as Slave. Make sure that whichever optical unit is left on the Secondary Channel is its Master. This is only because SOME early optical drives had difficulty acting as Master when there was an HDD as Slave on the same channel. I don't know if that is your situation, but it's just a precaution. (In fact, I think I did NOT do it this way in my machine and it works.)

I can understand that, when you Enable the IDE HDD, your BIOS tries to offer it as the first of the HDD's in the Boot Priority section. However, you then change it to be second with the SATA unit first. I presume you are then using SAVE and EXIT with these settings. And yet you say that the machine somehow refuses to keep that setting and insists on putting the IDE unit first and trying to boot from it, and then failing! That is really odd! I'm also intrigued that the solution that works is you set the BIOS to NOT have an IDE HDD installed, and yet it finds it and makes it fully available to Windows for use! Sometimes computers are stupid!
Share
February 15, 2011 3:46:31 PM

Best answer selected by mrs315.
m
0
l
February 15, 2011 3:55:27 PM

finally, i chose yours as the best answer paperdoc because you referred to the computer as stupid rather than me! i've moved the drives all around with the proper jumper configurations as you mentioned and have been using the "master/single" setting with the original setup but all to no avail.

bios dosen't reset the drive to first in boot priority unless i uninstall and reinstall the drive. it just refuses to boot from the SATA as though for some reason having the IDE installed through bios interferes with the SATA drive or otherwise affects the boot?

anyways, i've closed it up and it's working for whatever reason and so i'm happy. thansk again for all your help!
m
0
l
March 27, 2011 10:10:42 AM

hi..
i have a similar problem with some more constraints...i too have a mobo with both IDE and SATA ports..my IDE HDD crashed some time back and i purchased a new SATA hdd 500GB..now after connecting it to the mobo and starting the BIOS does not show any HDD and therefore i am not able to install OS(either win XP -SP2 or WIN 7)... initially when i had IDE HDD i had got installed raid drivers also..what to do with that?..is it to be enabled or disabled? PLZ HELP..

REGARDS

XAVIER
m
0
l
March 27, 2011 1:17:01 PM

i'm no expert so hopefully one of the veterans will add something to this thread as well but i know that you must have SATA drivers installed before you can use your SATA hard drive as such. not sure but i think RAID and SATA drivers are different. the RAID drivers enable you to use multiple SATA drives in co-operation with each other but you still need to have the SATA drivers installed first. you can usually download these drivers from mobo manufacturer's webpage or from a mobo cd if you have it? of course you have to do the install from a floppy disk. i also thought if you were installing win 7 that the drivers were included in the operating system?

do not enable RAID unless you are trying to use multiple SATA drives in some sort of arrangement.

you can use your SATA drive like an IDE drive by choosing the right mode in your BIOS. seems like this choice is worded differently depending on what BIOS you are using but basically it will be something about enabling/disabling SATA or IDE and you want to disable SATA or enable IDE. in this way you can use your SATA drive without the drivers and BIOS should recognize the device as a primary IDE device depending what port you have it plugged into. it is also important to enable your SATA ports even though you will be using the device as IDE it will still be plugged into a SATA port.

i hope this helpful in some way. you should start a new post listing all your specs and problem because this thread is already solved. someone with more knowledge will most likely respond to a new post. also, have a look through the forums. good luck!
m
0
l
a c 359 G Storage
March 28, 2011 2:25:33 AM

ravi420ran, try these few things.

1. You say your BIOS does not show ANY HDD attached. I presume you are in the BIOS Setup screens to examine their data. Only a few things could do this. First, go to where the SATA port(s) are configured, and make sure they are Enabled. (As a side issue, but not necessary, IF you are not using anything on your IDE port(s) now, you could go to their config area and DISable them.) If the port(s) are Enabled your BIOS should detect any SATA drive connected to one. If not, check these things in case one is faulty:
(a) for this purpose, connect only to the main SATA ports on the mobo - usually labeled with things like SATA_0, SATA_1, etc. Do not use any "extra" SATA ports or eSATA ports near the back of the mobo, because these may need drivers to operate.
(b) try a different SATA port to connect to.
(c) try a different SATA data cable (the more narrow one with 7 wires) to connect from drive to mobo port.
(d) make sure there is a power connector (15 wires, wider) from the PSU to power the SATA HDD unit. Maybe try a different connector as a check.
(e) if none of that works, see if you can connect your HDD in another computer to test whether it "works" there.
It is unlikely that ALL of your mobo SATA ports could be "dead", although one might be. It is possible that you got a bad HDD. Or even more likely, one of the other items above failed.

2. Now, IF you got the BIOS to detect the SATA HDD, the next item to address is the SATA Port Mode. Look in BIOS Setup near where you Enabled the port(s) for a line called SATA Port Mode. There may one one line to cover ALL SATA ports, or there may be a separate setting for each such port. What you set here depends on which OS you plan to install. XP and Win7 require different settings.
(a) If you plan to install Win XP in any form, it does not know how to use SATA (really, AHCI) devices unless a driver is installed. But how can you install a driver into Windows XP if that OS is not installed? A classic chicken-and-egg situation with a good solution OR a handy trick to avoid the whole question! The "proper" solution built into the Install routines for all Windows OS's is that, very early in the Install process you see a screen prompt to press "F6" if you want to install special device drivers. It will pause on this message for a little while. If you ignore it, the message disappears and the process goes on. But if you do press that key, you enter a subroutine to allow you to install the driver(s) needed. Doing this will add those device drivers permanently into this particular Windows XP installation and allow it to use the devices from now on, even for booting. The small problem is that this routine only knows how to install those drivers from a floppy diskette. So before you can do this, you must have a diskette drive installed and operating (at least temporarily) in your machine, AND you will have to have previously written the AHCI driver files for YOUR machine on a floppy diskette. Those files often are on a CD of utilities that came with your machine or mobo, or you may get them from a website. So with some preparation you can go this route - install the AHCI device drivers as part of the Win XP Installation process - and then your machine will be able to boot from this SATA HDD into Win XP. IF you go this route, the correct setting for the SATA Port Mode is AHCI (or maybe "Native SATA").
(b) Alternatively for Win XP, here's the "handy trick" I mentioned. Most BIOS's have a Port Mode setting called something like "IDE (or PATA) Emulation". If you set it this way, the BIOS will make the actual SATA unit appear to be just a simpler IDE device, and Windows XP knows all about them and will be happy to use it without any fancy drive install process. The downside is that, by doing this you lose a few of the advanced features of the AHCI (SATA) system which many people don't care about anyway.
(c) IF you are going to install Win 7, FORGET all that stuff! Win 7 HAS its own built-in drivers for AHCI devices and CAN use them for the Install process. So if you're installing Win 7, set your SATA Port Mode to AHCI (or maybe "Native SATA").

3. Once you have decided this and set the Port Mode, there's one more thing to do in BIOS Setup. Go to where you set the Boot Priority Sequence. You probably will find that your only choices are hardware devices the BIOS has detected, so all the stuff above has to be done first. I recommend you set this to try your optical drive unit first, then the new SATA HDD second, and no other options. That way from now on, you CAN boot from a bootable optical disk if you want to, but if there is no such disk in the drive, it will quickly proceed to booting from your HDD.

With those BIOS items set, Save and Exit from Setup. Make sure your Windows Install CD is in your optical drive so it can be found, and the machine should boot into the Install process and find a drive to use. However, per Item 2(a) above, if you are installing Win XP and have set the SATA Port to AHCI mode, you MUST use the "F6" process to install the required driver(s) from floppy before the Win Install routine can find that device. If you follow process 2(b) (IDE Emulation mode for Win XP) or (c) (Win 7 install) you will not need to do that.
m
0
l
!