Sign in with
Sign up | Sign in
Your question

Homebuilt not booting up after case transfer

Last response: in Systems
Share
June 6, 2009 8:09:59 PM

Hello, i have recently purchased the Thermaltake Spedo Advance VI90001W2Z and today i moved all of my pc components to that case.. It all worked perfectly fine on the old case.. After i transferred my old pc to the new case, i tried to boot up.. But it doesn't work.. The led's on the mobo are on (asus maximus formula) but when i press the on button, nothing happens.. I tried to clear cmos, but didn't help.. I tried pressing the on button straight from the button that is on the mobo, but even then nothing works.. I removed one by one all the components of my pc, till only the cpu and the mobo were left, and it still didn't boot up.. How can something that worked 3 hours ago not work now? I was carefull with both the mobo and the psu, but still, something happened.. Could it be something different that a failure of one of those 2 components? The components of my pc haven't changed, just the case..
June 10, 2009 5:01:40 PM

sounds like you werent grounded at some point and static attacked.it happens to the best of us
a b B Homebuilt system
June 10, 2009 9:00:50 PM

Double check the PSU cables. Do you have the 4/8 pin cpu power plugged in? The 20/4 pin main power?

The front panel wiring could also be wrong. Look at the wiring and the mobo manual real close to make sure they are correct.
!