PC keeps showing nothing after removing CMOS

Hello everyone, this is my first post and I'm looking forward to answers for this issue that's keeping me from sleeping

Not so long ago this problem arised, the PC qill turn on but nothing will show up. Recently I've workaround the problem by removing the CMOS battery and starting the PC again. It worked, and I thought the problem would be solved, it didn't. I wake up in the morning and the computer turned on just fine, get back from college and again the problem from the beginning appears. I tried removing the CMOS battery again and it worked, however It would seem completely ridiculus to spend an awful amount of time to open the PC remove the CMOS battery and wait for everything to load up. Any help is appreciated.
1 answer Last reply
More about showing removing cmos
  1. When you have the battery out and the PSU unplugged:

    1. Discharge the capacitors by holding down the power button for one minute.
    2. Reset the CMOS by using a jumper or the Clear CMOS button (whichever your motherboard uses).
    3. Keep battery out for 24 hours.
    4. Doesn't fix it, get new battery as yours may be nearly dead.
    5. Doesn't fix it, set BIOS to optimum settings (should be a quick option in the BIOS).
Ask a new question

Read More

Asus Battery CMOS Motherboards