Sign in with
Sign up | Sign in
Your question

Removing RAID

Tags:
  • NAS / RAID
  • Hard Drives
  • Motherboards
  • Storage
Last response: in Storage
Share
February 16, 2011 11:30:35 AM

Hi - I'm not sure whether this fits best in this forum or motherboards........................

I have an ASUS A8V deluxe motherboard with a WinXP Promise FastTrak 378 (tm) Controller and a single HDD. The HDD is somehow configured as a RAID device using something called the FastBuild utility. Everest reports it as
Drive #1 - Promise 1+0 Stripe/RAID0 SCSI Disk Device (189 GB)

The HDD is plugged into a SATA port of the motherboard

My issue is that I want to convert this to a simple IDE configuration as it appears that the current config is stopping a successful install of Linux, however I have no idea how. I've tried changing the BIOS setting for the Promise controller from RAID mode to IDE mode and deleting the RAID array using the FastBuild utility, however if I try either of those (or both together) although the BIOS finds the HDD as part of startup XP says it can't find a disk. Even if I use the XP install disc to try and re-install it says it can't find a HD to install to.

Can anyone help me to resolve this?

Happy to provide more information on the system if required

More about : removing raid

a c 75 V Motherboard
a c 115 G Storage
February 16, 2011 12:55:25 PM

have you using the driver disk for your controller?

during the installation of XP it should allow you to press F6 to add drivers for RAID or SCSI controllers.
February 16, 2011 1:51:51 PM

I don't have a driver diskette. I loked on the web and found some drivers. The readme.txt file says they are Promise SATA378 Driver Diskette and the drives in the WINXP folder are:

ULSATA SYS Microsoft WindowsXP miniport driver
PTIPBM DLL Promise WindowsXP set Pbm dynamic link library
ULSATA INF Microsoft Windows miniport setup file

I tried F6 and using these but got an error (I can't remember what it was but I can recreate it if it helps) Are these the right drivers? Can you recommend a good website to get drivers from in case these are corrupt?
Related resources
a c 75 V Motherboard
a c 115 G Storage
February 16, 2011 2:13:33 PM

are you using a IDE or SATA drive?

if it is a IDE drive, is it connected to the black or blue connector next to the memory?
February 16, 2011 4:26:58 PM

It's a SATA drive plugged into the SATA_RAID2 drive on the motherboard
February 19, 2011 2:43:29 PM

I solved this by plugging the drive into a normal SATA port on the motherboard. The Promise controller then gave errors during startup (saying no BIOS installed) but disabling the promise controller in the BIOS advanced tab resolved that
February 20, 2011 11:36:23 AM

Does your 378 configuration supports a IDE hdd as part of the raid? This raid array is just a simple way to hide the fact that you add another HDD and your space is increased and its not very performant. I e. you have a 200gb hdd and decide to add another hdd of 100gb .Your new value will be 300gb so basically add more space on they fly, It doesn't mater if its seen as IDE ir as RAID its just a pain to add the drivers every time when loading OS but you can also slipstream your drivers onto your install disk and get rid of the FDD. If i remember correctly you need to go into 378 bios and remove any disk assignemets and then it will be ok.(done this on my sk8v long time ago)
!