Sign in with
Sign up | Sign in
Your question

Bios not showing full 6 gigs

Last response: in Memory
Share
December 1, 2009 11:52:05 PM

Hi,
This problem is quite perplexing.
I recently built a i7 tri channel rig on an ASUS Rampage II GENE MB.
I’m running OCZ Gold Tri channel 1.65 volt (low voltage for i7) RAM. It’s the 1600 6 gig (3x2gig) kit.
My problem is that my MB only sees the first two DIMMS. So my bios shows 4 gigs of total memory instead of 6. Therefore, windows 7x64 also only sees 4 gigs. HOWEVER, memtest86+ shows all three DIMMS at the bottom of the screen (picture below) but shows 4 gigs of total memory. The crazy thing is, if you look closely at the test being run, I took a picture of it when it was testing 4096-5120mb of 4087 mb of ram! How is this possible? This made me curious so I pulled up the view DIMM settings option within memtest86+. The picture below shows that DIMM0 and DIMM2 have memory installed but nothing in DIMM4 where the third stick of ram is. I switched up the sticks of ram and this doesn’t change. All three sticks of ram passed memtest.
Moving on, in CPU-Z the ram shows as 6 gigs in Tri-channel mode. How is this possible? Has anyone run into this problem?
Things I know it’s NOT:
1. The RAM is fine. It’s also on the vendor list. It’s the 3 channel kit LOW VOLTAGE for i7 processors.
2. They are in the right DIMM slots: I took a picture to show this.













More about : bios showing full gigs

a b } Memory
December 2, 2009 12:34:18 AM

Scroll up about half way. I think he had to increase the QPI Voltage to 1.35V.
m
0
l
Related resources
December 2, 2009 3:15:44 PM

Thanks for the reply! I bumped up the QPI to 1.35v and the RAM Bus to 1.65v. No Dice. It still shows as 4 gigs.

I did notice on his post (from the link that you provided) said this: "I budged up the DRAM Bus up to 1.65v and the QPI to 1.35 (QPI @ 1.39 with CPU at 3.2)"

I'm not sure what he means when it says QPI to 1.35 then it goes on to say QPI@1.39 in parenthasis along with CPU at 3.2. Does he mean CPU at 3.2 ghz? I had my i7 manually overclocked to 3.8 (at stock voltage settings) before i decided to try and fix this 4 of 6 gigs of ram issue. I have been keeping the i7 at stock clock settings until i get this resolved.

to be honest, this issue is not effecting my gaming performance or operating system stability at all. I'm just trying to get all 6 gigs up and running.

Anywho, any other ideas or is there more than one place I need to change my QPI settings? All i did was set BIOS 904 back to default settings and then went into QPI RAM voltage settings and moved it to 1.35v and my DRAM bus to 1.64v. Am I missing something else?
Thanks!
m
0
l
December 8, 2009 7:53:48 AM

This can be a number of things i 2 have had this problem...

right now im waiting on a new set of ram sticks corsair dominators would only read 4 out of 6, but i think this is due to a faulty ram moduel cause when i only load with 1 of them i would get a bluescreen, when i had my ocz's before i rma'd them they would always show 6 gigs but had error in memtest, thats why i decided to go with different memory.


As far for you, this is what you wanna try...

since you already messed with voltages, try re seating the cpu, while doing that check the socket for bent pins where the cpu is placed (very common problem)

if that doesnt work before you go replacing the CPU it may be a bad memory controller. What you can do is try a different set of ram. If that doesnt work it could be the motherboard.

Also if you have an after market cpu cooler make sure its not on to tight maybe not getting good contact.
m
0
l
December 8, 2009 11:37:42 AM

Last night I took a single 2gig stick of ram and individually tested each DIMM. I was told by asus this would be a way to check for a bad DIMM slot.
Slot A1: System booted - little orange light turned on by the DIMMS saying RAM was found.
Slot B1: System booted - little orange light turned on by the DIMMS saying RAM was found.
Slot C1: System no boot. No Orange light.

I reseated the CPU a couple times and checked for tightness on my Zalman. I put it on snug but the second the screws were firmly in place i stopped screwing them in.

I think my Slot C1 is bad. I'm just baffled on why CPU-Z still picks it up?

Also, when you say "before you go replacing your CPU, it may be a bad memory controller". Isn't the memory controller on the CPU? I'm working with an I7. I checked each stick of ram using Slot A1 and memtest86+. they all passed.
m
0
l
December 8, 2009 12:51:11 PM

Yea i was tired last night and the way i worded that came out a little crazy. I was trying to suggest it may be your memeory controller on your cpu, haha sorry about that. Right now im on that step, if this new ram that im getting does not work... cpu is the last thing to be replaced, because mobo has already been replaced.

Also cpu-z does that, why it does that i dont know. Every where ive read including mine cpu-z picks on all 6 gigs. Even though it all passes you should still try booting up 1 stick at a time and messing around in windows, watching videos, playing a game etc make sure everything is ok.
m
0
l
December 8, 2009 1:48:00 PM

uhg. so much work for so little "real world impact" lol. the difference of performance from 4 to 6 gigs and dual to tri channel is minimal at best. Yet my OCD won't allow me to just let it go!
m
0
l
December 8, 2009 5:02:53 PM

why would you let it go???? you payed for 6 gigs you would want 6 gigs to work. Dont feel to bad, i built this computer when windows 7 came out and been battling with it since then. im finally coming close only thing is newegg is taking forever to send out my order.
m
0
l
December 8, 2009 5:09:24 PM

yeah, newegg won't take my MoBo back. not sure why, i purchased less than a month ago but the option is greyed out under RMA. Soooo, i'm working through ASUS manufacturer's warrenty....If I can get a hold of them.

If I RMA this board, instead of fixing it they will probably send me a new board. My Windows 7 x64 is a Newegg OEM purchase. Do you think I will have to buy a new copy of windows 7 since it's registered to the defective board? From what I understand, there is no phone support for OEM Windows 7. So when I try to reinstall on the new board it will say that it's already registered on another computer, then I won't be able to properly activate it. Who knows...
m
0
l
December 8, 2009 5:49:16 PM

No i didnt have to re buy windows 7, well oh.. but you have the oem, i dont know how thats really going to work. I hear there is a way to un tie the cd key from a motherboard, also it wouldnt hurt to just call microsoft and try... Have you tryed another set of ram sticks, before you do your motherboard or all the other steps???

because this is my 2nd board and im having the same problem. I went from an Asus P6T and an asus P6T deluxe.

its just crazy to me how so many people are having this problem.
m
0
l
December 8, 2009 6:07:34 PM

Yep, i went from Cosair xms3 to the OCZ gold because i thought it was the RAM. That didn't fix the issue. There is a common theme with ASUS motherboards only detecting 4 of 6 gigs of ram. however, I think mine is a seperate issue because it won't boot when i put the one stick in slot C1. I think that shows that the DIMM slot has malfuntioned....or never worked to begin with.

If I can't get my windows reactivated with the OEM version, I would be pretty upset with M$ because I JUST installed it onto a bad board...but I'm pretty sure I can get it reauthenticated on the New motherboard...I just hope I don't have to take untraditional measures to do so ;P.
m
0
l
December 8, 2009 7:04:29 PM

Yea just call microsoft and explain your situation. Have you contacted Asus already?? asking for an rma, if you recently bought the board, they should do a thing where they send you 1 first before you have to send yours back.
m
0
l
December 8, 2009 7:28:31 PM

I just requested for an RMA by using the website. http://livesupport.asus.com and filling out the request form. You think I should I also call them?
m
0
l
December 8, 2009 8:09:21 PM

I called them, makes me feel better knowing i got to actually talk to someone. Just word your words carefully, tell them that you have tested all sorts of ram even tell them that you tested a different cpu, and your confident that its the mobo.
m
0
l
December 9, 2009 3:12:06 PM

Im happy to report i got my new ram this morning and its steady reading 6 gigs of ram THANK THE LORD!!!!!!!!!!!!!!!!!!!!!!!!!
m
0
l
December 9, 2009 3:15:11 PM

Asus is sending me a new MoBo and I just need to send the defective one back.


So you are using Cosair? That's what i traded for my OCZ Golds. However, when i boot one gig at a time with each stick, they all work just fine.
m
0
l
December 9, 2009 8:36:56 PM

yea i was using ocz gold reason i switched to corsair cause those ocz's were defected and had to rma them, then it i happened to get a defective set of corsairs, ordered new ones came in this morning popped them in everything read fine, and also returned the defective corsairs today, they are corsair dominators 1600 8-8-8-24

just to make sure i rebooted like 10 times, and went to a complete shutdown 5 times. they are now in xmp mode, running memtest while im at work.

In your case it may be your motherboard. since you said they all work when you pop them in 1 at a time, and you got it to boot all those times and didnt get any bluescreens or anything. For some odd reason when you get your new motherboard and it doesnt work, your down to the last thing just like i was, which is the cpu, which i doubt its that but dont count it out.
m
0
l
December 16, 2009 12:20:49 AM

You're not going to believe this....or actually you will lol.

I individually tested each stick of my ocz gold. They checked out OK.
I then tested each dimm on my mobo. slot c1 wouldn't boot with one stick of ram. Sooo, I figured it was the mobo and placed for an RMA. ASUS rocks and sent my my new mobo in like no time flat. I hooked it up, and STILL only 4 gigs are showing. I'm starting to think it's the ram. I had a set of corsair that also only showed 4 gigs of ram. maybe i need to try again...third times a charm.

i checked the pins on the cpu pad...they are straight.

this is a headache....i need a beer.
m
0
l
December 17, 2009 3:22:20 AM

haha could be bad luck, 2 sets of bad ram, happened to me.
m
0
l
!