Sign in with
Sign up | Sign in
Your question
Solved

GA EP45 UD3P Sata II HDD problem =(

Last response: in Motherboards
Share
December 3, 2009 10:55:21 AM

Hi, I recently purchased a new computer and it arrived the other day. I went about setting it up but encountered a problem with installing the OS onto the HDD, I was forced to install my OS on my older, smaller and slower IDE HDD but would like to get this SATA II HDD to work.

Ok I'll start out with my parts and a little more information on the problem (spent 4 hours on this yesterday so frustrated lol)

Motherboard: GA EP45 UD3P rev 1.6 http://www.newegg.com/Product/Product.aspx?Item=N82E168...

HDD: SAMSUNG HD080HJ Sata II 3.0gbs HDD

RAM: 2 x 2 gb corsair dominator dual chan 1066mhz

CPU: intel core 2 duo e8400

Anyways heres the problem:

When I go to install windows XP professional (32bit) on my samsung sata drive I get the formatting part on my xp install and it pops up with the same message every time, 'Setup was unable to format the partition', the HDD is recognized in the bios and I'm hooking it up the SATA_0 and I've tried all the SATA_0-5 ports, I even tried the GSata ports (0-1) to see if it would help.

After a few hours of playing around with different sata slots and a few bios options (I still may be missing something) I finally gave up and just installed to my old IDE 10gig HDD.

I should also note that the CDROM I'm installing from is an old IDE CDROM and I don't know how that interacts with samsung SATA drive.

Maybe you guys can help me trouble shoot the problem.

Thanks for your time!
December 3, 2009 12:18:02 PM

Thanks for the reply, can't slipstream because I don't have a burner and I can't get an adapter atm, any other possible work arounds, perhaps involving another HDD? I have 2 IDE HDDS, 1 Sata and a usb key rofl.
m
0
l
Related resources
December 3, 2009 12:20:13 PM

I noticed this on the link you provided.

Quote:
If you BIOS has an option to change your hard disk mode from SATA to IDE then you can just pop in the good old Windows XP CD and get it set up within minutes. But if it doesn’t, then you have to do it the other way as mentioned below.


My bios has a ton of options, do you think it can support this or w/e? or am I misinterpreting it.
m
0
l
a b V Motherboard
December 3, 2009 12:21:06 PM

Put the SATA drivers on the flash drive and hit F6 during the installation when prompted for drivers.

EDIT:
Sure you can try turning off AHCI.
m
0
l
December 3, 2009 12:27:03 PM

alright I'll try it thanks
m
0
l
December 3, 2009 12:37:49 PM

My bios has this option.

SATA Port0-3 Native Mode-DISABLED (Allows the SATA controllers to operate in Legacy IDE mode.)

Would enabling Native Mode work instead of trying the usb key thing?
m
0
l
a b V Motherboard
December 3, 2009 12:38:26 PM

Sounds like a plan. Try it.
m
0
l
December 3, 2009 1:45:14 PM

Urg, can't even get into bios now with sata HDD connected, it just sits at bios screen for 10min and is unresponsive to everything.

I turn off the comp, unattach sata and bios and everything is fine. It wasn't doing this like 2hours ago, it was showing in bios but not allowing me to install windows on it, now I can't even get into bios with optimized / fail safe settings.

Only thing I've done in the past few hours is update windows from SP1 to SP3 and update mobo chipset / audio driver.
m
0
l
December 3, 2009 1:53:53 PM

does updating chipset affect bios or anything?
m
0
l
a b V Motherboard
December 3, 2009 1:59:54 PM

Keep it unplugged and then get into your BIOS. Make the AHCI change, plug it in while still in BIOS, then save and let it reboot.
m
0
l
December 3, 2009 2:06:01 PM

ok I'll try it. thx
m
0
l
December 3, 2009 2:45:07 PM

That allowed me to get back to windows installer but still says unable to format once I go to format it with NTFS

The weird part is that it sees it, it sees the previous partition that it failed to create and allows me to delete that partition and try to reformat it but with the same error everytime. It has to at least recognize the HDD because its showing the size of the HDD (77000MB) or something.

m
0
l
December 3, 2009 2:56:49 PM

I'm going to try the USB stick thing, I'm out of ideas if that doesn't work.
m
0
l
December 3, 2009 10:09:21 PM

USB key is a no go, I installed all the needed files on the USB but windows set up doesn't recognize it when I press F6. Just says floppy drive which I don't have.

Any solutions besides slipstream or diff OS?
m
0
l
a b V Motherboard
December 3, 2009 10:46:05 PM

Make sure USB devices are enabled in the BIOS. I've seen them set to off by default on some motherboards.
m
0
l
December 3, 2009 11:13:54 PM

The hard drive might be too big to be supported by xp unless it has sp1 or later.

install to the ide hard drive then use something like acronis trueimage to image to the sata drive... unplug ide drive and it should work.
m
0
l
a b V Motherboard
December 3, 2009 11:18:20 PM

It's just 80 GB. Even without SP1 it should handle that.
m
0
l
December 3, 2009 11:23:22 PM

USB is enabled, including USB keyboard, USB mouse, USB Storage, and USB 1 and 2.

One thing I noticed though was that the USB key shows up in windows partition set up as FAT32 3900MB (4gb) but the F6 thing still doesn't work.

You think formatting the USB to NTFS instead of FAT32 matters?

Either way I'm pretty close to just getting windows 7 from a friend since this *** is driving me mad.

Thanks for all the replies and troubleshooting btw.
m
0
l

Best solution

a b V Motherboard
December 3, 2009 11:26:42 PM

You'll find Win 7 the aspirin to this headache. You'll be up and already surfing online in under 30 minutes.
Share
December 4, 2009 1:12:23 AM

Not working with windows 7 either. Recognizes but says its not bootable / "Can't be installed to this disk"

In win7 I even accessed the USB and found the AHCI driver and tried to install it as AHCI but still no go.

What are the chances of it being the hard drive? Would the harddrive be messed up and still show up correctly in bios and still show up in windows installer with the correct amount of space?
m
0
l
a b V Motherboard
December 4, 2009 1:26:15 AM

There just might be some drive problems there.

Try this. Remove the USB drive. Windows might be looking at it instead of the HDD.
m
0
l
December 4, 2009 1:52:52 AM

tried it with the usb removed also, it shows up on the list in both XP and win7 with the correct space, USB has been both in and out as well. On windows 7 it shows the HDD then below it says "Windows cannot be installed to this disk, then some crap about making sure I have the controller drivers (which win7 should have for default SATA in a non raid or ACHI config right?) Either way I also found the AHCI .inf files and installed it in a AHCI configuration, it just isn't working.

Also shouldn't Setting SATA ports 0-3 to 'Native IDE' then plugging the sata drive into one of those ports cause it to act as a IDE drive and not need a driver? Because that didn't work either.
m
0
l
a b V Motherboard
December 4, 2009 2:00:39 AM

I'm reading a lot of people solved this problem by using a driver CD instead of a USB drive. That might be the solution.

Another option, can you get to the part where it lets you adjust partitions? If so, delete any partitions there and let it reformat it.
m
0
l
December 4, 2009 2:06:50 AM

On windows XP it lets me delete the old partition (makes a messed up partition when I try to format it)

Basically this is what happens, I get to the partition screen, I delete the partition, then I try to format NTFS (tried both quick and slow versions) and it starts formatting then like 10sec later it stops and it says its unable to format the partition and the "disk may be damaged" but thats just the default message I'm sure.

Also I tried the CD thing in windows 7 but it said that the drivers were unsigned or something and wouldn't work, so instead I downloaded from gigabyte.com and put on USB key, then searched USB key and it found the driver and installed it (was a AHCI GSATAII driver)

Also, is there a way to avoid the driver having to be "signed" or whatever for it to even attempt to load it in win7?
m
0
l
a b V Motherboard
December 4, 2009 2:23:59 AM

A few ideas.

1. Clean the install disc. Try again.
2. Back up the install disc and try the cloned disc.
3. Set BIOS to fail safe defaults.
4. Try a Ubuntu Live CD.
5. If works, use disk utility to reformat drive instead of Win 7 disc.
6. Run WD diagnostics (found on their web site).
7. Run memtest86+.
m
0
l
December 4, 2009 3:20:34 AM

Memory is good, WD diagnostics won't work since I can't get it to show. Drive doesn't show up even as a slave running off my HDD thats working.

This is the message I get in XP when I get to the partition screen now
76286MB Disk 0 at ID 0 on bus 0 on atapi
<Setup cannot access this disk>

Then next screen is bsod which says something along the lines of.
stop 0x0000008e (0xC0000005, 0xF84C49A8, 0xF7F0775c, 0x00000000)

Get the same message in both, Native Mode (SATA) and Legacy IDE mode.
m
0
l
a b V Motherboard
December 4, 2009 3:29:31 AM

Do you get any error codes trying Win 7?
m
0
l
December 4, 2009 3:51:06 AM

Nope, just says at the bottom of the little tool "Cannot be installed to this disk" when I click on the little link it says some default crap about making sure disk controller is installed.
m
0
l
December 4, 2009 3:51:24 AM

I'm about to chuck this hard drive out the window haha.
m
0
l
December 4, 2009 3:20:44 PM

I realize this is a pretty uncommon error and could very likely be caused by a messed up HDD. Just want to make 100% sure before I send this crap back (got it on ebay haha)

Windows 7 has SATAII drivers built in right?

m
0
l
a b V Motherboard
December 4, 2009 3:29:01 PM

All that's built so far or installed it one have worked without the need to install SATA drivers but I've heard stories of others not being as fortunate. My main system also has a Gigabyte board (not the same model as yours though) and it didn't require SATA drivers.

But, you can always try them. I can't hurt anything.

http://www.gigabyte.us/Support/Motherboard/Driver_Model...

Select your OS at the bottom in the drop down list and download the SATA RAID driver (I know it says RAID but it's a base SATA driver too).
m
0
l
December 4, 2009 3:46:44 PM

yep tried the driver on usb thing and windows 7 recognized it and installed it but still didn't work.

has to be the hard drive is only thing I can think. I think its some foreign model or something I'm not sure, the reason I'm curious is because I've found very little support for samsung HD080HJ on the web.
m
0
l
December 4, 2009 7:25:03 PM

Tried to see if my old micro atx K8V-MX asus board would recognize it as either 1.5 or 3.0gbs and it didn't, guess that seals the deal that the HDD is the problem.
m
0
l
a b V Motherboard
December 4, 2009 10:52:48 PM

Sorry we couldn't find a way to fix it but at lest you know the source of the problem now.
m
0
l
December 4, 2009 11:30:25 PM

Nah, I appreciate troubleshooting tips, learned a lot about SATA, IDE and my motherboard in the process hehe.
m
0
l
December 9, 2009 3:34:40 AM

I was going mad trying to install XP on my new EP45-UD3P system also. I had problems with several different flavors of Linux too. I had a few HDs (Seagate) start reporting incorrect sizes.

Anyway, I put in a new (yet again) HD, still kept having headaches w/XP. So, I got Windows 7 a week or so ago, installed that (clean install) and everything went GREAT.

I though Vista was a real let down, but I'm very happy w/Window 7.

There do seem to be a few features missing from my audio driver, however.
m
0
l
a b V Motherboard
December 9, 2009 3:44:39 AM

See if a Vista driver exists. Vista drivers tend to be compatible with Win 7.
m
0
l
Anonymous
a b V Motherboard
December 13, 2009 7:36:13 PM

I'm having the exact same problem right this minute on my GA-EP45-UD3P. I am sure it has to do with there are 2 RAID/AHCI controllers on the southbridge. One of them with the 6 orange SATA2 connectoer is the Intel ICH10R. The other controller with the 2 purple SATA2 connectors is the Gigabyte SATA2 AHCI/RAID controller. I think both of us are trying to use our orange connectors for our boot drive. During my Windows XP Pro 64 bit install none of these controllers are recognized unless you hit F6 key when it prompts during install. I can then successfully load the driver for the purple Gigabyte controller from my Sony VAIO USB floppy drive. But I don't have my boot drive on the purple plugs, I have 2 SSD's in RAID0 on the Orange Intel ICH10R controller because I am geeting a 3rd SSD for Christmas and need 3 connectors on same controller.

I am still downloading from Gigabyte site and trying different drivers. This next time I'll F6 load ICH10R RAID driver from floppy and try telling it "yes use this instead of the Windows driver" when it complains Windows already has a driver for this controller. If that don't work I'll just suck it up and put the boot drives on the purple Gigabyte controller I guess, or use Windows 7 which I don't want to do because my XBMC xboxes can't access shares on Windows 7 anymore (unless I allow anonymous guest no password access (on a large network with 3 wireless access points yah right) , and the onboard Gigabit NICs won't work with 64 bit Windows Ultimate (yes I downloaded and reinstalled every driver invented by MS, Realtec, and Gigabyte the drivers install fine but won't work (code 10 driver cannot start in Dev MGR). I had Windows 7 working once before on this machine, I don't know how I got the NIC drivers loaded though. I knew I should have bought ASUS but this stupid board won the newegg cup award like 3 times. Go figure. I'm bidding on a dual gigabit Intel card now so we'll see I guess.
m
0
l
!