Sign in with
Sign up | Sign in
Your question

SSD - total freeze on boot - expert help, please!

Last response: in Storage
Share
February 21, 2011 8:36:48 AM

Hi.

I would need the expert opinion of someone who (preferably) understands problem solving, electronics, signalling, how SSDs communicate with Sata controllers, driver implementations, Windows 7 - in the guts.

I have this problem for over 6 months now, and nobody was able to provide me with an answer, so I ask you guys to shed some light into this. This is a very common problem, as it appears on a lot of forums, but it seems there's no answer. It spans accross multiple SSD manufacturers (Crucial, OCZ, Intel) and notebooks. I have already tried some "classical" solutions, but to no avail.

My story:
I have bought an Asus Notebook G51-Jx-A1, and a separate Crucial M225 Drive (128 GB). Though they should work together, it seems it's a fundamental flaw in the hardware/software architecture that doesn't allow them to function properly.

My config:
Notebook Asus G51Jx-A1, Core i7-720QM, 6 GB RAM (Hynix), Geforece GTS360M, Windows 7 Home Prem. 64-bit, 500 GB HDD(original)
+
SSD: Crucial CT128-M225, 128 GB.

The problem:
When trying to boot into Windows, right after the Starting Windows logo appears, the SSD completely freezes, with the HDD led solid on. Only hard reset works. Problem appears in approx. in 3/4 boot attempts. It doesn't seem to have a pattern. It appears often, but randomly. I can "trick" it into booting (again, no pattern, but this seems to reduce number of boot attempts) by pressing F8 and choosing either "Disable driver signing" or "No auto restart in case of failure", or "Start normally". I choose different options, but randomly.
First, it appeared only during boot, but not during system operation. Now, it appears during system running as well, stays for approx 30 seconds, then resumes normal operation. If during boot, doesn't resume at all.
I have noticed that after reinstalling the drivers (any of them), the problem seems to alleviate, only to come back after a few tries.

What I have singled out:
It appears to be either a hardware or software issue between the drive and the Sata controller.
The system works with no problem, when I run it with the SSD connected to the PC by eSATA port. As soon as I plug it in the internal port, it begins misbehaving.

Things I have tried:
-updated BIOS;
-updated drive Firmware;
-different drivers: IDE, AHCI (Microsoft), AHCI (Intel RST last 3 versions)
-enabled/disabled TRIM, NCQ, Write Caching etc.
-Reinstalled Windows (both "restore function", clean OS install), (also added Intel RST drivers before OS install)
-format and partition allignment (both from OS Install options and command line);

Other important info:
- I do not have an option to switch between IDE and AHCI mode in BIOS; all was done at Windows level
- BIOS is pretty much locked. All I can change is boot order and time/date.
- Sata controller: Intel HM55 Chipset, Intel 5-series 4-port SATA controller.
- Crucial uses Indilinx controller on their drive.
- I have only one SATA port, glued to the Mainboard; I have one eSATA port, and a external Caddy.
- The system runs perfectly fine on the original mechanical HDD. No freeze whatsoever.

I would like to find where the problem is, hardware, software, to see if it's the notebooks' fault or the hard drive's fault. I want to know if other SSDs would work with this notebook or it would be the same problem with other brand/model.

Thank you very much for your help and hope we can find the issue for this once and for all.
G.
a b G Storage
February 21, 2011 1:44:29 PM

Hi and welcome to Tom's forum.

There is a way to know if the SSD is the problem: Test it in another rig (desktop, laptop) I'd think more in an SSD problem that a SATA port problem since you old HD works without freezing.
February 21, 2011 11:28:06 PM

Hey Saint19.
Thank you for your reply. I would try that in a few days, since I have an older sony laptop. The thing is I would not be able to replicate the same conditions.

As I stated in the original mail, the SSD works fine when connected to the eSATA port.
The only thing that I'm thinking of is that because the SSD has such a high number of IOPS, it might drive the controller crazy and loose track of read commands, which forces the drive into "lockdown" mode. The Sata port in the Sony laptop is only Sata 150 so being inherently limited, I don't know if the same problem might occur. The same story goes with eSATA. What do you think?

G.
Related resources
a b G Storage
February 22, 2011 1:28:25 AM

The SATA port can't accept more info that his max rate, so, in this scenario the SSD is bottlenecked for the SATA port.

Now if the SSD is specially designed for run under SATA 6Gb/s, the problem can be there.
February 22, 2011 7:37:02 AM

Hey.

Ok, it may be a bottleneck, but when it is not allowed to "strech its legs", why does the drive "take all his toys and go home"? :) )

As it is an '09/'10 model, it's designed for SATA 300, si it should have no problems. The Notebook is also rated for Sata 300, so they should kiss and make up, but they don't.

One interesting thing. If I install the Intel RST drivers, it also installs an "overview type" app. There, you can see that the SSD is set to Sata 150 mode. And benchmarks from ATTO confirm that the performance is capped (max 130 or smth.). So if it is a throughput problem this should have worked. But the freezes still appear. If I plug it into the eSATA port on the other hand, it works with no problems.

This has led me to believe that the problems may appear during intensive IOPS operations, where the drive sends too much information for the controller being able to interpret, and then they just loose the sync.

Do you know the inner workings of this communication process? How the electronic signals between the controller and the drive work? Or do you know how to get in touch with a electronics engineer or someone at the labs of THG? Maybe they can help.Because this is some pretty nasty stuff. I mean, I don't want to brag, but I consider myself a pretty smart dude. So I downloaded the controller tech specs from Intel, I thought i can alter the registry and solve the problems. Man, o man, It gave me a head ache. :) ))))

Any other help would be very much welcome,

George
a b G Storage
February 22, 2011 10:58:38 AM

A good solution is contact to Crucial support, they can help you.

I know the basci things about devices communications, the CPU request for the info in the data bus, the SSD put that info in the data bus and the CPU read it again using the communication bus.
February 22, 2011 1:25:10 PM

Yeah, I have already tried with the customer support(s). These guys are pretty much useless these days. They're a little better than the robot machines. I called the Crucial tech support in UK and there was this guy telling me to do basic stuff, like I'm a noob, and he was like...hurrying to get rid of me. He quickly jumped to "replacing the drive", which is bad for their company!!! I was trying to tell him, "Dude, I want to find the problem, not replace the drive. If the problem is not the drive, your company is going to loose more money and I'm not going to solve my problem".
I didn't manage to reach his brain. he said he'll send me a list of things to try and if not, they'll replace my drive. I haven't received that list yet.

With Crucial US, I had a little bit more luck. There was this girl, which had something inside her head, so she told me the first intelligent thing: "It has to be a software issue, if it comes randomly. Hardware problems are consistent." But when I tried to ask her about registry modifications, she told me she's not allowed to talk to me about that, because I can sew the company if something goes bad. Geez, it's the US. I forgot :) 

I would really like to talk to the engineers behind these things, the ones that actually make or repair the stuff, not the barrier of "Public relations" people. Unfortunately, I know nobody that good or someone who has the time and patience to solve this problem out.

I know that you may be busy, but I wanted to ask if you can forward me to some engineers here in the forum (being a Moderator, I suppose you know a lot of people.)

Thank you again for your time.
G.
a b G Storage
February 23, 2011 3:13:55 AM

Ok.

Let me talk 1st with one of our reviewers, I think that he can take a look of your problem.
February 23, 2011 6:56:53 AM

Thanks a lot! I'll be patiently waiting...

G.
a b G Storage
February 24, 2011 1:53:11 AM

Hi dude.

Here is the Chris answer, he is the Tom's Hardware Worldwide Editor-in-Chief and author of The OCZ Vertex 2 Conspiracy: Lost Space, Lost Speed? article.

Quote:
From reading katana’s thread, I would say with almost certainty that the problem is with his laptop’s internal SATA port. The eSATA port should run to the same controller, so the fact that it works fine there is indicative of a connection issue. He could double-check by connecting another drive to the same port or connecting his SSD to another machine, as you suggested. It just seems like it’s intermittently not getting enough power or losing its signal on one or more of the contacts. Does that sound plausible to you?
February 24, 2011 9:23:04 AM

Hey man.
It's a very good point. Now, since I know that SSD's consume less power than mechanicals, it shouldn't be an issue of maximum power draw. (eg. it doesn't have enough juice all of the sudden.). I have also looked at the golden contacts of the SSD, and they all have even wear marks, and I have almost always connected the drives in their caddys and screwed them tight in. So the issue may be at the electronic signals.

Now I don't know how the controller operates or how voltage fluctuates during the read/write operations, so I am playing a little "educated guess" game. I think that the voltage may fluctuate, and the rhythm is dictated by a clock of some sort (either the system's or the maybe the controller has in internal clock.). The freezing problem seams to appear during intensive I/O operations (such as boot). (as side-infomation, I have also copied large amounts of data from one drive to the other, and inside the same drive and never got a lock there.). The main difference between the SSD and the mechanical is a lot more IOPS, which probably (I'm guessing here) require a much faster voltage switch per second, something that the controller isn't used to.

Now I didn't do a IOPS metering, but I may suspect that there are 2 differences between the eSATA and the SATA connection. The SATA is connected to the mainboard and the controller directly,through a shorter route. FOr the eSATA I'm using a 1.5 m cable + a HDD caddy (which has its own board and electronics). It may not sound much of a difference, but maybe those few extra nanoseconds that it takes the electrons to reach the drive in eSATA mode gives the controller enough time to wake up and do the next voltage switch.
This is the most I can think of right now. Can Chris confirm this? I mean, does it make sence?

Thanks again for both of your time and support.

G.
February 24, 2011 11:47:34 AM

It might help if you tell us all how you have the drives partitioned and if you have OS related files installed between the two drives. Does Windows boot with the 500gb drive disabled?
a b G Storage
February 24, 2011 11:51:37 AM

Pretty sense, eSATA works with different specs and different speeds. You can try to do what we say, test the SSD in another rig to confirm the SATA problem.
February 24, 2011 12:32:09 PM

Sure. I would test it in my old sony laptop in a few days, when I'm a little more free from university. It would take some time though, because I need to reinstall the OS etc.

@currentuser:
I have the 500 GB original HDD drive partitioned as: hidden part, C drive (26%) rest D Drive. I have used the "restore function".

The SSD had multiple configurations: I once made 6 partitions on it once with different block sizes to test speed differences, but usually when I ran it in my PC, I had 2 main configs:

-first I cloned the HDD on the SSD with Acronis. I partitioned it in 2 (about 40% C and 60 % D).
- the other way was a clean format and clean OS install from a borrowed OEM disk.

I have tried the formatting in different ways, different options, format from Win install menu, format with diskpart from command prompt etc. Nothing seems to have effect.

When I did tests, each drive had it's own operating system. (Both Win 7 HP 64-bit)

Windows boots every time with no problems in the following configurations:
- HDD internal Sata port, SSD in eSATA port. Boots on operating systems on both drives. no problems.
- HDD internal Sata port, SSD disconnected
- HDD disconnected, SSD eSata port.
- HDD eSATA port, SSD disconnected.

System freezez during boot randomly and about 3/4 of times:

-SSD in internal SATA port. Doesnt' matter if HDD is connected or not to the external eSATA port.

Hope this helps,
G.

February 24, 2011 2:08:01 PM

It appears the SSD works better with the latency introduced with a sata cable. Sounds like a timing problem. I could only speculate on what the problem is. The first thing I do in these kind of problems is re-seat the ram and check if the memory timings are correct. Of course over clocking would cause this. But you didn't say you were over clocking. At least everyone here has a better idea on you are dealing with. It could be something as simple as a bios update to fix the problem. Having the latest bios doesn't guarantee compatibility with SSD.


katana_george said:

@currentuser:

Windows boots every time with no problems in the following configurations:
- HDD internal Sata port, SSD in eSATA port. Boots on operating systems on both drives. no problems.
- HDD internal Sata port, SSD disconnected
- HDD disconnected, SSD eSata port.
- HDD eSATA port, SSD disconnected.

System freezez during boot randomly and about 3/4 of times:

-SSD in internal SATA port. Doesnt' matter if HDD is connected or not to the external eSATA port.

Hope this helps,
G.

February 26, 2011 10:24:22 AM

Cloning can introduce all sorts of problems.
December 18, 2013 9:07:26 AM

Hi everyone,
I know this is my first answer here. But I want to share my sulotion for almost the same problem if not the exact one.
After I read a lot with no solution found I have done the following:

My PC spec:
Cpu: I7 4770k OC to 4.5GHz
SSD: Curcial M4 256GB
RAM: 16GB 2133
Motherboard: Asus ROG Maximus VI hero
OS: Windows 8

Problem: Windows just freezed in boot.

Solution: I went to BIOS > Boot > Compatibility settings and I disabled it

Disabled also the secure boot.

Hope it will work with you guys. Good luck
!