Solved

HD 5770 wont Overclock anymore

hi everyone , as u can see im new here and my English isnt perfect ,

i have a HD 5770 and i used to overclock it to 960Mhz core and 1430Mhz memory until today ! from today morning i cant overclock this thing more than 880core and 1330memory , i know what u wanna say but im somehow sure its not my PSU , why ? because i overclocked my Phenom II 955BE to 4.0Ghz (always on stock and 1.2Vcore) and Vcore of 1.48 and u know its huge amount of wattage i've drained from my PSU but it worked completly stable , plz someone give me an idea , its driving me nuts cuz i afraid my 5770 is near the end and i havent changed a single piece of hardware or my OS .

my system spec : Phenom II X4 955BE - 6GB 1333 Geil - saphire HD 5770 - 480W Green PSU (im living in Iran and Green PSU is OCZ PSU acctualy and its a very good PSU here with 5 years warranty !) Asus M4A77TD Mobo , Windows 7 ultimate 64-bit , and its about 1 month only that i have this rig , tanx for ur helps and ideas .
8 answers Last reply Best Answer
More about 5770 wont overclock anymore
  1. i dont think its dying out ! i never overclocked it , just 1 full day only to play damn Metro 2033 , that 1 day i overclocked it i used all the same hardware and software im using right now ! this is the most weird thing i ever had with PC , that's why i always choose console over damn expensive and useless PC ;) but plz someone help me here to find out about this !!!
  2. Best answer
    Take the memory back to stock, see if you can get it to go from there, your memory overclock was just to high and you likely punched out the ram
  3. damn ! a weird problem and a more weird way to fix it ! i reconnected the 6-pin power connector and now it works right on thoese freq's again !!! why was that realy ?!
    spentshells i think ure right and now i read more i see 1430 for memory is high , now its 960 and 1380 but anyway it was stable on 1430 with furmark !
  4. cables are the first things we should always check but few remember the "silly" small things...glad you got it workin! :bounce:
  5. cable was connected i just Reconnected it ! i still cant understand it but anyway tanx alot dude =D
  6. maybe it just was not seated right or you had a little piece of dust blockin one of your pins maybe....but at least its up and workin now......wish I could have recommended that to ya...but as you see there are ppl here to help ya( if they can) so come back anytime if ya havin some troubles LEGEND-90
  7. Best answer selected by LEGEND-90.
  8. i have 1000/1250 and get better results ccc 15.4
Ask a new question

Read More

Graphics Cards Overclocking HD