Sign in with
Sign up | Sign in
Your question

I5-2500k turbo boost

Last response: in Overclocking
Share
May 28, 2011 6:58:08 AM

Hi, I just recently got a new CPU and I have never had any experience with i series CPUs and turbo boost. It is bothering me, that whenever my PC is idle I get ~1600MHz, which is fine, because it helps to save power, but when I play games with heavy load, or do a benchmark, it goes only to 3400MHz. I have never seen it go up to 3.7GHz (I use CPU-Z),
and never to 3.3GHz. It should normally be at 3.3GHz and at 3.7Ghz with turbo boost. When I disabled turbo boost in bios, I got 3.3GHz at max load. I use Asus P8P67 Pro.

Can anyone explain me why there's only 100MHz increase with turbo boost and why I don't see the maximum 3.7GHz with turbo boost on?

Also, if game only uses 1 core at 100% and doesn't use any other core, all cores go up to 3.4GHz, is this a normal behavior?

Have a nice day,
Martin

More about : 2500k turbo boost

a b à CPUs
May 28, 2011 2:47:22 PM

Check your Turbo Boost multiplier in Asus AI Suite II software or in BIOS. Can't think of anything else. I also use P8P67 Pro and I get the same 1.6 GHz on idle, but full load and Turbo work fine (as applied to my i7-2600).
May 28, 2011 6:31:57 PM

Hi, thank's for reply.
What mode in bios do you use? Power saver, normal or extreme (or something like that...) ?
Related resources
a b à CPUs
May 28, 2011 7:56:17 PM

I switch BIOS to "Advanced" mode - that's where all the settings are. If I enter standard mode, the power settings are on "Normal".
May 29, 2011 2:24:21 AM

Switching to normal helped, Thanks.
Unfortunately now EPU is disabled. Could you be more specific where to find turbo boost multiplier in BIOS, or Asus AI Suite II, or both?
I was unable to find them.

P. S. Were you lucky enough to know what positions on TPU and EPU switches mean on or of? And what is the difference if I use BIOS to configure my PC?
a b à CPUs
May 29, 2011 2:17:18 PM

In Asus AI Suite II, go to "Tool" tab and open TurboV Evo, then go to More Settings --> CPU Ratio. In BIOS, it should be somewhere in the CPU settings... look around, it's very easy to spot.

I keep EPU/TPU switches on, they're supposed to be some CPU temperature/voltage control units or something... The "ON" position of both switches mean moving the slider towards the bottom right corner of the motherboard, provided that top left is the one where the CPU sits.

The difference in using the BIOS is that there're more settings there and, as far as I can tell, they're applied right from the start of your machine, while AI Suite II applies them only on OS boot.

BTW, why is EPU disabled now? Where does it say that?
May 29, 2011 7:39:38 PM

In BIOS -> Advanced -> Ai Tweaker and there you should see EPU Power Saving Mode. I am not 100% sure it means EPU itself is disabled, but I'm pretty sure that's the case.

Damn, I went into bios, restored default configuration, then changed settings as before and I once again get 3.4GHz with turbo boost...
CPU ratio tab asks me to restart PC. The last time it asked me to restart I got unstable 4.3GHz with turbo boost, which crashed my system. I would prefer to use BIOS for that, do you know which option is what I'm looking for and what value should I set it to?

Later I'll probably try to open my case and make sure all switches are turned on to see what will happen.
a b à CPUs
a b K Overclocking
May 30, 2011 5:22:11 AM

Turbo boost only gives you one extra bin for all 4 cores ~ 3.4 ghz. Run something like Super Pi that uses one core and you should get 3.7 ghz

Or better yet, just overclock it
May 30, 2011 8:46:00 PM

Thanks to amk-aka-phantom, I just figured out, that my TPU and EPU were always off. After turning them on first thing was that bios started twice and when I set mode to normal, I got 4.3GHz with ~1.35V. Didn't stressed that, then turned off PC, after it loaded bios (twice) I set mode to power saving and after restart BIOS loaded only one time and I get 3.7GHz with ~1.2V at load :)  Seems to me, that TPU and/or EPU might cause this double startup if configured incorrectly.

Bearclaw, that's what I've been reading about, but I didn't found a way to observe this. Maybe that 3.7GHz that I'm getting is not from turbo boost, but I really don't know anything more and really like to know.

I'll probably try to go through one tutorial later to get a better understanding of my system.
Tutorial: http://www.clunk.org.uk/forums/overclocking/39184-p67-s...
a b à CPUs
May 31, 2011 2:15:03 PM

P8P67 boards do weird things to the CPU... my i7-2600 overclocks itself to 4.2 GHz despite its locked multiplier (BCLK stays on default value) and maximum rated clock of 3.8 GHz with Turbo Boost.

Experiment around: try switching off Turbo Boost in BIOS and see what your maximum frequency will be.
a b à CPUs
a b K Overclocking
May 31, 2011 3:41:26 PM

Marsas said:
Hi, I just recently got a new CPU and I have never had any experience with i series CPUs and turbo boost. It is bothering me, that whenever my PC is idle I get ~1600MHz, which is fine, because it helps to save power, but when I play games with heavy load, or do a benchmark, it goes only to 3400MHz. I have never seen it go up to 3.7GHz (I use CPU-Z),
and never to 3.3GHz. It should normally be at 3.3GHz and at 3.7Ghz with turbo boost. When I disabled turbo boost in bios, I got 3.3GHz at max load. I use Asus P8P67 Pro.

Can anyone explain me why there's only 100MHz increase with turbo boost and why I don't see the maximum 3.7GHz with turbo boost on?

Also, if game only uses 1 core at 100% and doesn't use any other core, all cores go up to 3.4GHz, is this a normal behavior?

Test this:
Reset the BIOS back to default multipliers. Do a Prime95 torture test, and in the "Number of torture test threads to run" field enter 1. CPU-Z should show 3.7GHz. Then try it with 2, 3, and 4 in that field and you should get 3.6GHz, 3.5GHz, and 3.4GHz respectively. Basically, you should never see your CPU at 3.3GHz because it should always either be idle at 1.6GHz or Turbo'd to 3.4-3.7GHz.

If you overclock, it'll be a different story as Turbo Boost doesn't apply normally. Your CPU will either be at 1.6GHz idle or the full overclocked speed no matter how many cores are loaded.

amk:
my i7-2600 overclocks itself to 4.2 GHz despite its locked multiplier (BCLK stays on default value) and maximum rated clock of 3.8 GHz with Turbo Boost. said:
my i7-2600 overclocks itself to 4.2 GHz despite its locked multiplier (BCLK stays on default value) and maximum rated clock of 3.8 GHz with Turbo Boost.

You can overclock a non-K CPU by +400MHz Turbo. What you have is normal overclocking behavior.
a b à CPUs
May 31, 2011 8:43:48 PM

Leaps-from-Shadows said:
You can overclock a non-K CPU by +400MHz Turbo. What you have is normal overclocking behavior.


Ah, good to know that... kept me wondering for a while. Thanks for the info.
June 24, 2011 4:54:36 PM

Marsas said:
Hi, I just recently got a new CPU and I have never had any experience with i series CPUs and turbo boost. It is bothering me, that whenever my PC is idle I get ~1600MHz, which is fine, because it helps to save power, but when I play games with heavy load, or do a benchmark, it goes only to 3400MHz. I have never seen it go up to 3.7GHz (I use CPU-Z),
and never to 3.3GHz. It should normally be at 3.3GHz and at 3.7Ghz with turbo boost. When I disabled turbo boost in bios, I got 3.3GHz at max load. I use Asus P8P67 Pro.

Can anyone explain me why there's only 100MHz increase with turbo boost and why I don't see the maximum 3.7GHz with turbo boost on?

Also, if game only uses 1 core at 100% and doesn't use any other core, all cores go up to 3.4GHz, is this a normal behavior?

Have a nice day,
Martin


You probably run on "high performance" power plan in Windows 7. Therefore core parking is disabled on your system.
That means all 4 cores are always active, and Tubro Boost will add only +100 MHz.

If you set to "balanced" power plan, then the core parking will be enabled, and Windows will sometimes park (set to sleep) up to 3 of your cores (depending on system load).
Then, the Turbo Boost will give +200/300/400 MHz, accordingly to the number of cores active.
a b à CPUs
a b K Overclocking
June 24, 2011 11:09:53 PM

That isn't correct. My system does Turbo Boost just fine with the Power Options set to High Performance -- or it did when I had it at stock speeds. It doesn't now because I have Turbo Boost turned off for my overclock.
August 10, 2011 6:43:08 AM

I have the same problem with the i5 2500k on Windows XP x64. The turbo boost feature doesn't go above 3393 Mhz. Does this have anything to do with BIOS settings?
!