Sign in with
Sign up | Sign in
Your question

Having a problem with 4870x2

Last response: in Graphics & Displays
Share
July 4, 2009 7:13:26 AM

I just purchased a Sapphire 4870x2. I had gotten everything installed properly and updated to the 9.6 drivers. Here is the problem: regular surfing, movie watching, etc is fine, but when I tried to play BIA Hell's Highway or CoD 4, I got restarted on for the first one and stuck on a screen with endless sound looping then streaming particles after a few moments on the latter. I am not really sure how to solve this problem. I've reinstalled drivers, DirectX 9.0c to the latest. I am wondering if it's a resolution issue or I have to do something else. My monitor can reach up to 1900x1200 and I am hoping that is not the issue. Here are my specs

Intel Q9550
4GB AData PC2 6400 Dual Channeled
SoundBlaster X-Fi Xtreme Gamer
Sapphire 4870x2 not OCed
Windows XP Pro SP3
WD Caviar 640GB HD
Kingwin 1000w PSU

I am using the 8-pin molex splitter for the card since the 8 pin with the psu didn't work. I'm assuming this is going to happen to all my other games. Any help will be greatly appreciated.

More about : problem 4870x2

July 4, 2009 8:43:32 PM

Newegg only shows 1 Kingwin 1000w psu. If thats the one you have shouldnt you be using one 6+2 pin for the 8 pin connector and a solid 6 pin for the other? If you are using the 4+4 pin connector for the 8 pin connection on the video card thats incorrect! That connector is meant for the cpu. I dont believe it supplies enough power for the video card.
July 4, 2009 8:51:47 PM

Yeah, when I used the 8 pin connector from the psu on the card, it didn't show any display, so I watched a video of installing the card and I saw a gentleman use the 8 pin connector that splits two 3 pin molex connectors. Now, maybe I should plug them directly into independent molex connectors instead of my fan ones (they are dual sided). I've never had a psu like this with dual sided molex connectors and I keep learning as I build new technology, so, if that's my mistake right there, I hope that solves it.
Related resources
July 5, 2009 12:52:44 AM

Ok, I used an independent cable and it didn't do the trick sadly. I'm now suspecting a possible driver issue or something else. If I don't figure this out within two weeks, I'll take it down to my local computer shop. They've helped me out when I am stumped. Sadly, I am limited to tools I have at home and though I am computer savvy, I am not superior. Any other ideas are welcome, I don't want to return a 380 dollar superior card for an error I know can be fixed. I also forgot to mention, my mobo is a P5Q Premium
July 6, 2009 6:08:01 AM

Eureka, solved it. Shut off Cataylst AI and the card is just amazing. Praise be to the heavens.
July 6, 2009 8:36:15 AM

http://www.tweakguides.com/ATICAT_7.html
Read about AI. I love this guide
From the guide:
"Note: As of the 6.7 Catalysts, Crossfire users should set Catalyst A.I. to Advanced to force Alternate Frame Rendering (AFR) mode in all Direct3D games for optimal performance. Once again, Catalyst A.I. should only be disabled for troubleshooting purposes, such as if you notice image corruption in particular games."
July 6, 2009 8:41:11 AM

GreyFox37 said:
Eureka

What is that a Greek word or something?
July 6, 2009 8:51:49 AM

No, its a tv show
!