Sign in with
Sign up | Sign in
Your question

Gtx 570 overclock crashing some games

Last response: in Overclocking
Share
May 29, 2011 8:54:42 PM

Hello
I have a evga gtx 570 overclocked to 1.075v/900/1800/1900. It is stable when playing crysis 2, modern warfare 2, left for dead 2, 3d mark 06, vantage, 20011, furmark, occt, and evga oc scanner. It crashes medal of honor(2010)and homefront unless at stock speeds. Is this normal? Does anyone know why it works with all those but not those two?

Thank You
a b U Graphics card
a b K Overclocking
May 30, 2011 4:04:24 PM

Play around with drivers - don't assume that the latest drivers are always the best.

When overclocking my 260 SLI system, until recently the most stable drivers were 197.13. Using any newer drivers than that caused flickering in multiple games, and some drivers gave me lower FPS with the overclock than when at stock. Luckily the last drivers that came out for my GPUs have been working very well, giving me perfect SLI support in GTA.. but this is the first time new drivers have helped me for months and months.

Play around with older drivers and see if you can get stable in them games. Or maybe if you're using older drivers already, try upgrading.

Besides that, I can't think of any reason them games should crash due to an overclock. I have MOH2010 myself and it works just fine with my cards at 720 instead of 576.
May 30, 2011 9:50:16 PM

Its weird, Ive been playing and no crash. I do get this black flickering sometimes though. What drivers are you using acer0169?
Related resources
a b U Graphics card
a b K Overclocking
May 31, 2011 2:12:03 PM

I'm currently using 270.61.

I used to have the black flickering on GTA4 and Bad Company 2.

On GTA4 it was simply a sign of an unstable overclock (remember, stress testing is only half of checking you have a stable overclock - if your games are failing it IS NOT stable).

On Bad Company 2, the flickering was due to some error with the bloom settings on DX10. If I ran the game on DX9 (my cards don't have DX11) the flicker went away. Instead of running in DX9 though, I simply disabled the bloom effect in the .cfg file and now - no more flicker.
June 2, 2011 7:15:01 PM

Thank You for your response.
a b U Graphics card
a b K Overclocking
June 2, 2011 7:32:11 PM

They released new WHQL 275.33 drivers yesterday -- they are working well for me.
June 7, 2011 2:56:40 AM

Try down clocking it a little bit and see if you see a difference
!