Sign in with
Sign up | Sign in
Your question

X-fi Titanium Flexijack Line-in issue

Last response: in Components
Share
September 17, 2009 4:05:57 AM

Bit of an odd problem. I've been fiddling with settings for two days now, and I am absolutely baffled.

I'm trying to share the sound between my PC, Xbox 360, and PS3 using the X-fi Titanium PCI-E on Windows 7 RC1. I have my PS3 connected to the Optical In (which works flawlessly), and my Xbox 360 connected to Creative's moronic "flexijack." It was running just fine until I made the mistake of plugging in a set of headphones to my front headphone jack. Since then, I can't get any sound from my 360. Literally nothing else changed. I've tried several different drivers (Drivers from the disc, beta Windows 7 drivers, and the latest Vista 64 drivers), and nothing has changed. The flexijack is set to Line-in and not Microphone.

Is there any way to get that idiotic Flexijack to properly recognize my Xbox 360?
October 9, 2009 1:33:23 AM

First off, if you could give me some advice, where do I locate the flexijack? I'm trying to solve a buzzing noise problem with my card and apparently that's the solution.

Second, the reason would probably be that you have headphone detection on. When this happens, it goes to "Heaphone" Setting, so 2 channels. If you power down the computer like this, it will save the settings.

So, right click on the sounds thing in your system tray, go to playback devices. Select your speakers. Go to properties > Sound blaster tab > settings. You will be in the Creative Audio control panel.

Go to the speakers tab, and select your speaker configuration. I hope this helps, because that's what I do when not all my channels are working.
October 9, 2009 11:47:51 AM

Go to the Windows (not Creative) Control Panel -> Sounds. Set what you want you're default input device to be (in this case, Line In). As long as thats in use, the OS should keep other devices from taking priority. Worst case, you can switch the input yourself as needed.

Also, you may or may not need to turn on "monitering" for Line In to actually hear the stream on you're speakers; this can also be done from the Windows Control Panel.
!