Sign in with
Sign up | Sign in
Your question

Is my MoBo defective or can I solve this problem?

Last response: in Motherboards
Share
December 8, 2009 5:11:57 PM

First time builder. Here are the PC specs:

Crucial Ballistix Tracer 4GB (2 x 2GB) 240-Pin DDR3 SDRAM DDR3 1600 (PC3 12800) Desktop Memory

AMD Athlon II X4 630 Propus 2.8GHz Socket AM3 95W Quad-Core Processor

SAPPHIRE VAPOR-X 100269VXL Radeon HD 4890 1GB 256-bit GDDR5 PCI Express 2.0 x16

GIGABYTE GA-MA785GPMT-UD2H AM3 AMD 785G HDMI Micro ATX AMD


I assembled everything yesterday; and on the first boot up, 1) BIOS did not show up 2) the mobo did not beep 3) the mobo LED did not light up. It could not have been a power problem because the LEDs and fans of my chassis worked, and the power button on the front header turned on my pc. Also, it should not be a problem with my mobo receiving power since the heatsink was working. So, I disassembled everything but the cpu, mobo, and RAM and tried it: same problem. The cpu was properly placed in the board as well. Also, it should be noted that the front header power button turned the machine on, yet when held down for several seconds/minutes, the system did not shut off.


Has anyone had this problem. Is the mobo defective or is something missing?
a b V Motherboard
December 8, 2009 6:25:41 PM

Can you define disassembled, breadboarding means board out on table no case, just jumper the power good switch. Just use onboard video/ one stick of memory, make sure cpu plug is installed 4/8 pin and the 24 pin mainboard connection. No beeps? did you install a speaker? Good luck
Unrelated don't feel bad, I couldn't afford a new car so I built one by scratch and it doesn't work either.
Also make sure the Power supply isn't set for 220v.
m
0
l
December 9, 2009 6:19:59 AM

its bad.
m
0
l
!