Sign in with
Sign up | Sign in
Your question

Unable to install driver for Radeon x1950 Pro

Tags:
  • Graphics Cards
  • Graphics
Last response: in Graphics & Displays
Share
July 7, 2009 1:53:07 AM

Here's a long description, but it's only long because of the things I've tried that haven't worked.

I'm having a severe problem installing the proper driver for my graphics card, an x1950 Pro. Please read through to the end to see all of the ways I've tried to solve this problem. I've tried to give as much pertinent detail as possible. I'm at the point of having no idea what to do, and am totally unable to get the proper driver installed. Can anyone help?

After updating my graphics driver to Catalyst Display Driver 6.10 from the ATI website, I discovered that driver did not support my X1950PRO card. I was unable to roll back to the previous driver, so I then downloaded the correct "legacy" version from the ATI site. I DO have the correct driver -- I just can't get it installed.

- Original (wrong) driver: Catalyst Display Driver 6.10 (rev 8.591)
- New (correct) driver: Catalyst Display Driver 6.9 ( rev 8.291 )

However, I was unable to reinstall that driver, resulting in these two error messages:

- INF error. Video driver not found.
- Setup was unable to complete the installation. Try to setup your display adapter with a standard VGA driver before running setup.

After doing some research, I bought Driver Cleaner and followed the instructions precisely. However, after the final reboot, when I tried to load the correct driver, I get the same two error messages:

The computer is running Windows XP SP3
- .NET Framework 3.5 SP1 is installed and fully updated.
- Motherboard: Mach Speed P4M800

Information from Device Manager:
- The X1950PRO is no longer present -- the listed display adapter is DisplayLink Mirror Adapter
- Under Other Devices, are Video Controller and Video Controller (VGA Compatible). Both of these have a yellow question mark.
- Also, the Found New Hardware wizard is NOT appearing whenever the computer is rebooted.

I tried rebooting into Safe Mode after running Driver Cleaner and then installing the driver. But I got the same result with the same two error messages.

I attempted to "scan for hardware changes" in the Device Manager to force Windows to re-acquire the card after drivers have been uninstalled/cleaned. But when I do that and let it try to install automatically, it says it cannot find the software.

I tried following the information in this post about "Forcing Windows to Use the Standard VGA Mode Drivers Without Having to Use Safe Mode":
http://computerhelpandsupport....vga-compatible-driver/
But the only OEM*.inf file I found on my system was in /Windows/OemDir. There was no Oem#.pnf file with it.
- I attempted the driver install again, thinking that this would place the files I needed in the ATI folder so I could follow the instructions. But only one other OEM file appeared: oemdspif.dl_ . There was no .pnf file in the ATI folder.
- I attempted to install the driver through Device Manager
by using Update Drivers and then pointing to the inf file in the ATI driver folder.

I received the following suggestion from the maker of Driver Cleaner. It didn't work (my results appear below these instructions):
- Run driver/install
- After fails, right click on desktop, and select Properties
- Go to Settings, then Advanced
- Click on Adapter tab, you should see your Adapter type (e.g. Radeon X600 Series)
- Click on Properties button
- Click on Driver tab
- Click on Update Driver... button
- Click on "No, not this time" radio button (to bypass Hardware Wizard searching the web)
- Click Next
- Click on "Install from a list or specific location (Advanced)" radio button
- Click Next
- Click on "Don't search. I will choose the driver to install" radio button
- Click Next
- Click on Have Disk...
- Click Browse...
- Navigate to the location where ATI installed the driver files. For example, C:\ATI\SUPPORT\6-9_xp-2k_dd_35774\2KXP_INF
- Select the .inf file.
- Click Open
- Click Ok. A dialog comes up with a huge list of drivers. Navigate until you find the one closest to your card.
- Click Next and then Install.
- Click Finish

However, I wasn't able to complete all of those steps. Before trying the cleaning/install again, I went through the steps as a dry run. I got into Properties/Advanced/Adapter/Properties/Driver. But at that step, there is no Update Driver button. On the Adapter tab, there is no Adapter Type listed. The field is there with an icon, but not actual type is named. ( Adapter information list is all <unavailable> And when I select Properties, the Service Name is listed as VgaSave, and the Display Name is VGA Display Controller.

I'm not receiving any helpful answers from the DriverCleaner site, and am hitting the same results with every attempt. Unfortunately, System Restore wasn't working so there is no restore point. I'm redownloading the correct driver and will try again, but I feel completely out of options. All I can think of now is reinstalling the OS and starting totally from scratch, but man.... that's a last resort step.

Does anyone have a fresh insight?

More about : unable install driver radeon x1950 pro

a b U Graphics card
July 7, 2009 1:58:59 AM

The 9.3 drivers should support all of the now legacy products. Why are you trying to install such ancient drivers?
July 7, 2009 12:23:56 PM

The page in ATI's site that lists the legacy drivers (http://support.amd.com/us/gpudownload/windows/Legacy/Pa...) lists Catalyst Software Suite rev 9.3.1. This is what I've downloaded and installed twice now, both times using Driver Cleaner in between to completely erase the original drivers. Every time, after installation, it reads in Device Manager as Catalyst Display Driver 6.10 (rev 8.591).

However, this ends up being the driver NOT recommended by GeCube.

GeCube (the card manufacturer) notes "The CD Driver enclosed in the GeCube color Box is Catalyst Display Driver 6.9 ( rev 8.291 ) that supports X1950PRO graphics card properly! The recent released Catalyst Display Driver 6.10 from ATI website did not support X1950PRO due to the missing X1950PRO device ID during the updating process! Please install the display driver from the box."

I bought the card Open Box, so I don't have the CD. But I do have the correct driver downloaded, it just won't install without the error messages.
Related resources
a c 199 U Graphics card
July 7, 2009 12:49:07 PM

Have you checked to power leads? They can require a fair bit of force to fully connect and it will not be the first time this has been the problem.

Is this an upgrade? If so have you fully uninstalled and cleaned out the previous drivers-I know, it's obvious but...

Re download the driver package, perhaps the download is corrupted, it is rare but does happen.
July 8, 2009 2:32:50 AM

Coozie, the power leads are good. The previous drivers were fully uninstalled and cleaned out repeatedly with Driver Cleaner (see first post above). I redownloaded the driver with the same results. This was an attempted driver update, but the newer driver version did not support my card, which is why I'm trying to get back to the original driver.

Would a Repair install of XP be worthwhile? I don't know if that would revert back to the original graphics driver or not, which would then (hopefully) allow me to update to the correct version.
a b U Graphics card
July 8, 2009 2:51:19 AM

The driver is version 8.591, the release is 9.3. What is this 6.10 you are referring to? Those would be drivers from October 2006. I'm sure the original drivers would be about that old though.

At any rate, all drivers up to and including 9.3 should work.. Here are the archives from amd, older ones may be around the internet.

http://support.amd.com/us/gpudownload/windows/Legacy/pr...
July 14, 2009 2:18:23 AM

Well, I downloaded the driver yet again, and this time it seems to be working okay. Thanks to everyone for their help.
September 25, 2009 5:47:48 AM

Hi, I have not been able to download or install anything, ever, of Radeon updates, am forever being told no hardware compatible to driver has been found, do have a Radeon mother board, but was installed about four years ago, surely I must need some kind of update by now ??????

Maybe I need to uninstall, or change the download language, my pc language is Dutch.

totally frustrated,
karin de groot
the hague, the netherlands


Anonymous
a b U Graphics card
May 26, 2010 8:38:41 PM

s
!