Sign in with
Sign up | Sign in
Your question

IC7-MAX 3 & 2 Seagate 1TB Drives Not Seen on SATA 3 & 4

Last response: in Motherboards
Share
December 10, 2009 1:40:02 AM

Hi, I've had this mb for a while now working fine w/ 2 WD 74 GB Raptors running RAID 0 on the ICH5 SATA controller. I've just added 2 Seagate Barracuda 7200.12 1 TB drives which I want to set up as another RAID 0 array on the Si Chip. No matter what I do I can't get the BIOS to see both. After the POST SATA 1 & 2 show up, then the Si SATA BIOS starts but only shows a 0 ST31000528AS and a blinking cursur. It's there it hits the wall and stops. I can remove the two raptors and put the Barracudas on the SATA 1 & 2 connectors and the controller sees them just fine, so I know it's not cables, or the drives. I've tried to configure the BIOS (REV 18) in every imaginable way, but can't get these things working. Any ideas?

Specs:
ABIT IC7 Max3 MB
4 1G PC3200 DDR 400 Sticks RAM
RADEON9800
Intel Socket 478 3.4Ghz Processor (NOT OC'ed)
WD 74G Raptor on IDE1 & two DVD Burners Primary/Slave on IDE2.

Other info available upon request.
December 10, 2009 1:52:37 AM

I believe the SiI controller needs a separate device driver,
and that controller must be properly enabled in the BIOS.

In the BIOS, see "Onboard PCI Device" | "Serial ATA Controller"
(Page 3-16 in the IC7-MAX3 User Manual).

We have the Abit IC7 motherboard, and Device Manager
reports "Silicon Image SiI 3112 SATARaid Controller".

The Driver File Details are:

C:\WINDOWS\system32\DRIVERS\SI3112r.sys
C:\WINDOWS\system32\DRIVERS\SiWinAcc.sys
C:\WINDOWS\system32\SiISupp.dll

File version: 1.0.62.0


We found the latest device driver at the Abit website:
the filename is "abitsata_v1.33.exe" which is a
self-decompressing file.

GOOD LUCK!


MRFS
m
0
l
December 10, 2009 2:27:05 AM

Hmm....perhaps I have the *wrong* drivers. I have the following files:

C:\WINDOWS\system32\DRIVERS\SI3114r.sys (1.0.21.0)
C:\WINDOWS\system32\DRIVERS\SiWinAcc.sys (1.1.12.0)
C:\WINDOWS\system32\SilSupp.dll (3.0.28.0)

All created 10/4/2007

I'll have to search out the exe you posted and give that a shot. Thanks for the reply. Hopefully that'll solve this issue.
m
0
l
Related resources
December 10, 2009 2:29:09 AM

Also a visual check of the chip shows 3114CT176 stenciled on the top.
m
0
l
December 10, 2009 2:34:44 AM

I've checked the device manager and it shows, "Silicon Image SiI 3114 SATA Raid Controller" and it sees both the 1TB drives in the controller properties. It reads their sizes, serial numbers, etc. Yet Windows doesn't show the drives mounted and the SI BIOS locks up when loaded, after being enabled in the AMI Bios. Hitting CNTRL-S or F4 I believe does nothing.
m
0
l
a b V Motherboard
December 10, 2009 2:47:56 AM

Most likely its an out-dated Silicon Image BIOS that is choking on the 1TB drives. Not uncommon for an older controller ROM. You might be able to find a modded version of the latest ABIT BIOS that has incorporated a newer BIOS from Silicon Image.
m
0
l
December 10, 2009 3:01:00 AM

That's an interesting possibility. Any idea what I'd actually search for or for that matter where?
m
0
l
a b V Motherboard
December 10, 2009 10:23:18 PM

http://s89934018.onlinehome.us/BIOS/ic7max3p18.zip

Use at your own risk. I have no way of testing this so I cannot guarantee anything, only that I've done this with success numerous times before. It is highly unlikely to result in a non-functioning board, but there is no guarantee that any BIOS flash is perfectly safe.

There is a real chance the new BIOS may not be compatible with RAID arrays created using the older SI BIOS version. It may even be incompatible with the master boot record of non-RAID disks created on the old BIOS version.

Alternatively, you could disable the onboard Silicon Image controller and purchase a PCI SATA controller card.
m
0
l
December 10, 2009 10:27:57 PM

I agree 100%. After many hours of searching forums and newgroups I found a person with the exact same problem. He solved it buy returning his 1TB drives and settling for a couple of 500GB drives. I won't settle! I just bought a PCI SATA Controller card for $14 and we'll see how it works.
m
0
l
December 18, 2009 4:03:00 AM

PCI SATA controller received. I've connected the drives and the problem is solved.
m
0
l
a b V Motherboard
December 18, 2009 4:15:08 AM

Glad you got it solved.
m
0
l
June 2, 2010 2:29:11 PM

Has anyone got Windows7 installed on an Abit IC7 Max3 ?

The Sil 3114 driver doesn't seem to be correct (from Sil's website http://www.siliconimage.com/products/product.aspx?pid=2... ) so Windows7 isn't recognizing the 3114 chip.

I'm wondering if the SATA raid bios needs to be updated from 5.0.31 ? Abit doesn't have a BIOS update that contains a later version of the raid BIOS.
m
0
l
!