Sign in with
Sign up | Sign in
Your question
Closed

OCZ SSD Firmware 1.29 Update

Last response: in Storage
Share
a c 99 G Storage
March 2, 2011 8:59:03 PM

I am trying to due the firmware upgrade to 2 OCZ Vertex 2 60GB SSD, from 1.28.

However, many road blocks are in the way:

Per the OCZ Website here;

i.) Can't/don't do the firmware upgrade if the SSD run the OS. Make them a secondary drive...thus do the firmware upgrade before installing OS to these drives, using whatever you have before to get into Windows to run the program.

ii.) Can't/Don't do the firmware upgrade in running Intel RST 10 chipset drivers (which I am)...but I also have a Marvell PCI to IDE/SATA controller running my SATA optical drive as IDE. I am NOT going to roll back the driver either!

So, I tried to do this in my other/wifes computer, a HP PAvilion a6314f, with an Asus M2N68-LA mobo, using NVidia GeForce 6150SE nForce 430 chipset. The OCZ Toolbox application wouldn't detect the OCZ drives, which had 3 connected to it! 1-OCZ Agility 60GB running OS, and 2-OCZ Vertex 2 60GB which I'm trying to do the f/w upgrade. Drives were "formatted" in Windows, so Windows/Device Manage/Disk Manager would see them.

I contacted a OCZ Forum Support/OCZ Technology Group, and his last e-mail stated that the "NVidia chipset is blocking the toolbox. What driver...controllers in Device Manager?"

GR8!

So, can I try this on the machine I intend to put them in (this one, see my signature), using the Marvell SATA controller port? I'll try, and let ya'll know.

Anyway, what a PITA:

- Can't upgrade in they are the OS drive, so what if already installed in a rig?

- Can't upgrade using Intel RST 10 drivers for the chipset.

- What about IDE vs. ACHI mode.

- I know you can't do the f/w upgrade if in a RAID array, which they will be.

Anyway, Intels f/w upgrade was much easier! The program is DOS based, and they provided the software to make a DOS bootable CD. Speaking of making a MS-DOS bootable CD, what another PITA! The programs I found online don't work! I had to tweak the h*ll out of them to get a viable boot CD.

Any suggestions are welcome.
a c 143 G Storage
March 2, 2011 9:52:32 PM

1) Have you tried to roll back your Intel Driver to your previous version?

2) I have flashed multiple SSD when acting as OS (all Intel) without issues. I have not tried my OCZ, as it is 1.29 already.

3) Wait for 1.3 (or next #), which is in testing to help with the 25nm issues. I would expect a release this month sometime...
Score
0
a b G Storage
March 3, 2011 2:40:40 AM

Wait for next one ,there is not much new in this one anyway.
Score
0
Related resources
a c 99 G Storage
March 3, 2011 3:48:28 PM

I did it!

Since I could do it on the rig that had the Nvidia chipset, I tried on my rig with the X58 chipset (ICH10R).

First I tried to do it hooking up the (2) SSD drives to the JMicron SATA port(s) on the motherboard. When I checked the BIOS, I discovered that it will only “recognize” one drive in Drive Xpert. Else, the drives have to be set to “Speed” or “Back Up” mode (e.g. RAID 0 or RAID 1) in the BIOS for these ports.

So I thought, okay, I’ll just do one drive at a time. WRONG! The OCZ Toolbox did see the drive, but the info was wrong (said firmware 955 instead of 1.28), and wouldn’t update the firmware (the button was grayed out). Aargh! :pfff: 

So being my last option, I had to plug the drives into 2 of the “normal” SATA ports (port 5&6, drives 4&5). Ran toolbox again, and, like the instructions warn, it didn’t “see” the drives. Aargh, Aargh! :fou: 

Thus, I had to uninstall the Intel RST 10.1 program, thinking it would roll back the drivers to v9.6. I ran toolbox again, but still no drives. Aargh x3! :heink: 

Finally, I ran the Intel RST 9.6 driver program which warned about installing older drivers than what was already running. I ran toolbox again, and TA-DA! It saw the drives, and had the option to upgrade the firmware.

I upgraded the firmware to 1.29, quick and flawlessly. Then I ran Secure Erase, which I had to delete the partition information and/or remove the allocation in Disk Management, and it cleaned the drives quickly and flawlessly, too.

It really didn’t bother me about the driver rollback. But I was trying to did the whole thing without cracking my case open, since I have a “hot-swap” rack where my other (2) SSD are mounted in, with front panel access. A 2.5” to 3.5” dual-drive mobile rack mounted in a 3.5” to 5.25” front panel bracket (like a floppy drive).

That being said and done, I already have Windows 7 Home Premium 64-bit installed to the (2) SSD drives in RAID 0, and downloaded/installed all the Windows Updates. I even installed all my programs (Office 2007, Quicken, Norton Security Suite, Nero, etc.), just have to tweak them with my personal settings.

Now I can’t tell it these (2) OCZ Vertex 2 60GB drives in RAID 0 are that much faster then what they replaced; (2) Intel X25-V 40 GB drives in RAID 0; but I’ll run benchmarks later. Although the Windows boot screen with the floating bubbles seems to move and be gone quicker, to the log on screen.

I can only hope that the next firmware version let me update the drives in Windows as primary disks, in RAID, with the latest Intel RST drivers v10.1 or higher. Else, a MS-DOS based firmware upgrade like Intel has would be fantastic. HELLO, OCZ, ARE YOU LISTENING?
Score
0
a b G Storage
March 4, 2011 4:17:15 PM

This topic has been closed by SAINT19
Score
0
!