Sign-in / Sign-up
Your question

Asrock X58 extreme issues

Tags:
  • Motherboards
  • PCI Express
Last response: in Motherboards
December 12, 2009 8:09:21 PM

So...I posted something similar to this earlier, and I posted about issues with my new radeon HD 5870 card as well...but figured I'd post this issue here as it relates to my motherboard. As I described in the radeon post I made...my new HD 5870 seemed to not be working. I tried different configurations with PCI-E cables and nothing would happen...the system would power on but there would be no picture. So the last configuration I tried was a PCI-E cable straight from the Power supply and a PCI-E to molex (that at the end had two molex adapters which I plugged in).

Anyway I hit the power...the fans spun for a half second and nothing happened. Put the old GPU back in and uh-oh, nothing happened then either! I tried the PSU with the motherboard from my old system (an Abit KN8) and...it worked. So it looks like this new motherboard, which is actually a replacement after a Radeon HD 5850 I tried fried it the first time (differen story)...is fried. Is there any way I can fix this? Is it really fried? I push the power button and absolutely NOTHING happens. Yes, the PSU -is- turned on.

The wierd thing is that this is different than what happened before...before the MB wouldn't work (it wouldn't post) - but the fans on everything WOULD be spinning. Now absolutely nothing happens.

More about : asrock x58 extreme issues

a c 436 V Motherboard
December 13, 2009 11:13:56 AM

Try the old ps with your 5850 on the newer board if you haven't already. Could be your ps isn't compatable with the video card, not the board. I would also try a low end pci-e card which doesn't need any ps connections on your board before sending the board in for warranty.
m
0
l
December 15, 2009 12:19:40 AM

My asrock x58 extreme died on me after 4 days of use. I had it working with an xfx 5850, and it was awesome til the board died. The debug led no longer shows anything on boot, no picture, i tried clearing CMOS and the cmos jumper, and no luck. Its going out for RMA this week.
m
0
l