Sign in with
Sign up | Sign in
Your question
Solved

Memory frequency and timings are not properly detected in bios?

Last response: in Memory
Share
December 13, 2009 4:08:52 AM

I have a quick question. I just put together a new system and I have 6gb of g-skill ddr3 pc1600 memory installed. The motherboard is the Gigabyte EX58 UD3R rev.1.6. In the bios it was detecting the memory at a 1066 with timings of 7-7-7-20 and a command rate (CMD) of 1. I read from other posts that people experienced this innacurate detection before and fixed it by just changing the frequency and timings. I increased the SPD mulotiplier to 12x to get a frequency of 1600mhz on the ram and manually adjusted the timings to what the ram was speced at whic is 9-9-9-24. My question is really about what to do with the command rate. I always thought it this was always 2 for DDR memory but my mobo is detecting it at 1 and I was unsure about whether to leave this as is or change it to 2?

Also, I've been having trouble installing windows7. It returns an error during installation ( 0x80070017) which according to most sources is that it's due to an error becuase the copied disk is damaged or files are no good, but could this be due to my installed memory not configured properly? I ask this because after setting my:

CAS = 9
tRCD = 9
tRP = 9
tRAS = 24
CMD = 1(auto)

DDR Voltage is at 1.5V and my QPI voltage is at 1.15v. Within the memory specs, I get the phase led lights on my mobo all lit up going from green to red which supposedly is stating a load issue.

I don't know if this has one thing to do with the other...just thought I'd ask. Just was curious if my windows installation error coudl be due to the need to manually input the correct timings and voltages into my bios.

Best solution

a b } Memory
December 13, 2009 1:57:58 PM

First, I would Leave the memory at default detected config (1066). run memtest 95+ to verify memory (Raise Dimm Voltage to spec if needed and repeat memtest). Then install windows 7.

After windows 7 is installed. Down load CPU-Z and look at memory SPD XMP profile 1.
Set your memory to the listed spec. You will probably need to increase your dram voltage and change the cmd rate to 2T. Rerun Memtest from Bootable CD to verify before booting into Win7.

Not sure about the X58 board, but I have a P55 board w/ 2x2 G-skill (7-7-7-24-34-2T @ 1.6V) and in BIOS I have the option to select (use) XPM profile 1 which correctly set my memory paramaters (G-Skill RipJaw CL7, 1.60 V, 2T)
Share
December 13, 2009 5:20:12 PM

RetiredChief said:
First, I would Leave the memory at default detected config (1066). run memtest 95+ to verify memory (Raise Dimm Voltage to spec if needed and repeat memtest). Then install windows 7.

After windows 7 is installed. Down load CPU-Z and look at memory SPD XMP profile 1.
Set your memory to the listed spec. You will probably need to increase your dram voltage and change the cmd rate to 2T. Rerun Memtest from Bootable CD to verify before booting into Win7.

Not sure about the X58 board, but I have a P55 board w/ 2x2 G-skill (7-7-7-24-34-2T @ 1.6V) and in BIOS I have the option to select (use) XPM profile 1 which correctly set my memory paramaters (G-Skill RipJaw CL7, 1.60 V, 2T)



What I did was to enable XMP and chose the option profile 1 and the bios immedietly registered the proper frequency and timings as well as the voltage for what my memory is specced for.

I'm going to try and install win7 and hopefully not get this corrupt file error... it was an iso image of the os from work so in all likelihood its a result of the speed at which the iso image was burned and needs to be burned at a slower speed as which seems to be the consensus.
m
0
l
Related resources
a b } Memory
December 13, 2009 5:36:16 PM

sounds good, I would recommend that you run Memtest 86+ from a bootable CD to verify no memory errors prior to loading the OS
m
0
l
a b } Memory
December 13, 2009 5:43:40 PM

Suggest you Restore all defaults in the BIOS and install windows. Don't start fiddling w/ BIOS settings until then. The reason you buy higher frequency RAM is for overclocking......your memory is supposed to be at 1066 at a BCLK of 133.33 (8 x 133.33 = 1066).

Enabling XMS profile in my son's setup (Asus R2E w/ Mushkin 6-7-6-18) wouldn't post. So I just set the timings 6-7-6-18 manually and left all else on Auto.

My next step was to set BCLK to 160 memory multiplier to to 10 (160 x 10 = 1600) and run memtest overnight
My next step was to set BCLK to 200 memory multiplier to to 8 (200 x 8 = 1600) and run memtest overnight
m
0
l
a b } Memory
December 13, 2009 6:53:51 PM

Those are the settings the memory is guaranteed to work at, but that is not the settings that your board runs at by default. Your board is setting the memory at the boards default settings. Just because the memory can run faster than the boards defaults, does not always mean that the motherboard will play nice with it running that fast. :) 
m
0
l
December 13, 2009 7:02:49 PM

jitpublisher said:
Those are the settings the memory is guaranteed to work at, but that is not the settings that your board runs at by default. Your board is setting the memory at the boards default settings. Just because the memory can run faster than the boards defaults, does not always mean that the motherboard will play nice with it running that fast. :) 



Good point. I'm hoping to get win7 installed so I can test stability.
m
0
l
!