ASUS M4A89GTD Raid 0 Windows 7 Install Restart

So I just recently decided to do a RAID 0 configuration on my ASUS M4A89GTD with two 1 tb drives. I first set the Raid controller to the raid 0 setting and added my two drives. The raid manager reported back the raid 0 drive was healthy and working fine.

I proceeded to go through with a fresh windows 7, 64-bit install. The install goes fine but when the computer boots up to load windows 7, it hits a blue screen and instantly restarts. Over and over again.

I think I tracked down the issue to a rogue registry entry. Apparently there is an entry called iaStorV that causes the drivers.sys file to not load the drivers correctly, causing a blue screen error.

Things ive tried:
Using ubuntu off a cd. Didn't work because the chntpw doesn't know how to mount a raid 0 drive
Regedit bootloading programs, dont work because they dont know how to deal with a raid drive
Regedit in the system restore command prompt. Doesn't work because it's version doesn't match windows 7

Ive been at this for 3 days now and any help at all would be much appreciated.
7 answers Last reply
More about asus m4a89gtd raid windows install restart
  1. iaStorV is the RAID Driver I believe.
  2. Found the culprit, apparently when windows installation asks for drivers for the raid controller it has only been accepting the 32 bit version because it throws a signed drivers error on the 64 bit version. However, I've been installing the 64 bit version of windows. This incompatibility causes the blue screen.

    I know about disabiling driver signing enforcement for both the installation and for when windows loads. I will try out using both tomorrow and see what kind of results I get.
  3. Yes that makes sense. Hopefully that will resolve the matter.
  4. Unfortunately the 64 bit version of my raid drivers throws an unsigned driver error and windows installation wont load them. Ive tried using an older raid driver version without any luck as well.

    I read about using the repair option on the windows installation to load the drivers. I will try that later today and see if I can install a 64 bit version of windows
  5. Signed drivers on CD, copy to FDD or USB.
  6. das_stig said:
    Signed drivers on CD, copy to FDD or USB.


    On which cd?
  7. The restore function to load the drivers didn't work. Seems like im stuck on a 32 bit setting.
Ask a new question

Read More

Asus NAS / RAID Windows 7