Just tried AHCI and it's behaving strangely

I just reformatted and reinstalled windows and decided to go ahead and try AHCI, so before the windows 7 installation I configured the Bios to AHCI. Installed windows 7 and all the updates/drivers. Including intel rapid storage technology (isn't it the latest ahci driver for ICH10R?).

The system is really laggy, when I go to ''my computer'' to see the drives and their capacity, sometimes it tells me C: is full when it was almost empty. Then It would show the green ''loading'' bar up top and until it reached the end of it's loading the whole system freezes. Then I see the correct info 1.78TB free of 1.81TB and the system starts acting normally.

It happens fairly often too... I looked up stuff concerning AHCI and stuff about LPM (link power management) showed up. It seems to be a power management thing where it disables unused Optical drives and idle hard drives. But I never found out how to change it's settings...

Please help! are my hard drives simply not compatible with AHCI? or is it really some setting.

If it's my hard drives is there some complex maneuver necessary to go back to IDE?

MB: Asus P5Q (regular one) MCH=P45
CPU: Core 2 quad Q9400 not overclocked since formatting
GPU: Asus EAH4870 512M memory (ati radeon hd 4870) not overclocked
HDD: 1 Green WD 1TB (storage) and 1 Green WD 2TB (OS partition)
PSU: Corsair TX750W
Case: Coolermaster CM690
RAM: 2x 2GB DDR2 800MHZ kingston
Windows 7 professional 64 bit
3 answers Last reply
More about just ahci behaving strangely
  1. Those drives are compatible with AHCI. The green drives are definitely not well known for their performance. They are good for backups or data/media storage where performance is not a factor.

    This might be why you are seeing lag and why the speed seems to be not meeting your expectations. That capacity consistency issue is strange. Does it always give you a different result?

    Switching to IDE mode is just a matter of changing the BIOS setting. Now if you want to switch back to AHCI, follow the following procedure from the MS knowledge base (the 'let me fix it myself' section):


    Windows 7 has built-in support for AHCI. Did the Intel Rapid Storage technology program come with the motherboard (I'm trying to figure out why you chose to install it?)?
  2. I looked up AHCI driver on intel's website and this one popped up. It looked like the most recent driver too so I downloaded it.

    Anyways, for whatever reason the problem didn't occur since then. So I'll keep an eye on it, but it seems to be fine now.
  3. Glad to hear it.
Ask a new question

Read More

Hard Drives Storage