Sign in with
Sign up | Sign in
Your question

Hard drive shows up in Device Manager but not Disk management

Last response: in Storage
Share
March 8, 2011 5:56:14 AM

I can't figure out how to access my drive. It's a 2TB Seagate that was working fine until I just did a new Windows install. My other secondary drive worked fine through the new install as D: but I lost my E: drive. This has occurred before and I just had to assign a drive letter in Disk Management but now it's not even appearing there so I'm stumped, what should I do?
March 8, 2011 6:12:17 AM

looks like your boot partition is corrupt....do a chkdsk/f and see what happens...if it does not work go to the storage management under admin tools and reformat the drive
March 8, 2011 7:22:42 AM

I don't know what chkdsk/f means. I entered it in the command prompt but I get a "cannot run because the volume is in use by another process" message.

Also, I really need the data on the drive so I want to avoid formatting if possible. But even if I did want to format, I don't know how I could without having access to the drive options in any window. Device manager is the only place I can see it and it says the device is working properly, so do you still think it could be corrupt?
Related resources
March 8, 2011 5:44:38 PM

Did you by any chance reinstall Windows XP? If so, make sure you are on the latest service pack, because if it's the original XP with no service pack, I dont think it supports drives that large.


March 8, 2011 7:33:35 PM

I'm using Windows 7 Ultimate x64 with all the latest updates.
March 8, 2011 9:48:55 PM

still need help
March 8, 2011 10:26:16 PM

just follow these easy instructions, i got them from ehow website:


Things You'll Need:
Run Chkdsk F in Windows
1
Be aware that it is no longer necessary to run Chkdsk F from the DOS command line. You can still do it this way if you'd like (open the DOS command line and type "chkdsk /f"), but Chkdsk is now integrated into Windows itself.

2
Run Windows normally, allowing it to load fully.

3
Access the "My Computer" menu. You can do this by clicking the Start menu and clicking the "My Computer" menu option. You can also double-click the "My Computer" icon if you've enabled it on your desktop.

4
Right-click on the drive on which you wish to run the Chkdsk F command.

5
Click "Properties" in the right-click context menu.

6
Click on the "Tools" tab in the Properties window.

7
Click on the "Check Now" button in the "Error-checking" frame of the Tools tab.

8
Click in the "Automatically fix file system errors" check box under the "Check disk options" frame in the following window. This is the step which enables the "/f" command in Chkdsk.

9
Click "Start" to begin the Chkdsk scan. If there are a lot of processes running in the background, or if Chkdsk determines that it should be run when you next restart your computer, it will suggest it. It is always advisable to run the Chkdsk from the restart in this case.



March 8, 2011 10:29:23 PM

if it does not work then will need to use the chkdsk /f in command prompt...dos....just type cmd at the search bar and a new dos window will open after you press enter.
March 9, 2011 6:32:47 AM

Okay well as I said, I already tried running chkdsk/f in the command prompt. I don't know what else to do. The drive does not appear in "my computer" so I cannot select properties or do anything else.
March 9, 2011 6:34:48 PM

could be that the controller is dead...try to hook it up on one of your friends computer and see what happens....just make it a slave drive....no pun intended :) 
if it still does not work, most likely it's broken and will make a nice paperweight :( 
March 17, 2011 2:04:19 AM

evongugg said:
It is showing in the bios probably, so run hard disk diagnostics.

http://www.seagate.com/ww/v/index.jsp?locale=en-US&name...


Well I ran the SeaTools for DOS diagnostics and everything passed but the problems still persist. I contacted Seagate support and they said if it passed those tests then the drive should be fine so I don't know what to do next, any other ideas?
!