Sign in with
Sign up | Sign in
Your question

Sapphire HD4870 Dilemma **PLEASE HELP**

Last response: in Graphics & Displays
Share
July 13, 2009 6:30:05 PM

Its all started when i was playing GTA: IV. IT varied on how long i could play the game for until it crashes.
This is whay happends: http://www.youtube.com/watch?v=NImhGgDLQYo


I looked on the internet to see if it was just me with this problem.
Turns out this problem only happends to this Graphics Card...
I then found a "cure" say (on ATI's website forum.... This was to flash the bios. The program was issued by ATI and the new bios file was issued by them aswell.

I flashed the bios but i kept gettin errors
So i experimented and there was an opton to edit the bios.. And i changed (*!!!ONE!!!*) number... After u did that the computer froze. I left it for 10mins... Then i hit the reset switch.

Ever since then i havnt been able to get my card to work. :(  i miss my games :( 

I want to know weather there is a way of flashing it back


Do i need another card (different) and use that to get video on screen so i can flash it back.
Do i need the (same card) put into a crossfire configuation...

Or is it fu*ked?


Please help me!!

thanks
July 13, 2009 6:38:29 PM

Looks like you screwed your card by doing the bios update. Send it back get a replacement. Don't tell anybody what you did though.

The first part of the video......... I never seen it this bad before so I'm not sure but it almost looks like "ghosting". Worst I've ever seen. Means the refresh rate on the monitor is very high or you neglected to properly set up your video settings somewhere.
July 13, 2009 6:41:46 PM

if you power up the computer and there is no display then the card is dead from the bad bios. only way to get the card working is to send it back to Sapphire to get the bios reprogrammed.
July 13, 2009 7:25:02 PM

oh ok... before i make a decision i would like some more reply's =]
!