Sign in with
Sign up | Sign in
Your question

Bad PSU?

Tags:
  • Homebuilt
  • Systems
Last response: in Systems
Share
June 22, 2009 10:34:26 AM

So the other day my system went bad on me, nice chain of beeps followed by a wall of text stating it couldn't detect pretty much anything. After trying to reboot, I'd get no post beep or nothing. I was getting power to fans, opticals etc, so I did the take each thing out and test them individually, with no results. More so than not I was told it was a bad Mobo, YAY for a 2yr old system. I have since replaced everything in the system outside of the PSU, and wouldn't you know it, STILL no post. I did get it to post to bios once by tripping the CMOS battery but after setting up time/date etc and rebooting, I got the black wall of silence again. Now logic would leave me to believe that it was originally the PSU that was my problem, but I know computers some time defy logic. Any help/info would be nice, before I drop more $$ or throw it out the window.

More about : bad psu

June 22, 2009 1:00:18 PM

from the sounds of it. to me it does not seem like the PSU. if it was the PSU the computer would not boot or have a delay when powering it on or you would hear the fans power up and down like the power fluctuating. but if it is the only thing left that was original when the system was first built then i guess you have no choice.
June 22, 2009 1:04:57 PM

Welcome to the forums!

Please post your full system specs including any overclocks, the PSU brand, wattage and +12v amperage.

Start by double checking all electrical connections inside your case.
Remove and reinstall your RAM, Graphics Card, Hard Drive Cables and any Addon Cards.
Make sure there is no dust in the slots before reinstalling any componets.
Take a can of duster and blow out all of your heat sinks and the PSU.
Put your eyes and nose to work!
See if you can spot any Blown Caps or can smell any burnt components.

If you have already replaced everything short of the PSU and nothing is hooked up wrong, I would be willing to wager the PSU is at fault.
Related resources
Can't find your answer ? Ask !
June 23, 2009 4:15:49 AM

Thanks for the welcome!

Specs would be:
AMD Phenom2 955 3.2ghz
Asus M4A78T-E Mobo
4gig Corsair DDR3 1333
Radeon HD4890 vid card
and put in today a Corsair tx850w psu +12v@70A, was using a Thermaltake 650W

I went ahead and threw in a new psu, in vain hopes that WAS the link and I knew it wouldn't hurt with the new hardware. Still getting same response, lights fans(though I forgot to mention that the vans start fast then slow down.), and still no post. Went through the process of individual testing of components again, and can only get to bios once I've cleared the CMOS, but after exiting it still goes to nothing. Hate to think I have a $1200+ paper weight sitting here, still getting frustrated and am ready for bed. Yet again thanks for any help I can get, my two I trust after I'm stumped have also got no clue.
June 23, 2009 12:54:08 PM

i guess it could be another bad mobo. it's rare but it does happen.
June 23, 2009 6:40:31 PM

I was trying not to think that Capt., but it wasn't out of suspisicion. Figured two builds doing the same thing may be somthing more serious. I'm not a complete amatuer to hardware/troubleshooting, but this has me ready to go back to being a caveman. Could it be something on the case? Could the old psu have fouled up the new mobo that fast, or was it just the bad apple in the box?
June 24, 2009 2:52:19 PM

UPDATE--I now know it wasn't the psu, and have since exchanged the new board in case it was bad. Hook up mem, CPU,and psu......still nothing. Tripping the CMOS will still allow me to get to bios once, where I can see it detects both mem and CPU, but rebooting it give me the beepless void. Obsession is now turning to depression, and unfortunatly my tears don't power the system. Running out of options.
June 24, 2009 3:01:56 PM

hmm...what about the cpu? did you replace that too?
a b B Homebuilt system
June 24, 2009 3:13:07 PM

Did you manually set the speed/timings/voltage to the manufacturers specs for your new RAM? Incorrect RAM settings/faulty RAM can cause issues like you're reporting.
June 24, 2009 6:21:07 PM

captaincharisma said:
hmm...what about the cpu? did you replace that too?

CPU is fresh out of the box. As for setting ram speed/voltage, yes but I have to reset the CMOS everytime just to get to bios.
!