Sign in with
Sign up | Sign in
Your question

Green/Pink Display while playing games

Last response: in Graphics & Displays
Share
July 14, 2009 7:46:59 PM

Hey guys, just wondering if anyone knew a quick fix for my issue. My graphics work fine for everything except games. When I load a game, Diablo 2 / Oblivion for example, everything is there on screen, its just the wrong color. The screen is washed with bright green and pink instead of the correct colors.

I've scanned for viruses with Norton 360 and Webroot SpySweeper. The drivers for my videocard are up to date. I've patched the games I've tried. Not sure what else to do.

Currently using:
Gateway LX6810-01 (64 Bit)
Vista 64 bit Home Premium
Intel Core2 Quad core
8 gigs of ram
ATI Radeon X300/X500/X1050 Series Video Card

I'm not exactly sure which card it is in there, dxdiag only tells me that its one of that series. I know its an older card with a newer rig, I'm not sure if that could be part of it. They are older games that I'm trying to run as well.

Any assistance would be much appreciated.
a b U Graphics card
July 15, 2009 8:39:56 AM

My only experience with that kind of problem is when there are errors with the cable connecting your display to the computer. I assume you've tried unplugging then replugging the monitor right? If that did nothing, try another cable.
July 15, 2009 12:01:58 PM

Yeah, I meant to say its not a cable issue. I've tried dvi to dvi and dvi to mini dvi, as well as an rgb cable.
a c 187 U Graphics card
July 15, 2009 12:22:03 PM

Has this just happened?
Has this happened since an upgrade?
Which drivers are you using? ATI no longer support those cards, release 9.3 is the latsest available and it might be wise to back off to an older suite such as 8.12.
Did the system previously have annother card installed? If so did you uninstall its drivers before installing the current card?
!