Conroe 945G-DVI doesn't detect Sapphire 5750

Hello!!! I'm a newbie and need some help.
I tried to install sapphire 5750 to my motherboard (Conroe 945G-DVI BIOS 1.2) and my monitor did't show anything.
Before install sapphire 5750, i used 8800GT and it worked fine.

What should I do ???
6 answers Last reply
More about conroe 945g doesn detect sapphire 5750
  1. Contact ASRock support.
  2. I have emailed ASRock support and they asked me to call my reseller. But the reseller closed.
    I have updated my BIOS version to 1.9 and i have a few question:

    > My motherboard only 20 pin for the main power. The new motherboard have 24 pin.
    I'm already attach the 6 pin power to Sapphire 5750. My motherboard lack of power
    to run Sapphire 5750 because of the main power pin or not ???

    > My vga card slot on my motherboard is only PCIE X16.
    That's make my sapphire 5750 won't detect or not ???

    Thx
  3. well you can use a 24-pin psu on a 20-pin mobo but you CANT use a 20-pin psu on a 24-pin mobo. how many watts is your power supply? try putting the old card back in, see if it works then, and then go into bios wit hthe old card, and make sure its set ok, like if theres a setting for "default video: pci-express" or something. yeah, how good is ur psu, maybe its not up to the job? are all the power cables firmly connected?
  4. My PSU is 650W. I changed the BIOS to PCIE. But, it didn't work.
    My motherboard only have 20-pin power + 4-pin connector.
    Should I change my motherboard with 24-pin power + 4-pin connector???
  5. The motherboard ATX connector is not going to affect graphics card support. Any graphics card with its own power connector is going to take most power from its power connector, not the motherboard slot.

    It sounds more like a BIOS bug with the new HD 5xxx cards. There are quite a number of motherboards receiving BIOS updates to fix support issues like this. I would pester ASRock some more.
  6. I bought new system with chipset 785G and installed the Sapphire 5750.
    It worked. My screen didn't blank.
    So, the problem solved.

    Thank you for your advices, Guys !!!!! ;) ;) ;)
Ask a new question

Read More

Motherboards DVI Sapphire