Sign in with
Sign up | Sign in
Your question

This gets complicated, so bear with me

Last response: in Storage
Share
March 14, 2011 1:42:21 AM

Okay, so I have a home built system, a Dual Core E2160 OC'ed to 3.15GHz, 4x1 GB 800MHz OCZ memory, XFX 680i LT MB (FSB at 1400MHz), PC Power & Cooling 750W power supply, and a whole bunch of HDDs. Three Samsung 750GB Spinpoint F1's and a 400GB WD drive.

Originally, this system was running XP Pro. Didn't have any problems, worked great. Then one day, I touched my headphones that were connected to the front audio output and a spark jumped to the frame of the headphones. System sound was gone. Sound drivers were gone. So I RMA'd the motherboard (using on-board sound.) Got the new (refurbished) replacement board and put everything back together. Fired it up, but the sound drivers were still hosed, and I couldn't figure out how to fix the OS so they would work. Ultimately I screwed up a bunch of stuff with this install. It will still boot sometimes, but the sound still doesn't work, and it's become unstable.

So I decided I needed to do a fresh install. At the time, my data files were in the same partition as the system files, so I needed to install to a different drive in order to save my data. Since I had 4 gigs of RAM, I figured I'd go 64-bit for the new install. So I bought a couple of new HDD's (two of the Spinpoints; I was toying with the idea of raiding the disks since the Mobo has an on board RAID chip. No longer interested.) Installed Windows 7 64-bit with little drama.

Now I've got 7 running pretty well, but there are a few remaining things that cause problems.
1. The other original spinpoint HDD. It hangs the system if I try to move large files (like DVD iso files) to or from it. I can't format it because Disk Management says it's in use. It wasn't the previous system drive, but it had the page file, and it may have been the HD 0 when I originally built the system and it had the system page file on it. It's currently been emptied of all data, but remains an unusable 750GB storage block. Any attempt to do a full format on it also fails, even if I force it.
I have since moved it out of the HD 0 socket on the MB, and rebuilt the MBR on the correct hard drive by leaving it unhooked while I booted to the new system drive and repaired with the install disk. The disks all show up as healthy, with no bad sectors, though the current system disk is showing slow spin-up time.

I suspect the system is booting from the old corrupt MBR from the XP install, since that's what 7 does, it uses the oldest version of Windows to boot. My question is, how do I make it stop doing that? Do I need to get an external hard drive enclosure so I can hook up the problem drives after the system boots? I think the weird behavior of the old spinpoint is due to the hidden files/MBR, and I'd like to see if I can completely wipe the disk and see if that helps. Would moving all my data off the old XP system disk and formatting that help? Is that even possible? Disk management won't let me do that either.

Anyway, I was hoping for some input, 'cause I'm running out of ideas and this system is still acting flakey.

Thanks

Update: After scrutinizing the hard drive set up, I've cleared the MBR of the old system drive and verified that the current system drive is defective. Samsung has issued me a replacement RMA. I've created a system image on one of the good storage drives and will be shipping the defective drive to Samsung shortly. Hopefully this fixes my issues, fingers-crossed. Thanks.

More about : complicated bear

a c 302 G Storage
March 15, 2011 4:38:58 PM

If the problem is that it's still using the MBR on an old drive, do this:

Shut down the machine
Unplug the power cord
Push your power button (to discharge capacitors)
Remove the data cable or the power cable from every HDD except the one you installed Win7 on. Leave the DVD drive connected.
Boot to the Win7 installation DVD and choose to Repair the existing installation.

It will see that there is no MBR / boot loader on the drive and make them. Then you can boot directly from that drive.

Shut down again. Re-attach all the drives. Make sure that the drive in question is selected for boot. Boot. Celebrate.
m
0
l
March 16, 2011 1:09:42 PM

Thanks for the reply.

I've done that. The current system drive has a bootloader/MBR sector. One of my many problems, I think, is that I can't get rid of the MBR/bootloader on the old HDDs. So if I hook them up, because it's an older version of windows, those are the files used to load the system. I'm going to try just hooking up the old spinpoint drive, and not the old system drive and see if I can format the drive then.

Also, the new system disk is now acting like it's failing, with a climbing "current pending sector count" and one "Uncorrectable sector". And that makes sense, because it would explain why I was unable to get a RAID 0 array to work. So, I think I'm going to have to get another hard drive, and probably a bunch of new SATA cables just to make sure those aren't contributing to the problem, and an external enclosure so I can hook up the old drives after boot up.

I just hope this isn't all actually due to a faulty drive controller, because I'm tired of messing with this motherboard.

Fingers crossed.
m
0
l
Related resources
!