Sign in with
Sign up | Sign in
Your question
Closed

Black screen flicker when pc is connected to lcd with hdmi cable

Last response: in Graphics & Displays
Share
July 16, 2009 4:14:00 PM

i have a very annoying problem. i have recently bought a 42 inch philips lcd model pfl5604. i wanted to connect it to my pc so i can enjoy the full hd features of the tv. i connected my lenovo sl400 laptop to the tv using hdmi cable and after a while, the screen went black for a second and the picture got back to normal. it happened over and over again. i though that the problem is with the intel 4500 graphic card, that maybe it was to weak to handle the 1920/1080 reslution so i bought a graphic card, sapphire ati radeon hd 4550 512 mb with hdmi connection. i plugged the card to my pc and connected my tv to the graphic card but the problem was still there. i went back to the store and exchanged the graphic card to a Gigabyte ATI RADEON 4650 1 GB card and still the screen went black for a second over and over again. i took my computer to my brother to check with his 52 inch full hd philips tv and there was no problem, no black screens what so ever.
i have xbox 360 and hd cable box connected to the tv with no problem at all. i tried with different cables, all leading to the same result. the funny thing is, that i connected mt tv with a dvi to hdmi cable, and the problem was gone, no black screens. i spoke with the philips support in england, and they couldnt have an answer for me. i thought maybe the problem is with hdpc handshake, but when i checked on the 52 inch philips tv of my brother, there was nothing wrong.
anyone knows what's the problem?
July 20, 2009 10:36:22 PM

Did you try different resolutions, or only 1920x1080? Maybe the refresh rate is wrong, try messing with those resolution and refresh rate settings and see if it clears up.
July 22, 2009 8:57:34 AM

festerovic said:
Did you try different resolutions, or only 1920x1080? Maybe the refresh rate is wrong, try messing with those resolution and refresh rate settings and see if it clears up.


hi, thanks for your reply.
yes, i tried in different resoultions and refresh rates, i tried with different tv's and also on a same model of my tv in another store.
in different tv's there is no problem, only in the model that i have there is a problem.
Related resources
July 22, 2009 4:44:09 PM

So DVI to HDMI works? I know it doesn't carry sound, but can you run the sound to a receiver or an input on the tv that goes with the HDMI port?
July 23, 2009 8:20:13 AM

yes. dvi to hdmi works, i'm afraid i dont have a receiver.
i am in a constant contact with the philips technical support, maybe there is a need to a new firmware update.
in your opinion, could this be a problem of hdcp?
July 23, 2009 7:26:55 PM

I'm no expert on HDCP, but when HDCP fails on tvs in my lab, they don't sync up at all - they are black the whole time, not picture-black-picture-black etc.

I know you really want to use HDMI, but consider VGA, the specs for your tv indicate it has a VGA port, with an associated audio port(red white). Some tvs have better quality when hooking up a computer this way, even though its analog.
July 24, 2009 10:53:39 PM

great news, problem is solved, all the naging to the philips tech support paid off, they released a new firmware update that solved the problem.
July 26, 2009 12:18:12 AM

That's great. I've always wondered: how do you flash the firmware on a TV?
Anonymous
July 29, 2009 5:52:19 PM

mottiyos said:
great news, problem is solved, all the naging to the philips tech support paid off, they released a new firmware update that solved the problem.




Dear Sir,

I've recently bought the 42PFL7404H 42" and i'm having the same issue,

Can you please tell me where can I download the firmware upgrade?


thank you,

regards,

Eliran.
August 3, 2009 4:23:33 AM

hey dude , im experiencing the same problem with my sony 32" bravia ... the black screen shows up only when i play movies on full screen.... some1 any1 plzzz tell me how do i solve this problem !! :( 
Anonymous
October 14, 2009 10:55:38 PM

same problem here but with 20/09/2009 firmware in philips tv, did you get special firmware?

plz help

//Ricky
October 27, 2009 7:23:04 AM

i have this problem with sony bravia klv-46v550a lcd tv !!!!
at the first time it works great but after that when i connect hdmi cable it has black screen on lcd !!!
any one can help me ???
December 9, 2009 4:30:59 AM

I think that HDMI cable may be Hi loss signal or signal from HDMI card low signal. You may be chage HDMI cable to hi grage or hi quality HDMI cable.
December 17, 2009 3:59:27 PM

Hi there

I have a 10 months old 42PFL5630 D/12 and I have the same flickering problem with all HD sources: ps3, dvd with HDMI cable and movie box (External hard drive/multimedia player).

The problem only happens when using HDMI cables, and I have 3 different models (from cheap to expensive). I upgraded the firmware (which in theory fixes the loss of signal with HD sources), and itdid reduce the frequency of the flickering from every 2 minutes to every 5 minutes roughly, but didn't fix it for good.

I contacted Philips who agreed to pick the tv and repair it under warranty. The TV came back with "a new video module" and "fully tested and compliant", according to Philips workshop. Unfortunately, still not resolved. Got PHilips to pick it up again and got phone caññ from a technicain after two weeks who said he couldn't see anything wrong with the tv set, tried a ps3 via hdmi and no signal loss whatsoever. He said he was happy to "replace the motherboard again" (no longer called "video module" this time... go figure) but wanted to run it pass me first.

Either the Phlips technician is lying or being sloppy when testing and doesn't really pay attention, or my 3 HD sources are the problem, which I doubt very much.

I'm now waiting for the TV to cpme back from the second round at the workshop.


Should I upgrade to top of the range HDMI cables, which cost a bomb?
Anonymous
December 17, 2009 8:22:31 PM

notsej said:
hey dude , im experiencing the same problem with my sony 32" bravia ... the black screen shows up only when i play movies on full screen.... some1 any1 plzzz tell me how do i solve this problem !! :( 



I have a Sony Bravia 54" with the same problem. Every so often, a black screen appears for about 1 second, then it comes back. Did you solve this problem?
December 17, 2009 9:56:17 PM

Vic_a, you don't need top of the line cables, but maybe trying a different brand or HDMI spec cable may work. FWIW, I use over 20+ different versions of sony HDTVs, and none of them have this issue as I understand it. And no, I'm not some kind of sony fan.

For those of you that can, I would suggest running in component video mode. So far, the only people having this problem have been using HDMI cable. The picture quality will most likely be the exact same - 1080p is supported by component, too. Just an option.
December 19, 2009 11:48:27 AM

thanks for the tip festerovic, I'll give it a go.
January 19, 2010 5:45:49 PM

my 42PFL5630 D/12 has come back from the repair workshop, but is still suffering from the same random signal loss with any content via HDMI cables. I bought new cables from a different make. I have even bought component cables in 1080p but still, same problem with both with a ps3 and a multimedia player.

My TV has been away 7 weeks in total in the last 2 months, and the problem isn't fixed, unbelievable. But hey, that's life, I won't buy Philips ever again, no biggie. Sometimes you win, sometimes you lose :-
January 25, 2010 11:35:10 AM

I recently upgraded my Sceptre 1080 HDTV to the 120Hz model. Now I have the problem being described. How can I tell if the problem lies with the signal source (cable box), TV, or something else?
January 25, 2010 6:56:02 PM

are you guys that are suffering this problem plugging directly in to the tv, or an in between box such as a A/V receiver or some other switching device?

Also, what kind of media is this problem happening on? As in: blu ray discs, dvds, or other file types ie from the PS3/xbox360/ or a divx player. I have a huge array of TVs and equipment I can try and reproduce this on if I have all the facts.
February 1, 2010 5:21:11 PM

Found the cause of the problem!!!!
Nothing to do with the tv set. The problem is my Motorola cable set-top box. It switches on randomly when left on standby and sends a signal to the tv, which for a fraction of a second tries to change to the SCART input of the box, but then the box switches off and the TV comes back to the previous input it was on... I luckily found this a few days ago, when I noticed the STB switching on by itself. So when I don't use the cable STB, I just unplug it.

Apologies to Philips whose technical support has been faultless, given that they said from the beginning that the TV was faultless.
Anonymous
April 10, 2010 11:26:35 PM

Vic_A said:
Found the cause of the problem!!!!
Nothing to do with the tv set. The problem is my Motorola cable set-top box. It switches on randomly when left on standby and sends a signal to the tv, which for a fraction of a second tries to change to the SCART input of the box, but then the box switches off and the TV comes back to the previous input it was on... I luckily found this a few days ago, when I noticed the STB switching on by itself. So when I don't use the cable STB, I just unplug it.

Apologies to Philips whose technical support has been faultless, given that they said from the beginning that the TV was faultless.



How did you fix this problem?
If it has nothing to do with the TV-set, how is it that the computer tries to change from HDMI interface to Scart?
We have the same problem as above and has no clue what to do, pls help!
Anonymous
April 10, 2010 11:37:34 PM

festerovic said:
are you guys that are suffering this problem plugging directly in to the tv, or an in between box such as a A/V receiver or some other switching device?

Also, what kind of media is this problem happening on? As in: blu ray discs, dvds, or other file types ie from the PS3/xbox360/ or a divx player. I have a huge array of TVs and equipment I can try and reproduce this on if I have all the facts.


Hi!
We have the same problem on our TV, 4PFL563D/12!
Every 5min the screen turns black and the message "no video signal" (Swedish version) turns up, after a second it goes back to normal.
We have connected the TV to a PC via HDMI-cable through NVIDIA Gforce 9400 GT. Operating system is Windows XP Home edition ver.2 service pack 2.

if you can help in any way we will be greatful.



April 25, 2010 4:54:18 PM

Hi Dudes,
I ve got something interesting here.
I bought my Sony LCD KDL40S5500 TV a couple of months ago after a month i bought my PC and connected it with my tele through HDMI cable. I gave me a big grief since then, There are a couple issues with this. The screen keeps on flickering every so often and sometimes i can see a black screen or sometimes a green background ( like i am watching the x-ray image of the screen) and it keeps on flickering once it bring the x-ray and the other time normal screen.
First thing i did is took my computer to get it checked and computer worked fine at the diagnosis stage for 45 mins, even i took my hdmi cable and the tech connected it with someother tv.
After two months of pain i got my motherboard changed and thought it would help ( motherboard has built in HDMI connection and ATI Raedon VGA) u know what..... the problem was still there then rang Sony service centre, they took my tv away and got the motherboard replaced(according to them) the guy who brought the tv back to my home asked me to signed the paper that i ve received it, i told him to hang on or a couple of mins, let me check the tv. i switched on the tv, connected with computer and you know what..... after 2 mins i was looking at an x-ray image. i signed the paper and told him that problem is still there, he took the picture of the screen and promised me that he ll speak to the engineer about it. it was a week ago but i didnt hear from them yet. i ll give them a call tomorrow.....
well, during the time when sony tv was away for repair, i bought a 22" LG tv and it worked 100% fine with my computer no black screen , no x-ray image.
it means, my computer is ok, hdmi cable is working then where is the fault........ may be it doesnt work properly with big screens................................ what do u think?
and yes, i tried at different refresh rates and screen resolutions but result.........same
April 25, 2010 7:45:22 PM

I have no problems when I use the vga going to my sony kdl 40s45100. If you are experiencing the black screen flicker, please try VGA instead of DVI or HDMI.
April 27, 2010 12:04:50 PM

hdmiproblem said:
Hi Dudes,
I ve got something interesting here.
I bought my Sony LCD KDL40S5500 TV a couple of months ago after a month i bought my PC and connected it with my tele through HDMI cable. I gave me a big grief since then, There are a couple issues with this. The screen keeps on flickering every so often and sometimes i can see a black screen or sometimes a green background ( like i am watching the x-ray image of the screen) and it keeps on flickering once it bring the x-ray and the other time normal screen.
First thing i did is took my computer to get it checked and computer worked fine at the diagnosis stage for 45 mins, even i took my hdmi cable and the tech connected it with someother tv.
After two months of pain i got my motherboard changed and thought it would help ( motherboard has built in HDMI connection and ATI Raedon VGA) u know what..... the problem was still there then rang Sony service centre, they took my tv away and got the motherboard replaced(according to them) the guy who brought the tv back to my home asked me to signed the paper that i ve received it, i told him to hang on or a couple of mins, let me check the tv. i switched on the tv, connected with computer and you know what..... after 2 mins i was looking at an x-ray image. i signed the paper and told him that problem is still there, he took the picture of the screen and promised me that he ll speak to the engineer about it. it was a week ago but i didnt hear from them yet. i ll give them a call tomorrow.....
well, during the time when sony tv was away for repair, i bought a 22" LG tv and it worked 100% fine with my computer no black screen , no x-ray image.
it means, my computer is ok, hdmi cable is working then where is the fault........ may be it doesnt work properly with big screens................................ what do u think?
and yes, i tried at different refresh rates and screen resolutions but result.........same


mate i am having exactly the same problem. i bought a new pc (i7 980 cpu, ati 5970, asus premium...) and i coonected it to a 40" philips 9704 (one of the best 40 inches out there) and every now and then the screen blinks and comes back just like you said as an xray (shade of blue or pink). it either goes back to normal, or i have to flip channels and it s all ok again.

im dying to know the cause, been 3 weeks now and im investigating. i tried another tv set and i had no problems and still at the same time, my philips after checking it separately is ok (sent it to a repair guy who played a dvd on it without any problems).

so i know its not a hardware related issue, some mismatch or incompatibility somewhere between the tv and pc.

please let me know if you found a solution.

thanks,
Anonymous
July 4, 2010 2:57:37 PM

abbalinos said:
and every now and then the screen blinks and comes back just like you said as an xray (shade of blue or pink). it either goes back to normal, or i have to flip channels and it s all ok again.,


Had the same problem, for some reason Windows 7 detected the TV and set the refresh rate to 59Hz. The Bravia I have (40EX401) only supports 60Hz. So after a while the colour channels will go out of sync and you get the pink.

I have forced the refresh rate to 60Hz and haven't seen the pink since.

Good luck,

D.
July 4, 2010 3:06:24 PM

This topic has been closed by Mousemonkey
!