Sign in with
Sign up | Sign in
Your question
Solved

Primary HDD became an "unallocated" disk.

Last response: in Storage
Share
March 15, 2011 7:41:29 AM

I had an old IDE HDD fail on me so I trialled some software to see if I could still navigate the filesystem on it (Windows wouldn't let me access the drive at all - "Data Error [Cyclic Redundancy Check]"). That's not my main concern anymore however.

At some point I managed to wipe my primary OS hdd. I only noticed when I was on a Linux LiveCD, that the drive had become "931.51 GB of Unallocated" space. No idea how or when. I can't have accidentally done a secure wipe of the disk so I thought it would be easy enough to undelete. Not so.

Recovery scans take hours. I was hoping I could be able to use testdisk to undelete the full volume, but testdisk can't find any windows partitions. It found a 3GB Linux partition but I never had linux installed on the drive...

I've tried running these programs:

Pareto Data Recovery
EASEUS DATA recovery
Recover My Files
BootDiskSuite
DiskPatch
HP USB Disk storage format
BootMaster
testdisk ✰
Partition Find and Mount ✰
Runtime GetDataBack ✰

They all appear to show different results. I have another 1TB HDD which I can copy an image to if necessary.

My IDE HDD was my main photo storage, the 1TB was backup. Both are gone. Oops...
a b G Storage
March 15, 2011 1:25:13 PM

As a photographer, I feel for you. GetDataBack is a great little program and usually works. You can use microsoft's WINTERNALS recovery CD to help recover partition information. This is a very helpful tool.

http://www.geekstogo.com/2009/01/17/erd-commander-free-...


Note in WINTERNALS (ie ERD Commander) run Disk Commander and do a search for lost volumes.

Hope that helps!
m
0
l
a b G Storage
March 15, 2011 2:13:25 PM

Your old IDE may be recoverable first step would be to try and take an image of it.

For your other disk google "data carving" it's a raw data recovery technique. Photorec (a companion to Testdisk) is the first thing I would try.
m
0
l
Related resources
March 15, 2011 9:45:21 PM

Thanks I'll check out ERD too.

I'm running Photorec. It will take about a day to get my photos off and onto an external. In one big mess of a folder. There's so many dupes; it must be finding the shadow copies.
m
0
l
a b G Storage
March 16, 2011 12:12:12 AM

Yes Photorec can not recover filenames or folder structures and you will get a lot of partial files.

One other to try is http://findandmount.com/
m
0
l
March 16, 2011 5:15:42 AM

Thanks, I'll try that too! Don't all applications would use the same methods for recovery? I'd be surprised if I had any success at this point.

Photorec has 12 hours left. Edit: That's a bad estimation. It's now at 9 hours, 6 hours later.
m
0
l
a b G Storage
March 16, 2011 1:42:54 PM

Not all tools use the same methodology. The Winternals tool works very well at recovering partition information.
m
0
l

Best solution

March 16, 2011 9:30:35 PM

'Partition Find and Mount' instantly found the cause of the problem. Others worked too, but this made the most plausible cause more apparent.



Partiton F&M is able to mount the recovered partition which shows it labelled as DISKPATCH and the volume contains DP.EXE and 'Recycle Bin'.

Here is the DiskPatch 'Boot Media Builder'



None of the options were useful to me because I didn't have a diskette, the Boot CD didn't load, and the extracting option only copies the program files to a new location. Plus it was a trial so it's supposed to be harmless. The only step which must have caused the problem is when I tried creating a bootable USB using this guide. This should not have been able to do it either however because it includes the 'HP USB key formatter' which shouldn't be able to format a SATA drive.

I can see the correct file structure using GetDataBack, but it doesn't have the virtual mounting feature or any easy way to quickly reverse the damage that has been done. ReclaiMe just as well if not better in some ways. Both software recovered the same files, and showed the same damaged files.

There must be more to the problem though. In theory only a few KB worth of files should be corrupt. Instead, about 5% of my photos are damaged throughout the whole HDD...

Side-note: You can convert unallocated space to an unformatted RAW drive, safely if that helps at any stage.
Share
a b G Storage
March 16, 2011 9:45:27 PM

Best answer selected by CompTIA_rep.
m
0
l
a b G Storage
March 16, 2011 11:37:16 PM

Glad findandmount worked for you. And thanks for the explaning the problem it makes sense now.

I would have thought Testdisk would have fixed this as well but I guess not.
m
0
l
!