Sign in with
Sign up | Sign in
Your question

New SSD Question, Please Help!

Last response: in Storage
Share
March 15, 2011 5:52:32 PM

I just an ssd and installed Windows 7. When I go into the Bios it says my old hdd is sata and the ssd in using ide controllers. How do I get the ssd to show sata?

More about : ssd question

March 15, 2011 6:26:27 PM

Also, I am only getting a writing speed of 158 and it is suppose to get to 250. Any suggestions?
m
0
l
a b $ Windows 7
a c 305 G Storage
March 15, 2011 7:22:27 PM

My best guess is that either your motherboard lets you set AHCI / IDE mode on a port-by-port basis, or that it has two controllers and you put one of the drives on the other controller.

First, what model of motherboard do you have and which SATA ports are the two drives plugged into?

Second, can you go into BIOS and change the mode on that port as a TEST ONLY. Don't leave it in BIOS mode, you won't be able to reboot.

Third, there's a registry hack floating around that will let you tell Win7 that you really need it to to talk to an AHCI-mode controller; this courtesy of tecmo34. Then you change the mode, reboot, and you are done.

Fourth, if the PC originally booted off the old HDD, and the HDD was attached to the motherboard when you installed Win7 on the SSD, you are actually booting from the HDD and the boot menu is passing control to the OS partition on the SSD. If this bothers you, once all the other issues are resolved, disconnect the HDD, boot to the Win7 DVD, and choose to Repair the installation on the SSD.

Let us know how things go.
m
0
l
March 15, 2011 7:59:12 PM

I think it is an error in the bios. AMD overdirve shows it listed as a SATA and it shoes AHCI drivers. For some reason or another the bios still shows IDE. It is weirding me out. The SSD drive is connected to the 1 SATA slot and the HDD is connected ot the 3 SATA slot. I had it disconnected when I added the SDD. I read somewhere to do that so I did. The MOBO is a Biostar 890FXE. Thanks for the reply.
m
0
l
!