Sign in with
Sign up | Sign in
Your question

Samsung HD204UI firmware udpate help

Last response: in Storage
Share
March 15, 2011 11:47:47 PM

I recently got a 2tb Samsung HD204UI and I could really use help making a bootable cd or usb thumb drive in order to run the firmware update. I've spent a few hours trying various things and I'm just not getting it at all. The samsung website provides me with a zip file (http://www.samsung.com/global/business/hdd/faqView.do?b...) that contains an .exe file and instructs me to create a bootable cd or usb drive in order to run it. I've tried tinkering with nero/ultrasio/magiciso and I Just can't seem to get it. From all the reading i've done, i'm assuming i have to take the .exe file then somehow make that into a bootable iso file - i've made it into a regular iso file but not bootable - and then create a bootable usb drive with it. But i really can't get past the first step - if that is even the route to go. What do i need to do? What programs do I need? Any help would be appreciated or even a link with pictures of a step by step guide. Thanks in Advance.
March 16, 2011 11:30:10 AM

not sure this tells me how to go from an .exe file to bootbale iso. i've made a bootable USB pendrive in the past for a ubuntu live install, i got that part. but where do i begin as far as getting that .exe onto the pen is concerned.
m
0
l
Related resources
March 18, 2011 7:34:24 PM

Whoops. I have the exact same question, for the exact same drive. I wish I had noticed your thread before I cluttered up the forum with one of my own.

Here's hoping someone can give us an answer...
m
0
l
a c 288 G Storage
March 19, 2011 5:03:15 AM

There is no need to create a CD ISO.

Create the bootable USB flash drive, then unZIP the contents of the ZIP file to the root directory of your USB drive.

Reboot from the USB drive and type "FAEG" at the DOS prompt.

BTW, the BIOS must be temporarily reconfigured for legacy IDE mode, not SATA mode.
m
0
l
March 31, 2011 5:35:13 AM

I'm having an issue. I managed to get into the SFLASH menu via bootable CD but I don't see it flashing the firmware.

Searching shows that most people just typed in the "F4EG" and the program installed it. All I get is a menu. Do I have to type a specific command? A scan shows the hard drive is port 2. Thanks.

http://img.photobucket.com/albums/v234/Wiznaz/611e96e2....
m
0
l
a c 288 G Storage
March 31, 2011 6:28:15 AM

Type "DIR". Do you see any .bat files?

Have you tried typing "FAEG" instead of "X:\FAEG"?
m
0
l
April 1, 2011 5:00:22 PM

^ Has anyone seen this before? I would like to update the firmware.
m
0
l
a c 288 G Storage
April 1, 2011 9:27:39 PM

Type the following:

DIR X:\*.bat /S /P
DIR X:\*.exe /S /P

What do you see?
m
0
l
a c 288 G Storage
April 2, 2011 4:54:30 AM

Thanks for the feedback. I wasn't sure whether X: was the drive letter of a RAM drive. For example, Seagate's CD based firmware updaters create a RAM drive and then extract the firmware files to this RAM drive. I was wondering whether F4EG.EXE (not FAEG -- sorry) operated the same way.

I notice that Samsung's instructions say to "connect Target HDD to Primary / Master". Instead you say that your drive is connected to port 2. Is this SATA port 2 or IDE port 2?

Have you configured your SATA controller for "compatibility" mode in your BIOS setup? This will make your drive look like a PATA drive, not SATA. Samsung's updater is looking for a PATA drive.
m
0
l
April 2, 2011 6:57:09 AM

It's connected to the 2nd SATA port on the mobo but I say it is port #2 also because I did a scan in SFLASH and that's what it revealed. I did go into BIOS and change it to compatibility mode.
m
0
l
a c 288 G Storage
April 2, 2011 9:18:12 AM

FWIW, here is a Dell update for older Samsung models:
http://ftp.us.dell.com/ide/R139989.EXE

It uses an earlier version of SFLASH. The command line to update the firmware is ...

sflash24 /run:1107.est /auto

In your case I would try ...

F4EG /AUTO

I'd disconnect all other drives just to be safe.
m
0
l
a c 288 G Storage
April 2, 2011 11:07:52 PM

It appears that F4EG is hard coded to update the primary master IDE drive.

AISI, you need to swap the positions of your two drives.

At the moment the WD drive is the primary master (I/O port 0x1F0, IRQ14), and the Samsung is the secondary master (I/O port 0x170, IRQ15).
m
0
l
a c 288 G Storage
April 3, 2011 4:26:12 AM

Your screen shot shows that you used the AUTO switch.

Did you try it with just a plain F4EG command?
m
0
l
a c 288 G Storage
April 3, 2011 6:14:59 AM

Now the I/O port is 0x9000 instead of 0x1F0. Check that BIOS is still set for compatibility mode.
m
0
l
April 3, 2011 5:55:29 PM

It finally worked! Thank you, fzabkar!

After several attempts of trying this, I was able to re-flash successfully. I made sure:

-All USB flash drives were disconnected
-No other HDDs were connected except the Samsung
-The Samsung drive was plugged into 'SATA1' on the mobo
-The SATA configuration was set to 'Compatible' in the BIOS

This time the FREEDOS boot menu was actually a little different for me while getting to command prompt than what I was given during the unsuccessful attempts. I knew something was up when I didn't get the usual 'X:\FREEDOS' in command prompt either; all that was there was a 'X:\'. I just typed 'F4EG' and hit Enter and watched it successfully do it's thing. Here is a screen shot:

http://img.photobucket.com/albums/v234/Wiznaz/a3b64981....

http://img.photobucket.com/albums/v234/Wiznaz/20f9063f....
http://img.photobucket.com/albums/v234/Wiznaz/884bbc87....

Thanks,
Mike
m
0
l
April 12, 2011 10:56:32 AM

It only need to unplug USB-flash :)  I just re-flash my HD204UI in AHCI-mode on SATA-4 with 5 HDDs connected to MB.
m
0
l
!